Download Realtek HD Audio 2.80 driver

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Dec 5, 2016.

  1. Reddoguk

    Reddoguk Ancient Guru

    Messages:
    2,323
    Likes Received:
    346
    GPU:
    RTX3090 GB GamingOC
    Never had any issue installing new Realtek sound drivers. Only issue i've had is terrible website download speeds and yea 2.80 failed to install any visible Audio Manager which was a quick fix by running it manually which magically made the manager appear in Control Panel.
     
  2. Han2K

    Han2K Master Guru

    Messages:
    278
    Likes Received:
    1
    GPU:
    MSI GTX1080 GX
    What to do if you have realtek audio/codec:
    1.Go to BIOS.
    2. Set Integrated Devices -> HD Audio -> Disabled.
    3. Buy a discrete sound card.
     
  3. schmidtbag

    schmidtbag Ancient Guru

    Messages:
    6,484
    Likes Received:
    2,832
    GPU:
    HIS R9 290
    Better option:
    1. Uninstall the crapware Realtek offers and just install the bare essential drivers.
    2. Get an external receiver based on SPDIF
    3. Use the SPDIF output

    Or:
    1. Get an external receiver that works with HDMI audio
    2. Use HDMI output


    With an external receiver, even the crappiest chipsets will be good enough. Discrete sound cards are only worth it if you use analog headphones.
     
  4. Dorel

    Dorel Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    AMD HD7900
    Realtek High Definition Audio Drivers R2.81 is released, Driver version: 6.0.1.8036
     

  5. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    43,761
    Likes Received:
    10,928
    GPU:
    AMD | NVIDIA
    Thanks I'll mirror the new binaries onto our download servers.
     
  6. marcolau

    marcolau Member

    Messages:
    14
    Likes Received:
    6
    GPU:
    gtx 980 4gb
    Has this one fixed the 5.1 issue ....................finally ( rear speakers not working since win 8 was out ) ?
     
  7. WareTernal

    WareTernal Master Guru

    Messages:
    255
    Likes Received:
    42
    GPU:
    PNY RTX 3070
    As other have said, I've never seen an issue with Realtek audio drivers. Compared to AMD or Nvidia, Realtek is always 100% rock solid. When I hear about bad Realtek audio drivers I automatically know it's "operator error".
     
  8. zasy99

    zasy99 Member

    Messages:
    15
    Likes Received:
    2
    GPU:
    AMD 390x
    For those with the ALC1150 chipset like I have on my Asus Maximus VII Hero I just downloaded and installed these drivers (due to the reports here saying the drivers linked in the original post did not contain ALC1150 compatible drivers).

    http://www.pcgameshardware.de/Sound-Hardware-217390/Downloads/Realtek-HD-Audio-Treiber-Download-1044438/
    "Realtek HD-Audio-Treiber R2.81 (Windows Vista/7/8/10, 64 Bit)[207,4 MB]"

    In device manager I went to "Sound, video and game controllers" and uninstalled the "Realtek High Definition Audio" device and restarted Win10.

    I extracted the above package with 7zip and ran the setup (you could probably just run the downloaded exe, I like to see whats in the package first), it installed the drivers, another restart and all is working fine.

    Image showing driver info after installation.
    http://prnt.sc/dvkrap
     
    Last edited: Jan 14, 2017
  9. dragonlord

    dragonlord Member Guru

    Messages:
    185
    Likes Received:
    43
    GPU:
    Nvidia Beta Tester
    The drivers gave WinAmp a hiccup for me. The Directsound Output driver came back with a No Device Found error. Manually switching the output to Wave works as well as going into the Directsound output module and switching from Primary Sound Driver to Realtek.

    This is with SPDIF out BTW if that helps.

    So far there have been no problems with movies, video players, games, etc.
     
  10. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    11,063
    Likes Received:
    4,753
    GPU:
    ASUS RX 470 Strix
    What version of Winamp are you using? I am using "Winamp v5.55 - 10th Anniversary Edition"... it's my favorite haha//

    ohh.. spdif, I'm not using that..

    Before installing these new Realtek drivers I uninstalled the previous through Windows Device Manager, then did a driver clean of the old ones using Driver Fusion by Treexy "in safe mode", then a registry clean with ccleaner, then installed the new ones.

    ps.... these drivers are THICC

    [​IMG]
     
    Last edited: Jan 15, 2017

  11. Irenicus

    Irenicus Master Guru

    Messages:
    583
    Likes Received:
    100
    GPU:
    1070Ti OC
    Still using the unlocked ones that allow DTSi and DDL...I see no need to upgrade at all. If anything it will probably break things.
     
  12. Irenicus

    Irenicus Master Guru

    Messages:
    583
    Likes Received:
    100
    GPU:
    1070Ti OC
    Eh? That's not been an issue at all, that's something you're doing wrong on your end, your hardware or outputs, receiver or whatever. I've always had full 5.1 in every OS since WinXp

    it's just you. Never had an issue. And windows 10 actually installs....wait for it.....REALTEK DRIVERS! lol

    Nothing wrong with their drivers, apart from locking out certain features which the hardware is capable of, like DDL etc...but that's easily negated with unlocked drivers.
     
  13. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,778
    Likes Received:
    1,111
    GPU:
    EVGA 1070Ti Black
    I been using the 7614 that I unlocked and will continue to do so if it anit broke dont change it, especially when it comes to realtek and there questionable drivers
     
  14. Irenicus

    Irenicus Master Guru

    Messages:
    583
    Likes Received:
    100
    GPU:
    1070Ti OC
    Nothing questionable about them except for not allowing us access to certain features unless we have a certain mobo, despite the hardware being capable. Other than that. I've never had an issue. Just always make sure to not let the Realtek Audio thingy run on startup as it doesn't do anything at all and is not required for fucntionality
     
  15. dragonlord

    dragonlord Member Guru

    Messages:
    185
    Likes Received:
    43
    GPU:
    Nvidia Beta Tester
    v5.66

    DS output v 2.63 (d)

    hardware acceleration enabled just like yours

    Since you aren't using SPDIF out, I'll assume this is related to that difference until someone pipes up with more info.

    Thanks. :)
     

  16. ektoradsj

    ektoradsj Member

    Messages:
    36
    Likes Received:
    17
    GPU:
    RX 580 8GB XFX
    Hi guys i have alc 892(msi-z77a-g45) and in realtek hd audio manager it shows alc0 .With previous drivers everything was showing up normal.Anyone has something similar?
     
  17. DLD

    DLD Master Guru

    Messages:
    887
    Likes Received:
    71
    GPU:
    MSI GTX1060 6GB
    For those who experience "error problems" during installation (especially in Win 10 64bit):

    -thoroughly and completly uninstall the previous driver: 1. regular procedure, 2. driver sweeper, 3. reboot
    -do NOT try to install the driver by launching "xxxxR281.exe". Extract it to some temp folder using 7ZIP or WinRAR or a similar tool.

    I repeat: do NOT run that xxxxxxR281.exe, but rather extract all FILES and folder(s) that are contained within (this xxxxR281.exe is actually a compressed self-executive chain of files + a folder). So, extract all the files (and the folder) into the aforementioned temp. Browse the extracted files until you locate the "setup.exe". Run it. That's it.
     
    Last edited: Jan 15, 2017
  18. grimmute

    grimmute Member

    Messages:
    13
    Likes Received:
    3
    GPU:
    SAPPHIRE RX590 8G
    I'm having the same "problem" with my ALC892 too. Everything seems to work fine though.
     
  19. gopher04

    gopher04 Master Guru

    Messages:
    207
    Likes Received:
    12
    GPU:
    EVGA GTX780 Classified
    So they release a new driver, yet their web page has been down for 2 weeks now.
     
  20. SHS

    SHS Master Guru

    Messages:
    494
    Likes Received:
    44
    GPU:
    Sapphire Vega 56
    Mine is listed right as I have ALC898

    I know it very odd
     
    Last edited: Jul 1, 2017

Share This Page