Download: Radeon Software Adrenalin 2020 Edition 20.4.1 drivers

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Hilbert Hagedoorn, Apr 2, 2020.

  1. Agonist

    Agonist Ancient Guru

    Messages:
    3,113
    Likes Received:
    383
    GPU:
    XFX 5700XT Raw II
    I am doing everything clean. No importing any settings. Its better using Dec 2019 drivers before the 2020 ones. And I still have an issue here and there. But dramitically better. And I am using a AMD referance card as well.
     
  2. PrEzi

    PrEzi Master Guru

    Messages:
    660
    Likes Received:
    529
    GPU:
    AMD 6900XT
    Try the 19.12.1 driver (this exact version as it´s the last pre-2020) and report back if the issue still persists.
     
  3. Dekaohtoura

    Dekaohtoura Master Guru

    Messages:
    334
    Likes Received:
    44
    GPU:
    Sapphire V56 Pulse
    Weird, I've only had problems with the first "2020" release, for some reason it wouldn't install properly.

    After this, only 20.2.1 seemed to not work as it should (FSync related problems) and the occasional restore settings trial&error.

    Anyway, if 19.12.1 works best for you, stick with em and hope for a new problem-free release.
     
  4. chispy

    chispy Ancient Guru

    Messages:
    8,985
    Likes Received:
    1,216
    GPU:
    RX 6900xt / RTX3090
    Thank you for trying to help , i already did tried that driver ,as a matter of fact i spent 3 days testing every single driver since this video card was released and in all the them i have the same issue , also i tested this same video card on 3 different pc and it did the same. At this point everything points out to hardware failure / doa video card. It has been 4 working days since i submited a ticket to xfx and no answer so far back to me , i'm still waiting for xfx n.America to respond.
     

  5. PrEzi

    PrEzi Master Guru

    Messages:
    660
    Likes Received:
    529
    GPU:
    AMD 6900XT
    Hmm.... it indeed seems to indicate some HW issues. You have tried to find a matching updated BIOS to your card at TPU?
     
  6. The_Amazing_X

    The_Amazing_X Master Guru

    Messages:
    619
    Likes Received:
    211
    GPU:
    Red Devil V64
    I have an issue on Breakpoint, when I turn on HBCC the game will crash, it only crashes if it goes over 8g vram, on the amd Log it says it was fixed but I think the issue its still there.

    Vega 64 Red devil here
     
  7. TUMIK

    TUMIK Active Member

    Messages:
    69
    Likes Received:
    33
    GPU:
    RX470
  8. Chastity

    Chastity Ancient Guru

    Messages:
    2,710
    Likes Received:
    902
    GPU:
    Nitro 5700 XT
    Jackalito and Passus like this.
  9. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,445
    Likes Received:
    2,813
    GPU:
    MSI 6800 "Vanilla"
  10. ThatBusch

    ThatBusch Member

    Messages:
    29
    Likes Received:
    3
    GPU:
    ASRock RX 5700
    Hopefully with a fix to the stuttering issues with some games.
     

  11. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,445
    Likes Received:
    2,813
    GPU:
    MSI 6800 "Vanilla"
    Out now. :)

     
    Agonist and Jackalito like this.
  12. Agonist

    Agonist Ancient Guru

    Messages:
    3,113
    Likes Received:
    383
    GPU:
    XFX 5700XT Raw II
    See alot fixed.
    Just slapped an AIO 120mm on my Vega 56. Man, what a difference. Still on the older driver, but the noise reduction and clocks staying at 1500+ are surely nice.
    Maybe I will update to this driver and try it out.
     
  13. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,331
    Likes Received:
    809
    GPU:
    Gigabyte 3060 Ti
    20.4.2 is out.
     
  14. Agonist

    Agonist Ancient Guru

    Messages:
    3,113
    Likes Received:
    383
    GPU:
    XFX 5700XT Raw II
    I sure as hell hope it fixes issues. Because I had to black screen crashes with enhancing off and even three blue screens. On the newest driver with a clean install and everything else works perfect and my Vega works perfect and other people's rates. I'm on my third freaking set up in 3rd power supply. And a new install of Windows. I've even ran DisplayPort cable HDMI cable and even turned off freesync. I'm literally about to say screw AMD. Gpus right now. And I have never done that before
     

Share This Page