Download: Radeon Software Adrenalin 2020 Edition 20.4.1 drivers

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Hilbert Hagedoorn, Apr 2, 2020.

  1. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,562
    Likes Received:
    2,958
    GPU:
    MSI 6800 "Ref"
    https://www.amd.com/en/support/kb/release-notes/rn-rad-win-ryzen-mobile-4000

    AMD Ryzen (Laptop) 4000 series integrated GPU drivers.
    Curiously these are versioned at 27.20.1001.4001 whereas 20.4.1 is at 26.20.15029.20013 which I believe means they're WDDM 2.7 compliant.

    EDIT: Won't reveal too much but I wonder if I can dump the profile on these just to see if anything is different here on this branch of the drivers.
    (20.4.1 seems to be dated April 1st and these are dated April 3rd from what it's looking like.)


    EDIT: Internally this is 20.10.01.04_20200323_1329 compared to 19.50.29.20_20200401_1515 though the version number probably doesn't say too much.

    DSE Manager .exe and the DOP Engine .dll files are gone even though the driver supports both DCH (U*.inf) and the standard (C*.inf) install method so that's interesting as well but could be just because it's not used on the cards this is intended for and it could still be part of the desktop driver suite.


    EDIT: Bunch of new flags for OpenGL but the names aren't very easily identifiable though one could be related to NGG or Next Gen Geometry.

    Ones applied to a test profile another one is applied to Unigine and the final one for NGG is applied to a "Vred" profile.


    Profiles from 20.3.1 and the newest don't seem to be part of this driver.
    But it's mainly HighPerfGPUAffinity flags.

    So not much to see from that comparison at least, it's a newer branch but that's already clear from the version numbers used.
     
    Last edited: Apr 7, 2020
    Krteq, OnnA and PrEzi like this.
  2. Krteq

    Krteq Master Guru

    Messages:
    924
    Likes Received:
    545
    GPU:
    RX Vega 56 +64 BIOS
    Yes, MicroSoft's versioning of drivers is pretty clear for some time. First 2 digits representing WDDM revision
     
  3. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    3,332
    Likes Received:
    696
    GPU:
    Nitro 5700 XT
    good to know
     
  4. PrEzi

    PrEzi Master Guru

    Messages:
    714
    Likes Received:
    579
    GPU:
    AMD 6900XT
    Guys.... related to my earlier findings -- black screens with Vega64 when watching YT I've recommended to lock in the P1 state and set the voltage for the GPU +10mV higher.
    This was kinda workaround that solved it for me. Now I've found a better solution (thermals etc.).
    Just set +12mV in the MSI afterburner and check if it bumps the VDDC by 0.01 in GPU-Z monitor.
    That way I have lower temperatures and correct idle clocks. Causes marginally higher power draw but it is by far better solution than locking onto P1 state as minimum.


    UPDATE : scratch that...... just got a black screen when applying only the additional mV to GPU in idle.... So for me locking to P1 as minimum is the only viable option for now....
    I don't know.... maybe it is related to too low idle clocks.... be it GPU or MEM.... or both....
     
    Last edited: Apr 9, 2020

  5. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    498
    Likes Received:
    37
    GPU:
    Sapphire 5700 XT N+
  6. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,628
    Likes Received:
    939
    GPU:
    Gigabyte 3060 Ti
    Anyone tried the new Warzone update with 20.4.1?!

    Let me know!
     
  7. UkOldGit

    UkOldGit Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 5700 XT
    Freesync on or off makes no difference. I only have two options turned on, image sharpening and surface optimization, with these on or off makes no difference to the screen corruption when starting MW in fullscreen mode.
     
  8. gabsvm

    gabsvm Member Guru

    Messages:
    146
    Likes Received:
    26
    GPU:
    RX 580 8gb
    Is possible to experience a less fluid experince after i upgraded to 1909 from 1809? Is a clean install. Games dont stutter but they feel weird.
     
  9. Lipici

    Lipici Member

    Messages:
    48
    Likes Received:
    13
    GPU:
    580
    Getting out of monitor standby with previous drivers was instant, 1 second.
    Getting out of monitor standby with 20.4.1 i get borred , 6 seconds.

    On DP.
     
  10. FR4GGL3

    FR4GGL3 Active Member

    Messages:
    93
    Likes Received:
    34
    GPU:
    GB 3080 Gaming OC
    @PrEzi what do you exactly do to get the blackscreen? I also have a Vega 64 LC and haven't had a blackscreen for a long time. But I would try to reproduce your issues, if that might help.
     

  11. Max

    Max Member

    Messages:
    22
    Likes Received:
    7
    GPU:
    R9 390X
    Fps dropped by ~10% for me, but i think its update issue. Airplane scene for example - min 40 fps before, 36 now
     
    LocoDiceGR likes this.
  12. PrEzi

    PrEzi Master Guru

    Messages:
    714
    Likes Received:
    579
    GPU:
    AMD 6900XT
    What BIOS Version do you have on your card? I have the latest possible I could get on TechpowerUP (016.001.001.000.008774) but on the other hand -- I also have it since over a year now... And when I revert to 19.12.1 everything is back to normal.......

    And what do I do to trigger them?
    Nothing special --- have 2020 drivers installed, Windows 10 1909 with all the latest updates, Freesync on + stock settings everywhere (except Anti Lag on and Fluid motion on in the video settings) and no OC.
    All the OC and/or monitoring Software not running in the Background. HDR currently disabled as this causes some issues with The Division 2 and latest 20.4.1 drivers.

    Then the Black screens started to happen starting with 2020 drivers and when using Opera Developer build or Vivaldi Stable (both Chromium based web browsers) to watch YT videos. Doesn't matter if the HW acceleration in the browsers is on or off (including the hidden browser flags).
    Problem is - it is not easily reproducible.... sometimes it can run for a few days without any issues, and sometimes I got 2-3 black screens a day. I already did try everything including playing with advanced overrides, under Display (Voltage HDCP etc.). I have also noticed that it is more common when watching several videos in a row and also in full screen.

    Then the screen goes black, keyboard freezes (doesn't react to caps lock), but the sound is still coming out normally for like 7-10 seconds. Then it freezes too and only a hard reset helps.
     
    Last edited: Apr 10, 2020
  13. Max

    Max Member

    Messages:
    22
    Likes Received:
    7
    GPU:
    R9 390X
    Experiencing exact same issue for all time having 390x since 17.xx prolly. I can use my pc 24/7 several days with no issues, but some day watching youtube/twitch or just browsing - my screen goes black. I tried reflash bios with some voltage tweaks / increasing idle memory/core clocks but still nothing. The only moment that I have never used windows 7 or 8.1 with this card, I guess its a windows 10 issue in particular but I can't prove it OR it's just my old PSU is pulsing and can't handle stable 12v. What psu do you have btw?
     
  14. PrEzi

    PrEzi Master Guru

    Messages:
    714
    Likes Received:
    579
    GPU:
    AMD 6900XT
    I have an Corsair AX1200i and I have proven my TRX40 Workstation to be stable for 24/7 under full load on every component, so you can count out the PSU issue with me.... Besides - with 19.12.1 or earlier it was black screen free. Reverting back fixes that too... but then I am loosing the new features and optimizations.

    The only viable "fix" or rather a workaround is to lock to P1 state as minimum with 852/810mV resulting in 850 GPU / 800 mem clocks, higher power draw and temps in idle.
    But it solves the black screens completely.

    Wish I could just be able to tune the idle behavior and rise the gpu and memory clocks a little...
     
    Last edited: Apr 10, 2020
  15. FR4GGL3

    FR4GGL3 Active Member

    Messages:
    93
    Likes Received:
    34
    GPU:
    GB 3080 Gaming OC
    My LC is a PowerColor (if that matters) BIOS Version is also 016.001.001.000.008774. It was shipped with that BIOS.
    I also use Win 10 1909 along with the latest Updates. I also do use Freesync.
    On Desktop I use the Radeon "Standard Setting" (no Image Sharpening). I NEVER use Anti Lag as this gave me rather more lag then less. And I don't use GPU scaling anymore.
    I lowered the Voltages of the Vega a notch and made a custom Fan Curve (raised rpm as the Water gets too hot).
    And maybe the most important difference: I use an Intel Platform (Gigabyte Z390 with a 9900K which is undervolted a bit but tested rockstable on everything I found so far).

    Are you shure that the Hotspot Temperature of your Vega is okay? I had Blackscreens and even Reboots in the past. I RMAed my old Seasonic 850W PSU. I now have a SuperFlower Leadex III 850W.
    I also found out, that my Card doesn't like upping the Power Level since 2020 Drivers. The Hotspot raises insanely by upping it. As long as I keep the Power Level at 0% everything is nice and cool and stable. Since then no more Black Screens and no more Reboots.

    I didn't use Opera or Vivaldi so far. But I will give them a try. Do you have to watch YouTube the whole day long or could it be that the screen goes black as soon as you startup a Video?
     

  16. PrEzi

    PrEzi Master Guru

    Messages:
    714
    Likes Received:
    579
    GPU:
    AMD 6900XT

    Temperatures were the first thing I have checked and they are in a perfect area not exceeding 70 degrees under load (also a custom fan curve). And the Black Screens happen not in 3D but in 2D (videos) where the card is idling at or below 40 degrees. Power level stock, my PSU is a Corsair AX1200i and the whole system is perfectly stable except the black screens. Did several hours of different torture tests including memory (needed a little bit of tuning to get it perfectly stable since I have all the 8 banks populated with 128GB total and DDR4 @3200.)

    No it is not enough to start a video. Sometimes it happens fast sometimes it happens after several hours or days. You can have stops in between watching the videos... Like I've said -- sometimes it happens after a few hours, sometimes after two or three days....
    Oh and it might matter that I never turn my PC off, running 24/7. Just turning off my C49RG90 monitor.

    As a last resort I might try to revert to the older BIOS for the card...
     
  17. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    3,332
    Likes Received:
    696
    GPU:
    Nitro 5700 XT
    I recall a time that some were having problems updating drivers after several months using a different bios (a bios other then what came with the card). Although the card did work (provided a higher OC, etc) everything would work for a few months. Then all of a sudden started having issues with the latest driver, at the time.

    Come to find out when reverted back to the original driver (which they had a backup for) they could update the drivers. Come to think of it I also recall that some bios was intended for a stealth update of the same make/model card and wasn't for that card. It was then I stopped doing that myself and haven't looked back since.
     
  18. Paul L

    Paul L Maha Guru

    Messages:
    1,146
    Likes Received:
    10
    GPU:
    AMD 5700 8gb
    All better soo far, had one green flash on screen soon after reboot. seems solid so far :)
    Much more to test. :)

    PS- Solid as in CEMU, Wow yeah something changes & I played other none Emu things,
    I was locked out of Custom settings & loaded my past saved profile & it worked to load all the 3D stuff.
     
  19. Jumy

    Jumy Member

    Messages:
    32
    Likes Received:
    6
    GPU:
    9700pro to 5900xt
    yes sure, i also remember another period that thanks to this and the new wattman etc there was card die in particular ram side... you remember well?
    AMD need stop doing this and dictate guidelines for 3thparty prod. same for all, one driver and remove the crap in his software, so i decide what does my card do, is many simple
    My old card are still alive and fully functional (only some recent 4870-4870x2-5870-7970 all UVD bug??) my only shrewdness is to take care of ati / amd software, what it does and remove it for survive
    Now with inherited rx 480 always retrace the old road, my brother with 5700xt same situation if not worse, i seriously think is last ati/amd
    if they don't change and i hate the green side... but will have no other choice
    I don't know what has changed lately but i notice a deterioration in all video quality, burning white, black undefined, i had to turn down brightness in my monitor 70 to 25 and still the annoying blue light, now for read and web is usefull night light w10
    20.4.1 a big fail again
    I just signed up and I never write but now i'm tired with these experimental driver/software, always live in beta tester side... need a stop!!
     
  20. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,628
    Likes Received:
    939
    GPU:
    Gigabyte 3060 Ti
    Next big game in June - Death Stranding for PC.

    Until then i hope they focus on bug fixes - safely from home!

    Happy Easter (Soon) and stay safe.
     
    Jackalito, Passus and OnnA like this.

Share This Page