Download GeForce 361.43 WHQL game ready driver

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Dec 21, 2015.

  1. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    42,148
    Likes Received:
    10,105
    GPU:
    AMD | NVIDIA
    Nvidia just released a GeForce 361.43 WHQL game ready driver. they offer some new GameWorks VR tweaks yet also include a number of bug-fixes for Star Wars Battlefront SLI and other things. Download ...

    Download GeForce 361.43 WHQL game ready driver
     
  2. Denial

    Denial Ancient Guru

    Messages:
    13,528
    Likes Received:
    3,073
    GPU:
    EVGA RTX 3080
    So are they just dropping support for Fermi SLI in regards to WDDM 2.0 or did it just not make it into this release?

    I'm glad they finally fixed the 144hz issue.
     
  3. BlueRay

    BlueRay Master Guru

    Messages:
    277
    Likes Received:
    76
    GPU:
    EVGA GTX 1070 FTW
    Ohh finally the long awaited fix for the idle clocks above 120hz going to test it downloading atm
     
  4. RadioActiveLobster

    RadioActiveLobster Active Member

    Messages:
    74
    Likes Received:
    4
    GPU:
    EVGA 1080Ti FTW3
    This does not fix the idle 144Hz GPU clock issue for me.

    This is on a clean install (after wiping with DDU in safe mode)
     

  5. DeskStar

    DeskStar Maha Guru

    Messages:
    1,280
    Likes Received:
    220
    GPU:
    EVGA 3080Ti/3090FTW
    Can anyone say they have good things to report with this driver...? Away from my computer for a few days, so I can not say whether it is anything beneficial.
     
  6. haxzion

    haxzion Member

    Messages:
    39
    Likes Received:
    1
    GPU:
    GV-N2070GAMING-8GC
    no problems with this drv yet but im only playing FO4 atm
     
  7. ESlik

    ESlik Ancient Guru

    Messages:
    2,412
    Likes Received:
    21
    GPU:
    EVGA x2 1080 Ti SC Black
    Best driver for me since 347.88. I'm on Win. 7.
     
  8. JonnyF

    JonnyF New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    MSI 980Ti 6G
    Me neither - I have two monitors (the second is just normal 60Hz)

    If I disable the second monitor - the bug is fixed, leave it enabled and the bug is still there.

    Setting my main display to 120Hz at desktop works around the issue as before.

    Presume NVidia didn't test with multi-monitors! (Go figure!?)

    Jon.
     
  9. bonzo

    bonzo New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Leadtek GTX 970 Hurricane
    This fixes the 144 Hz issue for me. I installed the drivers without using DDU (but I did tick the clean install via Custom Settings).

    I set it to 120 Hz prior to installing (confirmed that it was running at idle clocks before installing), and afterwards, I changed the refresh rate to 144 Hz and confirmed via Afterburner that it's running at idle clocks.

    I also have a second monitor running at 60 Hz, but it's plugged in to the motherboard rather than my graphics card.
     

Share This Page