Download: AMD Ryzen Chipset Driver 2.10.13.408

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Oct 20, 2020.

  1. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    40,773
    Likes Received:
    9,182
    GPU:
    AMD | NVIDIA
    AMD offers updated drivers for its motherboard chipsets including B350, A320, X370, X399, B450, X470, X570, B550, and TRX40 Chipset. The drivers offer an updated power plan for AMD Ryzen CPUs that coo...

    Download: AMD Ryzen Chipset Driver 2.10.13.408
     
    Ghosty likes this.
  2. Martin5000

    Martin5000 Member Guru

    Messages:
    141
    Likes Received:
    61
    GPU:
    8 gig
    Really annoying.
    I reset pc to fix my install problem.
    all went well.
     
    Last edited: Oct 20, 2020
  3. Kaleid

    Kaleid Ancient Guru

    Messages:
    2,579
    Likes Received:
    217
    GPU:
    MSI 5700 8GB
    Seems to raise power usage quite a lot. Seldom at 70w idle, 94w up to 120w instead.
     
  4. Turanis

    Turanis Ancient Guru

    Messages:
    1,772
    Likes Received:
    458
    GPU:
    Gigabyte RX500
    ^yYou are on balanced or Ryzen power management?
    Try balanced or High power for gaming.
     
    Kaleid likes this.

  5. Kaleid

    Kaleid Ancient Guru

    Messages:
    2,579
    Likes Received:
    217
    GPU:
    MSI 5700 8GB
    Ah, good that you mentioned it. It was set automatically to Ryzen high performance. Changed it to Ryzen balanced. I'll report back if it doesn't work..
     
  6. Wanya

    Wanya New Member

    Messages:
    8
    Likes Received:
    2
    GPU:
    ATI
    try this for better idle when mhz don't go below base or 2.2 ghz

    powercfg -setacvalueindex scheme_current sub_processor THROTTLING 1
    powercfg -setactive scheme_current
     
  7. Serega_Mih

    Serega_Mih Member

    Messages:
    16
    Likes Received:
    4
    GPU:
    GainwardGTX1660S
    Thanks to this news, I learned that there is an AMD folder weighing 2GB on the C drive, can it be deleted? Path C:\AMD\
     
    Undying likes this.
  8. GSDragoon

    GSDragoon Master Guru

    Messages:
    285
    Likes Received:
    134
    GPU:
    AMD Radeon RX 6800
    Yes
     
    Serega_Mih and Undying like this.
  9. Undying

    Undying Ancient Guru

    Messages:
    15,413
    Likes Received:
    4,429
    GPU:
    Aorus RX580 XTR 8GB
    Installed no issues here with X570 Gaming X.
     
  10. kapu

    kapu Ancient Guru

    Messages:
    4,704
    Likes Received:
    406
    GPU:
    Radeon 6800
    As always buged :D
    upload_2020-10-20_16-45-7.png


    Anyone help with this bug ? :(
     
    Last edited: Oct 20, 2020

  11. Martin5000

    Martin5000 Member Guru

    Messages:
    141
    Likes Received:
    61
    GPU:
    8 gig
    I ended up resetting.
    i tried but failed to fix my problem but after reset it went in no problem.
     
  12. JAMVA

    JAMVA Master Guru

    Messages:
    274
    Likes Received:
    208
    GPU:
    RYZEN 5800X :)
    I have a .msi few errors like this in windows 10 with a msi installer if it can't get internet access.

    I have to turn off my third party firewall in windows temporarily during install , then it will install fine.
     
  13. kapu

    kapu Ancient Guru

    Messages:
    4,704
    Likes Received:
    406
    GPU:
    Radeon 6800
    i dont have any firewall , i tried to google that error but nothing conclusive . I heard it might be problem because my system drive is not C: ..... Kind sillyy
     
  14. balthier

    balthier Member

    Messages:
    43
    Likes Received:
    2
    GPU:
    Gigabyte 2070 RTX
    Driver installs fine no error no problem but no matter what i do i always get AMD PCI Device Driver 1.0.0.80 instead of the new 1.0.0.81.Tried to unninstall drivers firs,update manualy nothing works.I wonder if this is only for some new chipsets?:( Desktop 20- 10- 2020 18-03-24-336.png
     
  15. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,433
    Likes Received:
    2,789
    GPU:
    MSI 6800 "Vanilla"
    There's a log file in C:\AMD (If the folder hasn't been deleted since it's also the temporary storage AMD uses unlike say using the Temp folder.) maybe that information can help show what's happening with the process here and why that's acting up,looking at the extracted files there's a completely different version for Windows 7 and Windows 10 only has the .81 driver from what I can tell.

    If nothing else just device manager it and point the driver location to:
    C:\Users\USERNAME_HERE\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2AC4B528-F55F-47BC-B598-781D8A0A9B7E}\IODriver\PCI\PCI Driver\WTx64

    That should do it.
    (Should be a system component version .80)

    EDIT: Hmm well manually setting a path to the newer driver should do it, might have to do it fully manually and pick things instead of letting the OS decide.

    Wonder if it's not picking up the file directory or if the driver repository and Windows opts to just keep the .80 version for some reason.


    EDIT: I'm on a X570 though perhaps there's just a issue with INF data for getting this to install on certain board models come to think of it.
    Would be a bit strange though as there's only a W7 and W10 driver here so that'd result in nothing on fresh system installs and driver updates so has to be a bug in that case.

    Not sure how this identifies and works, 500, 400 and 300 series I would imagine but unsure on A or B or X models.

    It's less about the motherboard itself and more about the chipset component far as I know and stuff here which this software installs drivers for.
    (Which there are some differences with in regards to PCI Express 4.0 or 3.0 for this on non-X570 boards, hmm.)

    Maybe the .80 has more entries in the INF, for some reason.

    So .81 here goes as unsupported and skips it but as it wasn't a error or fail it doesn't show during the install process but should show up in the log for the full details on what happened during installation for the various devices and such.
     
    Last edited: Oct 20, 2020

  16. Lily GFX

    Lily GFX Active Member

    Messages:
    94
    Likes Received:
    85
    GPU:
    AORUS 3090 Master
    Installed fine on the pc with MSI motherboard but it would not install on the
    with the pc with ASUS motherboard. Even thou previous Chipset was
    uninstalled in Apps & features. I think something with Windows prevented
    uninstalling the old driver properly.

    This post by Astyanax helped me (post #37):
    https://forums.guru3d.com/threads/download-amd-motherboard-chipset-driver-v2-07-14-327.433424/page-2

    You can also download the tool directly from Microsoft if wanted here:
    https://support.microsoft.com/en-us...hat-block-programs-being-installed-or-removed

    Maybe helpful for some:
    -Run downloaded troubleshooter tool
    -Check advance
    -Click Next
    -Click Uninstalling
    -Remove everything AMD Chipset related (GPIO2, PCI, PSP, Balanced Driver,
    SMBus Driver Alpha) you can skip Ryzen Master.
    (Need to do one and one and a registry backup is added to a folder called
    MATS on the system drive, that can be deleted after if wanted.)
    -Delete AMD folder on the system drive if not already, just to be sure.

    -Install new driver and hopefully next update will be fine too without redoing
    above. I did try reinstall on top just to check after and it worked^^
     
  17. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,647
    Likes Received:
    643
    GPU:
    MSI 2070S X-Trio
    Giving these a miss, like the last ****** set! :D
     
  18. kapu

    kapu Ancient Guru

    Messages:
    4,704
    Likes Received:
    406
    GPU:
    Radeon 6800
    I'm still using windows default drivers because on my system they cant install, always same error , diged half of the interent to fix it , tried 10 different solutions .
    upload_2020-10-21_0-23-44.png

    What am i missing if im running windows default drivers ? i haven't noticed any crashes or anything like that .
     
    rl66 likes this.
  19. rl66

    rl66 Ancient Guru

    Messages:
    2,852
    Likes Received:
    349
    GPU:
    Sapphire RX 580X SE
    Work fine with B450 and X570...
    On other hand previous working nicely too.
    Ryzen power management seem to work better...
     
  20. rl66

    rl66 Ancient Guru

    Messages:
    2,852
    Likes Received:
    349
    GPU:
    Sapphire RX 580X SE
    Not much, windows are updating driver from AMD, you just don't have the latest but it work and you don't have the "extra stuff" that are useless in normal use.
     

Share This Page