Download: AMD Radeon Adrenalin Edition 19.3.1 driver

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mtrai, Mar 6, 2019.

  1. warlord

    warlord Ancient Guru

    Messages:
    2,432
    Likes Received:
    798
    GPU:
    Null
    Hardware breakers, ruiners are not enthusiasts. Unless you do believe people here are more enthusiasts than AMD engineers themselves.
     
  2. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,880
    Likes Received:
    470
    GPU:
    RX Vega
    If you read the Vega reviews, you will find Hilbert recommends flashing.

    Please be more respectful towards the community here.
     
    AlleyViper, Krteq and Embra like this.
  3. vbetts

    vbetts Don Vincenzo Staff Member

    Messages:
    14,717
    Likes Received:
    1,300
    GPU:
    RTX 2070FE
    So, some of us here need to cool it down.
     
    Undying, warlord and BlackZero like this.
  4. warlord

    warlord Ancient Guru

    Messages:
    2,432
    Likes Received:
    798
    GPU:
    Null
    Hilbert is no AMD though and warns you about the dangers of bricking the cards. He is a respectful and experienced reviewer and trusted from thousands of people by the years. I do not think he ever said people go flash your cards easily just like formatting Windows.

    Whether you like it or not, you do not reserve support from any corporation's/company's developer, WHEN YOU ALTER the hardware/equipment. To my eyes, the thread is ruined when I read comments about flashed cards not working as expected. I am with AMD on this.

    I stop this, it is not going anywhere. I speak with AMD engineers and they are with me on this. They are not idiots, imagine if they should flash all gpus with alternate bios only to make customers feel better when you break the EULA and your warranty. Have a nice day.

    PS, I also never supported flashing 5850-5870, 6950-6970 and later etc. It was never into my principles. And by seeing your profile, I know and participated to this site and forums 7-8 years earlier than you, so we are not the same in terms of respect towards this place.
     
    Undying and BlackZero like this.

  5. Thiago Diniz

    Thiago Diniz Member

    Messages:
    25
    Likes Received:
    16
    GPU:
    RX VEGA 64
    well, nowhere in this thread I saw someone saying "amd MUST fix this"... until now we are only discussing what could be the "problem" and how to solve it, no one is blaming amd for that.. I don't see how this thread is ruined..

    And me, as an AMD VEGA 64 user, agree with AMD, we take our own risks flashing a bios into the card that is not made for it, and amd has the rights to not support it. It used to work very well by the way, but AMD is constantly trying to improve its drivers and we have to deal with it, flash back stock/original bios and move on
     
    OnnA likes this.
  6. Embra

    Embra Master Guru

    Messages:
    921
    Likes Received:
    208
    GPU:
    Vega 64 Nitro+LE
    You always take your own risk flashing a bios. If AMD wanted to, I am sure they could lock the bios from flashing.


    Let's be civil.
     
  7. spectatorx

    spectatorx Master Guru

    Messages:
    740
    Likes Received:
    97
    GPU:
    Radeon RX580 8GB
    You can't blame ATI as they do not exist anymore :p
     
  8. passenger

    passenger Master Guru

    Messages:
    333
    Likes Received:
    41
    GPU:
    Sapphire RX580 8GB
    AMD fixed little greens which appeared in video players for me few release back, they mentioned something similar in release notes:
    • Video playback may become green or experience corruption when dragging the Movies and TV application to an HDR enabled display.
    Radeon overlay works perfect. On a down side lagging in Metro Exodus is to pronounced.
     
    Last edited: Mar 12, 2019
    Undying likes this.
  9. Undying

    Undying Ancient Guru

    Messages:
    12,007
    Likes Received:
    1,623
    GPU:
    Aorus RX580 XTR 8GB
    Indeed. I even stoped using afterburner after many years. Wattman and radeon overlay works great so why bother with it.
     
    ManofGod and passenger like this.
  10. gvarv

    gvarv New Member

    Messages:
    9
    Likes Received:
    12
    GPU:
    Vega56 - LC
    Phew - thanks for the research, I thought I was going crazy trying to troubleshoot my Vega 56. I modded the card, water cooled it and flashed the LC Bios way back when. Card would randomly slow down with any driver after the 19.1.1 for me. I guess it is time to try some Vega 64 bioses - I need my 11xx mhz memory clocks darnit!!!
     
    OnnA likes this.

  11. Kaerar

    Kaerar Master Guru

    Messages:
    348
    Likes Received:
    43
    GPU:
    RX Vega 64
    Yeah will have to test the stock BIOS again then. Currently on the 8774 LC BIOS and it's not missed a beat for me, gave better perf on my card than my stock BIOS. Will need to find a BIOS that likes the new drivers. I'm intrigued to see if the LC cards with the 8774 BIOS are having issues as well??
     
  12. Thiago Diniz

    Thiago Diniz Member

    Messages:
    25
    Likes Received:
    16
    GPU:
    RX VEGA 64
    As far as I know LC Cards are working flawless, the problem only occurs with modded cards/bios mod.. in another forum a guy said he has 2 vega cards, one LC and one reference flashed with LC BIOS, and he said the problem only occurs in the modded one
     
    Kaerar likes this.
  13. OnnA

    OnnA Ancient Guru

    Messages:
    9,851
    Likes Received:
    2,081
    GPU:
    Vega 64 XTX LiQuiD
    Upgrade Profile ;) -> Be the Proud Owner of the Vega Beast :D :p
     
  14. OnnA

    OnnA Ancient Guru

    Messages:
    9,851
    Likes Received:
    2,081
    GPU:
    Vega 64 XTX LiQuiD
    I have xxx8774 (this is newest BIOS revision)
    My GPU was shiped with iT :cool:

    Everything is Fine on my XTX.... BTW - 19.3.1 have a little better Perf/tW
     
  15. gvarv

    gvarv New Member

    Messages:
    9
    Likes Received:
    12
    GPU:
    Vega56 - LC
    Fine - first profile update in ten years :p :)
     
    Undying likes this.

  16. gvarv

    gvarv New Member

    Messages:
    9
    Likes Received:
    12
    GPU:
    Vega56 - LC
    Ditching the LC bios and flashing 8706 bios.
    - Flashing went smoothly
    - With old driver 19.1.1
    - Quick test 3DMark TimeSpy at 1700/1100 Graphic score: 7683
    - Will update with score from 19.3.1
    - Quick 'n Dirty upgrade from 19.1.1 to 19.3.1
    - 3DMark TimeSpy same settings: 7611
    No stutters, no hang and let's face it no significant difference between the 19.1.1 and 19.3.1 scores.

    Thanks to the great people on Guru3D for finding the solution to a weird problem!!!
     
    Last edited: Mar 13, 2019
  17. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    1,977
    Likes Received:
    553
    GPU:
    Gigabyte R9 380 4G
    So the problem was you, flashing another Bios if i understand correctly?
     
  18. Krteq

    Krteq Master Guru

    Messages:
    501
    Likes Received:
    74
    GPU:
    RX Vega 56 +64 BIOS
    He flashed non-LC BIOS to a reference Vega which fixed that issue I guess
     
    gvarv and LocoDiceGR like this.
  19. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    1,977
    Likes Received:
    553
    GPU:
    Gigabyte R9 380 4G
    19.3.2 Today/Tomorrow For Division?!?!??!?!?

    Radeon Sponsored.
     
  20. gvarv

    gvarv New Member

    Messages:
    9
    Likes Received:
    12
    GPU:
    Vega56 - LC
    Bought a reference Vega 56 in 2017. Modded it with liquid metal and liquid cooling. Flashed it with a LC bios to take advantage of higher power profiles and OC ability. Then after more than a year of working smoothly I upgraded from 19.1.1 to 19.2.x and nothing but problems. Solved by flashing a Vega 64 non LC bios as Krteq correctly surmised.
     
    Krteq and BlackZero like this.

Share This Page