DownClock Fix for Fury/390 series cards (may work for others too)...

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ReaperXL2, Mar 1, 2016.

  1. dave343

    dave343 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    EVGA GTX 960 4GB
    Well... Nvidia isn't free from mistakes in their history, I just prefer them. But you're right, having a community fix is a bit ghetto IMO...
    I know AMD is working on a fix, however it probably isn't that simple. Since they added the down-clock issue to the known issues on the release notes, then that tells you they couldn't figure out the problem before releasing the driver, and I bet they are still scratching their heads.
     
  2. xacid0

    xacid0 Master Guru

    Messages:
    443
    Likes Received:
    3
    GPU:
    Zotac GTX980Ti AMP! Omega
    Except that this "issue" is actually a power saving feature they introduced since first Crimson driver?
     
  3. BoMbY

    BoMbY Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    Fury X
    Did some of you with the downclocking issue ever try to set the Windows Power Management options all to max power?

    As this problem isn't happening for everyone, there must be some outside influence causing it.

    Edit:

    Yes, except the recent two WHQL drivers, or so, which are causing massive Windows problems for some users. And all the other issues ...
     
    Last edited: Mar 9, 2016
  4. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,901
    Likes Received:
    777
    GPU:
    Inno3D RTX 3090
    Like deleting EDID data :D

    This issue shouldn't exist on AMD though. Even a single "tick" on the "Advanced" options of Crimson that reverted to the previous behavior, would be so nice. I wonder how many game benchmarks are skewed because of it.
     

  5. TonyTurbo

    TonyTurbo Master Guru

    Messages:
    233
    Likes Received:
    16
    GPU:
    Vega 64 @ 1750/1180
    seems to not work for me...mind you I'm on crossfire. Seems the GPU1 is staying locked, but GPU2 still fluctuating. I dropped core clocks to 970 on both cards just to test.

    GPU1 is left side, GPU2 is right

    [​IMG]

    EDIT*

    Just tried a few other games, GPU2 dropping under 800mhz core when I'm nowhere near my fps limit of 120fps. Does not seem to be working here.
     
    Last edited: Mar 9, 2016
  6. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    CFX must be definitely a factor in here.

    What clocks do you get applying the reg key and without dropping core clocks?

    I mean using AB only to monitor GPUs not to OC them manually or via AB clocks profile.
     
  7. BoMbY

    BoMbY Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    Fury X
    I can force some strange clock behavior on my system with FRTC set to a very low value.

    With FRTC set to 45, I get 41.01/43.21 average FPS in 3Dmark test 1/2. Using FRTC 45 with ClockBlocker I get 44.57/44.57.

    So the power savings could simply be to aggressive, and you get issues if you don't put enough stress on your GPU (which doesn't usually seem to happen for me). Maybe you run into something similar with Vsync on.

    As the OPs settings are fiddling with exactly this, it does seem to be the perfect fix for the problem.

    Edit: Getting 44.65/44.62 with PP_AllGraphicLevel_DownHyst = 20 and FRTC 45.

    Also logging showed weird jumpy GPU frequencies without DownHyst, and stable 1050 with DownHyst.

    I would say that's a perfect confirmation.
     
    Last edited: Mar 9, 2016
  8. Goiur

    Goiur Maha Guru

    Messages:
    1,109
    Likes Received:
    383
    GPU:
    ASUS TUF RTX 3080
    For those who are not on change.org thread.

    16.3 are out.

     
  9. TonyTurbo

    TonyTurbo Master Guru

    Messages:
    233
    Likes Received:
    16
    GPU:
    Vega 64 @ 1750/1180
    hasnt done jack ****, cores still dropping to 500/600mhz even with the power feature disabled.

    well there's a a surprise, core clock issue not fixed. Back to the 3rd party programs to lock it. GPU1 left, GPU2 right, 120fps limit, as you can see dropping to 500/600mhz on the cores when only doing 68fps.

    [​IMG]
     
  10. Goiur

    Goiur Maha Guru

    Messages:
    1,109
    Likes Received:
    383
    GPU:
    ASUS TUF RTX 3080
    Works fine for me, more info @ 16.3 thread.
     

  11. Agonist

    Agonist Ancient Guru

    Messages:
    3,414
    Likes Received:
    638
    GPU:
    Dell 6800XT 16GB
    Downloading now.
    Gonna test these out with FPS limits in Afterburner and freesync.
     
  12. Goiur

    Goiur Maha Guru

    Messages:
    1,109
    Likes Received:
    383
    GPU:
    ASUS TUF RTX 3080
    Comment on 16.3 thread your findings pls. It seems 2xx series cant disable/enable eco mode.

    For me is working fine.
     
  13. FinalKenpachi

    FinalKenpachi New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    R9 290 Trixx
    This setting not for R9 290 Trix? Because i don't see this setting.
     
  14. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    2xx is not supported, its only for 3xx and fury.

    The settings it disables are specific for those cards, they don't exist in 2xx and earlier bios.
     
  15. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,116
    Likes Received:
    1,396
    GPU:
    2070 Super
    I keep hearing people mention 500MHz clock on their GPU, which reminds me of typical PowerPlay GPU freq.
    Also this fix uses "PP_AllGraphicLevel_DownHyst" which again hints at PowerPlay(PP).

    Issues with PowerPlay while playing 3D game have been existent on Radeons since forever.
    Downlocking while playing 3d game and having youtube video open is not even considered a bug.
    It could be that GPU gets stuck in PowerPlay clocks, an issue that I have not experienced on my 290,
    but which has plagued all my previous Radeons.

    Make sure you dont have any videos opened in background.
     

Share This Page