Doom Eternal bad performance

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PrMinisterGR, Apr 11, 2021.

  1. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,735
    Likes Received:
    651
    GPU:
    Inno3D RTX 3090
    I really don't know how to name this thread exactly.

    I have a very high end system (5950x, 32 GB DDR3200 CL14, RTX 3090), that performs as it should in all benchmarks, with the latest stable version of Windows and the latest stable NVIDIA driver via DDU.

    Either if I play the game on my monitor (4k60 RGB 10bit, no Gsync), or on my TV (4k120 RGB 12bit HDR with GSync), the game feels much slower than what the frame rate indicator would imply. That's with everything on Ultra Nightmare at 4k.

    I cannot record what I mean, unfortunately, but it seems as if the framerate is somehow lower than what is reported, and whenever it isn't, there are lagspikes.

    I have tried everything I could imagine. I removed the game settings completely, reinstalled it, disabled vsync and or any frame limiter from the game, tried borderless and fullscreen, tried the NVIDIA vsync, the game vsync, triple buffering on or off, the game frame limiter, the NVIDIA frame limiter, enabling Gsync, disabling Gsync, forcing Maximum Performance on the card, nothing makes a difference.

    Anyone has any ideas, or am I the only one?
     
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,538
    Likes Received:
    3,838
    GPU:
    GTX 1080ti
    try to disable all overlay injections except for RTSS, that'll mean

    Discord
    Steam
    Precision
    <Any other vendor utility> (Firestorm/Gputweak/EasyTune)
    <Review the list of loaded modules with resource monitor and disable those too>

    This will rule out any chances that rtss is measuring an overlay sitting on top rather than the game itself.

    Check the status of the platform clock value using bcdedit (should be false or missing in the printed list)
    Disable HAGS < most common source of fps not feeling responsive or "fast", especially for Presentation from Compute queue optimized titles


    On a non system related matter,

    The game is perceived slower than DooM because the FOV is different,
    https://www.reddit.com/r/Doom/comments/ezdo4v/psa_the_reason_movement_in_doom_eternal_looks/
     
    Smough likes this.
  3. Dagda

    Dagda Master Guru

    Messages:
    271
    Likes Received:
    48
    GPU:
    RTX 2080 super
    verify if gamebar is also not enabled.
     
  4. SalamatiQus

    SalamatiQus Active Member

    Messages:
    77
    Likes Received:
    44
    GPU:
    RTX 3080 Vision OC
    Check what refresh rate your monitor is reporting.
    An example from Sekiro with unlocked framerate. If I have "Preferred refresh rate" as "Application controlled" then Sekiro is stuck 60Hz mode even with fps unlocked (120+ fps) and with lots of stutters. Setting to "Highest available" fixes it and allows to refresh rate catch up with fps.
     
    AsiJu likes this.

  5. Susahamat

    Susahamat Master Guru

    Messages:
    331
    Likes Received:
    159
    GPU:
    GTX 980 Ti Poseidon
    yup same here, the game has smooth before until patch for the first episode dlc come out.
     
    PrMinisterGR likes this.
  6. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,182
    Likes Received:
    2,151
    GPU:
    MSI 6800XT GamingX
    Runs great here but I did find if I record gameplay with mic I get framedrops and very erratic frametime.

    So based on that maybe try disabling microphone and make sure Discord or anything that would use the mic isn't running simultaneously.

    Make sure Present From Compute is On in game settings.

    EDIT: running GSync compatible 144 hz display with RTSS cap at 120 or higher.

    Also make sure you use at least RTSS version 7.3.0 Beta 3 if you are using RTSS / AB to monitor the game:

    RTSS 6.7.0 beta 1

    Last but not least, try an older driver, skimming through the driver thread for 465.89 there seem to be various issues with some users related to DX12 and/or Vulkan.
    Personally still using 460.97.

    EDIT2: FYI the mic issue was due to RTSS encoder server being set to 64-bit, no drops when recording with 32-bit.
     
    Last edited: Apr 12, 2021
  7. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,182
    Likes Received:
    2,151
    GPU:
    MSI 6800XT GamingX
  8. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,735
    Likes Received:
    651
    GPU:
    Inno3D RTX 3090
    Present from compute has been switched on and off, and it feels the same still. I don't use RTSS, the only overlay I use is the Steam one, and even that I disabled and got the same behavior. Every single other game works properly, including CEMU in Vulkan, and RDR2 in Vulkan. They both work fine with the Steam overlay btw, but for Doom I even tried to disable it and it was the same. I don't know how to describe the performance exactly, it's as if it's on molasses somehow. According to the game frame counter, there is zero performance issue. I am not using any external performance counter. I am not using any vendor utility. For RGB I use OpenRGB (or however it's called), which is a run once utility to set some colors and that's it.

    I am not using RTSS at all. I will check the case GeForce Experience is trying to record clips, but I have this globally disabled.
     
  9. Undying

    Undying Ancient Guru

    Messages:
    15,711
    Likes Received:
    4,736
    GPU:
    Aorus RX580 XTR 8GB
    Linus actually realized it in this video 6900xt is much smoother despite having less fps also in Doom.

    Watch carefully he talks about it
     
    PrMinisterGR likes this.
  10. itpro

    itpro Master Guru

    Messages:
    997
    Likes Received:
    535
    GPU:
    Radeon Technologies
    Become a true power user by becoming an insider. Try at least release preview channel or even beta which gives different drivers many times. I could never work or game in public channels. It disgusts me to avoid early fixes from developers, I respect myself as a developer and others too.
     

  11. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,538
    Likes Received:
    3,838
    GPU:
    GTX 1080ti
    Smoother can translate into delay time, thats the problem.
    did this benchmark cover input response times/
     
  12. Undying

    Undying Ancient Guru

    Messages:
    15,711
    Likes Received:
    4,736
    GPU:
    Aorus RX580 XTR 8GB
    Your eyes can easily notice stuttering similar to sli you dont need fancy delay benchmarking. I think this is what op is talking about having the same issue.
     
    PrMinisterGR likes this.
  13. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,538
    Likes Received:
    3,838
    GPU:
    GTX 1080ti
    Well, saying its like molasses would actually be like playing a console game originally developped for 60hz/60fps at 30fps without a frameskipper, to me that is.

    @RealNC mentioned at some point that some monitors appear to drop frames at 144hz, im wondering if theres a connection to that.

    I haven't found much in my searches that correlate to the experience here, though i recently remote played and found a similar issue in KH2FM when the remote resolution jumped to 4k30 when the game needs 60 (when vsyncing).

    A video with the framerate graph running would help immensely, as would a gpu trace.

    hrm, internet says to disconnect bluetooth devices (to fix a similar issue on PS4)

    You know what, i had a similar thing with WarFrame a couple of years back, due to a bug in their Xinput code and frame limiter, the input was being time linear stretched across the total framerate and not updating every frame as it was intended to be so it wound up moving slower than it should.
     
    Last edited: Apr 14, 2021
  14. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,182
    Likes Received:
    2,151
    GPU:
    MSI 6800XT GamingX
    I'd still say try downgrading your driver. If the problem persists then you know it's not driver related at least.
     
  15. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,735
    Likes Received:
    651
    GPU:
    Inno3D RTX 3090
    This is what I also see, I think. I really don't know how to describe it exactly.
    I understand where you're coming from, but my Windows installation on the PC is basically an entertainment box, I won't beta opt in anything at this point. I spend my whole day doing dev/operations stuff, no more.

    It "feels" like this. The only time the game behaved close to OK was when I disabled Gsync and enabled the fixed (not adaptive) 1/2 Vsync from Nvidia Inspector, at 4k120.

    I will try to get something today.

    hrm, internet says to disconnect bluetooth devices (to fix a similar issue on PS4)

    It really feels like a weird issue with the game, I don't get this in anything else.
     

  16. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,735
    Likes Received:
    651
    GPU:
    Inno3D RTX 3090
    I figured out what it was, thanks everyone for helping! I will leave the post mortem here in case anyone else needs some help with this or something similar.

    - I add all my games to Steam. The reason for this is Big Picture mode, and having a Steam controller and a couple of Dual Shock 4 controllers. This makes playing games with them super easy with basically zero driver installations, through a friendly environment.
    - Doom Eternal is a GamePass game. There are two issues with GamePass games:
    a)Steam cannot hook to them.
    b)You cannot add them by executable.
    - I use GloSC (Global Steam controller), which creates a "fake" hook and forces Steam to enable the correct input profiles. With every single other game I have tried via GamePass, GloSC is working with no issue. But with Doom Eternal (works fine with Doom), it does not. Not only the overlay needs to be disabled for the entry that GloSC creates for Doom Eternal in Steam, but you need to go to C:\Program Files (x86)\GloSC\targets , and edit the Doom Eternal file to disable the overlay from there too. So now my GloSC Doom Eternal profile looks like this:
    Code:
    [BaseConf]
    bEnableOverlay=0
    bEnableControllers=1
    bUseDesktopConfig=0
    bHookSteam=0
    version=520
    [LaunchGame]
    bLaunchGame=1
    Path=BethesdaSoftworks.DOOMEternal-PC_3275kfvn8vcwc!Game
    Args=
    Type=UWP
    bCloseWhenDone=1
    
    

    You also need to make sure that the Nvidia driver "understands" this is Doom Eternal. It seems that currently Nvidia is basically not tracking GamePass games through profiles. You will notice that if you have this game from GamePass and try to add it via the Nvidia driver to edit its profile, it creates a non-sensical profile. If you edit the "Doom Eternal" profile from the drivers, nothing happens.
    The driver produces this (profile via Nvidia Inspector):
    Code:
    <?xml version="1.0" encoding="utf-16"?>
    <ArrayOfProfile>
      <Profile>
        <ProfileName>bethesdasoftworks.doometernal-pc_3275kfvn8vcwc</ProfileName>
        <Executeables>
          <string>bethesdasoftworks.doometernal-pc_3275kfvn8vcwc</string>
        </Executeables>
        <Settings>
          <ProfileSetting>
            <SettingNameInfo>Vertical Sync Tear Control</SettingNameInfo>
            <SettingID>5912412</SettingID>
            <SettingValue>2525368439</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
          <ProfileSetting>
            <SettingNameInfo>Maximum pre-rendered frames</SettingNameInfo>
            <SettingID>8102046</SettingID>
            <SettingValue>1</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
          <ProfileSetting>
            <SettingNameInfo>Flag to control smooth AFR behavior</SettingNameInfo>
            <SettingID>270198627</SettingID>
            <SettingValue>0</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
          <ProfileSetting>
            <SettingNameInfo>Power management mode</SettingNameInfo>
            <SettingID>274197361</SettingID>
            <SettingValue>1</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
          <ProfileSetting>
            <SettingNameInfo>Frame Rate Limiter</SettingNameInfo>
            <SettingID>277041154</SettingID>
            <SettingValue>116</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
          <ProfileSetting>
            <SettingNameInfo>VRR requested state</SettingNameInfo>
            <SettingID>278196727</SettingID>
            <SettingValue>0</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
          <ProfileSetting>
            <SettingNameInfo>Enable G-SYNC globally</SettingNameInfo>
            <SettingID>294973784</SettingID>
            <SettingValue>0</SettingValue>
            <ValueType>Dword</ValueType>
          </ProfileSetting>
        </Settings>
      </Profile>
    </ArrayOfProfile>
    

    What I did to make this work, was export the Doom Eternal profile from Nvidia Inspector, edit it with Notepad++, and I added the
    Code:
    <string>bethesdasoftworks.doometernal-pc_3275kfvn8vcwc</string>
    part to the Executeables part of the Doom Eternal "real" profile as a new line, so now that part of the Doom Eternal profile looks like this:
    Code:
    <Executeables>
          <string>ghostx64vk.exe</string>
          <string>doometernalx64vk.exe</string>
          <string>bethesdasoftworks.doometernal-pc_3275kfvn8vcwc</string>
        </Executeables>
    
    I then re-imported it with Nvidia Inspector.

    After doing all of the above, the game flies. Thank you all for trying to help! I will keep all this in mind the next time I have an issue.
     
    Cave Waverider, AsiJu and Astyanax like this.
  17. TimmyP

    TimmyP Master Guru

    Messages:
    621
    Likes Received:
    34
    GPU:
    RTX 3070
    Wow Linus is cited as a credible source on this site now...
     
  18. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,538
    Likes Received:
    3,838
    GPU:
    GTX 1080ti
    Good catch, Nvidia probably overlooked the fact the game got a UWP release.
     
  19. AsiJu

    AsiJu Ancient Guru

    Messages:
    7,182
    Likes Received:
    2,151
    GPU:
    MSI 6800XT GamingX
    Glad you got it sorted!
     
  20. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,116
    Likes Received:
    130
    GPU:
    RTX 3090 ROG Strix
    Looks like that's the case with most if not all the recent Bethesda UWP releases.
     
    PrMinisterGR likes this.

Share This Page