Doom 3 bfg 3d Nividia vision doesn't work

Discussion in 'Games, Gaming & Game-demos' started by pstlouis, Oct 16, 2012.

  1. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    3
    GPU:
    RTX 2080Ti Aorus Xt
    I set the max fps to 120 and choose quad buffer but the software doesn't detect the 3d option. :thumbdown
     
  2. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,173
    Likes Received:
    1,921
    GPU:
    Zotac GTX980Ti OC
    Maybe because its locked at 60fps, its game engine "limitation"


    you can try this if you haven't already; Make a autoexec.cfg file (not txt) and put it in base directory

    now add

    seta com_allowConsole "1" //although this is not really necessary..

    and

    seta com_fixedTic "-1"


    seta com_fixedTic [-1,0,1] - If set to 0 (the default) Doom 3's ticrate is capped at 60FPS, meaning the game framerate cannot exceed this, except when running a timedemo. If you want to remove this cap, set com_fixedTic to -1. Setting it to 1 removes the cap, but causes the game physics to go out of sync. Removing the FPS cap doesn't necessarily improve performance, and can lead to more variable framerates. Note that com_fixedTic -1 doesn't work as of the latest patch.

    and enable vsync to limit it at 120fps if it works..

    http://www.tweakguides.com/Doom3_8.html
     
    Last edited: Oct 16, 2012
  3. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,445
    Likes Received:
    2,813
    GPU:
    MSI 6800 "Vanilla"
    This engine update should support 120 FPS though from what I've read, I could be wrong but 3D vision was one of the main features of this re-release.
     
  4. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    What engine it uses? Famous IDSh!t 5?
     

  5. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,445
    Likes Received:
    2,813
    GPU:
    MSI 6800 "Vanilla"
    Partially, or something like that.
    (Unsure, Carmack described it as using elements of ID Tech 5 but I don't know the specifics.)
     
  6. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    3
    GPU:
    RTX 2080Ti Aorus Xt
    it has 120 fps setting but stay at 60 fps even if we set it to 120. :biggun:
     
  7. Tranceholic

    Tranceholic Banned

    Messages:
    901
    Likes Received:
    0
    GPU:
    MSI GeForce GTX 570 Fermi
    just installed Doom3 BFG as well and testing this method

    source: http://3dvision-blog.com/tag/doom-3-bfg-edition/

    edit: just changed the sitting to quad buffer and restart game, bang!! in 3d now. now off to play in the dark!
     
    Last edited: Oct 17, 2012
  8. peterzum

    peterzum New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    2xGTX480
    Similar problem, but I fixed it

    I had a similar problem, enabling 120Hz, Quad Buffered, and Vsync on, didn't help.
    But then when I switched my resolution in Doom3 BFG, to a video mode that specifically also said 120 Hz (1680x1050x120Hz), the stereoscopic 3d started working.
    (I also previously set quad-buffered 3d-mode, although I don't remember what I had left the other vsync (on - probably), or refresh rate (120 - probably) settings at (there is a seperate place to set refresh rate to 60 or 120 independent of the resolution, in the same menu as the vsync)).

    So try:
    Enable Quad-Buffered 3d mode
    Set Vsync on
    Set refresh rate to 120 Hz
    Select a resolution that includes "x120" at the end
     
  9. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    3
    GPU:
    RTX 2080Ti Aorus Xt
    thank you i will try that. Doesn`t noticed that in the res menu you have to choose the res with the refresh rate. :banana:
     
  10. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    3
    GPU:
    RTX 2080Ti Aorus Xt
    problem solved

    Thank you peterzum for your help. I applied the 1920x1080@120hz with quad buffer and 120 fps. 3D work perfectly. doesn't noticed the option with the 120 hz refresh rate. :banana:
     

  11. Nano2k

    Nano2k Active Member

    Messages:
    87
    Likes Received:
    1
    GPU:
    RTX2080TI
    Cool stuff, finally a use for my Nvidia glasses!
     
  12. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    3
    GPU:
    RTX 2080Ti Aorus Xt
    I could tell you that doom 3 bfg is super in 3D mode with the new res. :banana:
     

Share This Page