Display Driver Uninstaller Thread

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Wagnard, Jul 14, 2013.

  1. Titan29

    Titan29 Master Guru

    Messages:
    295
    Likes Received:
    4
    GPU:
    Ref Vega 64/1060 6G
    Results with 3.7 (Win864 Pro):

    The DDU was not able to remove the following:

    oem22.inf
    Provider: Advanced Micro Devices, Inc.
    Class: Display adapters
    oem23.inf
    Provider: Advanced Micro Devices
    Class: Sound, video and game controllers

    2013-08-02 10:31:50 PM >> oem22.inf Found
    2013-08-02 10:31:50 PM >> Executing Driver Store CleanUP(delete OEM)...
    2013-08-02 10:31:51 PM >> Deleting the specified driver package from the machine failed

    because it is in use by a device.

    2013-08-02 10:31:51 PM >> oem23.inf Found
    2013-08-02 10:31:51 PM >> Executing Driver Store CleanUP(delete OEM)...
    2013-08-02 10:31:51 PM >> Deleting the specified driver package from the machine failed

    because it is in use by a device.

    So, I had to uninstall my gpu from device manager. After that I again ran DDU and got this:

    2013-08-02 10:36:42 PM >> oem23.inf Found
    2013-08-02 10:36:42 PM >> Executing Driver Store CleanUP(delete OEM)...
    2013-08-02 10:36:42 PM >> Deleting the specified driver package from the machine failed

    because it is in use by a device.

    What could be the cause of this?
    I have since then installed 13.8 Beta and it has been working good so far.
    The only issue I can see is for some reason custom gaming profiles are still not working for me in CCC. e.g if I create one for star craft 2.exe with AA set to 8x, it does not work. Setting AA on system level works.

    Lastly, I think something else is being missed by DDU as well. After installing 13.8 Beta, CCC still 'remembered' it had to open in 'Advanced' view as opposed to 'Basic' view, as would have happened in a clean install. It could be a registry setting or a config file, but I do not know what.
     
  2. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    This is weird. Its not happening on my side.
    Since my software is kinda new, it still miss some stuff for some configuration.
    Im trying to get them all be assured :).


    After using DDU with 13.8 beta its still have the CCC to advanced?

    If you could find in device manager what is not uninstalled from the "display adapter" and "sound controller" in device manager I would greatly help.(and if possible , giving me the device instance path ; ou can find all this in device manager; It look like this : PCI\VEN_10DE&DEV_1188&SUBSYS_26903842&REV_A1\6&116C07A3&0&00800008

    If you cant find, s screen shot of GPU-z could do the trick too.


    For CCC at "least for me" everything is back as default. This was tested with the other beta 13.6 beta 2 if my memory is correct.

    Ill give a look if something hasn't changed in recent driver version.

    If possible, can you give me the COMPLETE .log file?
    pastebin will do


    Also, could it be possible that your systemdrive is not C:\ or that you changed the default installation folder when installing the driver? just asking...
     
    Last edited: Aug 5, 2013
  3. Shady757

    Shady757 Member Guru

    Messages:
    177
    Likes Received:
    2
    GPU:
    Gigabyte G1 GTX 970/GSYNC

    This is what I think is likely, I think I'll add/fix or you can to check for systemdrive variable, rather than automatically using C:\. It's quite easy code.
     
  4. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    Release 3.9

    Blackscreen Workaround
    -After a Successful cleaning , the system will automatically restart in 5 seconds

    Nvidia only
    -More Physx cleaning from registry
    -Cleaning Shield Streaming from registry.
    -Cleaning some more stuff from the folder zone of the registry

    AMD only
    -Delete all drivers files in windows directory and sub folders.
    (this will come in next version for Nvidia)
     
    Last edited: Aug 8, 2013

  5. Memorian

    Memorian Ancient Guru

    Messages:
    2,977
    Likes Received:
    178
    GPU:
    Strix 2080 Ti OC
    Nice, thanks
     
  6. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    Release 3.9.1

    -Do not force the reboot and instead ask for it before starting to CleanUp.
    Also explain the reason why it is highly recommended.
     
  7. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    Release 3.9.2

    New buttons
     
  8. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    Release 4.0

    NVIDIA
    -Delete Driver files in windows directory.
    -delete some more registry entry (SharedDlls)

    Nvidia/AMD
    -Possibly fixed a little application hang after CleanUp ( application was
    lagging for a few seconds or until we clicked a few times on it).
     
  9. Han2K

    Han2K Master Guru

    Messages:
    279
    Likes Received:
    1
    GPU:
    MSI GTX1080 GX
    Last time i used it, it wiped out physx too. If current version still does then it would be nice to have a checkbox so you can choose if you actually want to clean it up. Usually there's no need to reinstall physx when updating drivers so it's a little bothersome if the tool is forcing you to do it. Apart form that, very nice tool, keep it up!
     
  10. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    Yes it does wipe physx too.
    I will think on adding a check box.

    Physx sometimes get updated too when updating driver so removing them is not bad.

    Physx take less than 10 sec to install is it really a problem to remove it?
     

  11. Mraz

    Mraz Master Guru

    Messages:
    656
    Likes Received:
    3
    GPU:
    /
    I choose the option to restart after its done, and ticked the box saying delete NVIDIA or AMD folders.

    I got a black screen, and the PC hasnt restarted, I thought it might need more time I left it like that for 10 minutes...nothing.

    Restarted, entered safe mode and saw it said while deleting, that some part of the driver is still in use by an unindentified device and it cannot be removed, unfortunately I havent had the log option ticked.

    You should make the log thing mandatory, that it always saves itself in the folder or whatever, because it only takes a couple of KB's and I cant see it hurting anyone really.

    In the end I cleaned it up through safe mode, and all went well, but there is still one thing I dont understand.

    It still says, not always btw(which is strange) that I have version 318.22 installed on my PC after cleaning it up with this app.
    I simply dont understand why, I guess I will have to do a complete fresh OS installation.
     
  12. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    did you cut the internet connection before cleaning?
    also when in safemode, give me the .log file it generate.


    I will probably make the .log as a default option as you suggested.
     
  13. Mraz

    Mraz Master Guru

    Messages:
    656
    Likes Received:
    3
    GPU:
    /
    Yeah I disabled the internet adapter.

    I dont have the log from safemode...
     
  14. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    can you do in a command prompt a "devcon dp_enum" and give me the result?

    devcon should be located in the x86 or x64 folder in where you installed DDU.
    if not, start DDU(without cleaning anything) it will generate it.

    I may be able to avoid you a fresh o.s reinstall if the bug is simple.

    Btw why you want to reinstall? you have other problems?
    Thanks.
     
    Last edited: Aug 9, 2013
  15. Mraz

    Mraz Master Guru

    Messages:
    656
    Likes Received:
    3
    GPU:
    /
    I found the line what showed up...

    oem60.inf found
    Executing Driver Store cleanUP(Delete OEM)...
    Deleting the specified driver package from the machine failed because it is in use by a device.

    I dont have other problems, all OC's are stable and PC is functioning normally, but ever since that dreaded 318.22 release or whatever it was my PC sometimes would act up, rarely but it does.

    EDIT: In way like its still showing that driver version installed, altough there is none at all in that moment etc.
     

  16. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    We now would need to know what exactly is oem60.inf.
    you can try a "pnputil -e"

    Ya 318.xx is bull...


    oem doesnt reflect what is currently installed. its more like a driver cache. so when you windows rescan for new device it take it from there. That is what the driver store is

    just tell me with pnputil what exactly is oem60 and ill see if I missed something on the cleanUP process or if something is simply jammed on your driver store.
     
    Last edited: Aug 9, 2013
  17. Mraz

    Mraz Master Guru

    Messages:
    656
    Likes Received:
    3
    GPU:
    /
    I found the same line in the old log which I still have, here...

    Btw...I'm not in cmd now cuz I cant nail the path down to where its installed, and alternate version of just running it didnt work.

    Anyway check the old log, and even the older one I have too, shows the same line as not being able to be deleted, really dunno why.

    30.7.2013. 23:40:22 >> OS : Windows 7 or Server 2008r2
    30.7.2013. 23:40:22 >> Architecture: x64
    30.7.2013. 23:41:02 >> DDU Version V3.5
    Uninstalling NVIDIA driver ...
    Executing DEVCON Remove
    DEVCON Remove Display Complete
    DEVCON Remove Audio/hdmi Complete
    Executing Driver Store cleanUP(find OEM)...
    oem4.inf found
    Executing Driver Store cleanUP(Delete OEM)...
    Driver package 'oem4.inf' deleted.

    oem60.inf found
    Executing Driver Store cleanUP(Delete OEM)...
    Deleting the specified driver package from the machine failed

    because it is in use by a device.

    Driver Store cleanUP complete.
    Cleaning process/services...
    Killing Explorer.exe
    Cleaning UpdatusUser users account if present
    The group name could not be found.

    Cleaning Diectory
    Could not find directory 'C:\Users\Svaar\AppData\Local\NVIDIA'.
    Could not find directory 'C:\Program Files\Common Files\NVIDIA Corporation'.
    Cleaning Regkeys
    Starting reg cleanUP
    No value exists with that name.
    No value exists with that name.
    Debug : Starting S-1-5-xx region cleanUP
    Debug : End of S-1-5-xx region cleanUP
    End of Registry Cleaning
    Scanning for new device...
    Clean uninstall completed!

    30.7.2013. 23:41:02 >> Finished.
     
  18. Mraz

    Mraz Master Guru

    Messages:
    656
    Likes Received:
    3
    GPU:
    /
    I think it might be jammed in, cuz it shows that ridicilus 318.22 or whatever the number was.

    This has nothing to do with you or this app what I will say now, but that retarded 318, really messed up a lot of peoples PC's and I read a few posts of people complaining of fried cards etc. this is really unprofessionally done, and I cant believe that happened.
     
  19. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,624
    Likes Received:
    236
    GPU:
    MSI Geforce GTX 1080
    pnputil can be run from anywhere its a system command
     
  20. Mraz

    Mraz Master Guru

    Messages:
    656
    Likes Received:
    3
    GPU:
    /
    Sry bro, it just flashes if you know what I mean, it opens and closes for a second.

    I am not that PC literate, if you can help out a bit more ill be glad to post whatever it shows up.
     

Share This Page