Display Driver Uninstaller Thread

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Wagnard, Jul 14, 2013.

  1. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    I don't think so as I've experience the bug more than once. The normal display driver works fine and the driver I installed previously can also be re-installed however I can't uninstall a driver that's broken.
     
  2. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Do you know when you start running my uninstaller, If the screen blink or if you can see in device manager that the *broken* device get actually remove and then get back? Or it just stay there?


    Also if this is due to some sort of system corruption, even my tool would probably never be able to fix this as anything could have damage the driver.
     
    Last edited: Jul 14, 2013
  3. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Nope it's not a System corruption as I am using a Fresh Version of Windows 8.
    And yes when uninstalling a driver the OS does blink however it does not uninstall the broken driver. (it blinks for the Un-installation of another driver.
     
  4. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Its maybe not system corruption but for sure something went wrong somewhere and since its not the first time its happening im wondering what it is.
    So the driver is stuck in device manager... If you can find the Vend Id i told you earlier for this stuck driver Ill see if I can do something.

    Just be sure too that the blink is not the kill of explorer.exe. It could look like as the display driver was removed.

    Did you found also what keep hold on the file that couldn't be deleted earlier?
     
    Last edited: Jul 15, 2013

  5. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    HydraVision to the files belonging to Hydravision...It's an AMD Package
    The blink is due to the Un-installation of a Driver and the installation of another driver.
     
  6. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Ah ok Ill take care of it. Its true I didn't kill that package. I wasn't using it on my laptop so I forgot this thing existed.

    Ill do this in the next days. My wife is looking at me with aggressive eyes... That means enough computer for today ;)
     
    Last edited: Jul 15, 2013
  7. Krteq

    Krteq Master Guru

    Messages:
    395
    Likes Received:
    13
    GPU:
    R9 290 Tri-X OC
    Wagnard, will your unninstaller do a cleaning of reg entries for hidden (old) devices in a device manager? Those entries causes lot of problems in some cases.
     
    Last edited: Jul 15, 2013
  8. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Why not try it? The tool performs an uninstall in 30 secs to one minute.
     
  9. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Well it should remove stuff from earlier versions. I'm trying to catch them all.
    Next thing to add is an important one that I've forgotten. (hydravision)
    Thank delon for spotting this.

    Can you give me an example of the hidden entry you talk about?

    Also, the project is open so if some people know a little of VB.Net I'll be happy to add you to the project contributor.
     
    Last edited: Jul 15, 2013
  10. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    V1.6.3 Released.

    Big lines : more log, crash fix, Beginning to take care of hydraVision


    ps. For HydraVision , I expect some windows process that may hold some files.
    If so, tell me what are they. I have some here that I know but want to confirm if it always the same for everyone.
    Waiting feedback.
     
    Last edited: Jul 16, 2013

  11. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Before using the uninstall tool the installation of packages always finish without a problem. But now it displays a yellow exclamation mark. Unfortunately AMD Installer never mentioned what caused the problem.
    There I decided to check the Windows log and found the following error below.

    Activation context generation failed for "C:\Program Files\ATI\CIM\Bin64\SetACL64.exe". Dependent Assembly Microsoft.VC80.MFC,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50608.0" could not be found. Please use sxstrace.exe for detailed diagnosis.

    Also this is another fresh OS install previously I used Windows 8 which also had the yellow exclamation mark. Now I'm on Windows 7.
     
  12. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Thanks a lot ! this was bugging be. I couldn't find why the Catalyst installation was giving a Warning. Even so everything work but it was anoying.
    Now I have more details.

    I know its something with the CIM that I don't clean correctly.
    Thanks. I hope it will be enough to find the exact cause and fixed it.
    Like I said tho, it seem everything work without a problem as it is considered a warning.


    EDIT: Under what Tab in the event log you found this? (Application, security ,setup or system? )
     
    Last edited: Jul 16, 2013
  13. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    I found it under application, After installing the driver.
     
  14. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Just in case it bug you before I fix this, you simply have to install the driver with the catalyst installer, than uninstall it from add/remove program. After that reinstall it and you will be green.

    Its something I probably forgot to remove when removing the catalyst installer.

    Btw on my side I could not generated that particular error on the eventlog. It could be a generic error from amd/ccc . it happens sometimes even when everything runs well, but im still investigating.
     
    Last edited: Jul 16, 2013
  15. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    This method worked well when I was on Windows 8, however on Windows 7 the yellow exclamation mark just sits there. So an uninstall through Device manager and the AMD Catalyst Default Uninstaller does not resolve the problem. This bug also appears when uninstalling through Add and Remove.
     

  16. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    For the yellow mark, just to be sure, its on the Catalyst installer you see it. Not on Device manager?


    If its on the catalyst manager. It happened to me that it wouldnt go away and it was because I use my uninstaller with 2 different driver and had to reinstall each driver with AMD catalyst and uninstall each of them with catalyst install manager.
    This included removing the Catalyst install manager too.

    Anyway gona check this a lot more wednesday as im Off that day. SO ill have full time to work on this.
    Thanks for your feedback.
     
    Last edited: Jul 16, 2013
  17. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    No problem.....The bug only appears in Catalyst Installer/Uninstaller.
     
  18. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    1.6.4 Released.

    -Fixed a possible hang when uninstalling the driver from the driver store. (affect both AMD / Nvidia)

    +more stuff you can read from the SVN on google code.

    As for the yellow mark on Catalyst installer , im still researching the cause. I did found ther regkeys to delete about CIM. Those key get cleanUP in 1.6.4 too.

    I've open a support Ticket with AMD to have more info on those warnings that doesnt show on the CIM normal log.
    Lets hope I get something back...
     
  19. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    OMG after DAYS of searching, tracing, etc... I think I finally found the cause of the Yellow mark and i'll be able to fix it !

    PS : even driver sweeper doesnt fix it ;D Im superior !

    Sorry for the ego ;p

    Ill release a new version when im 100% sure its fixed.
     
  20. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,434
    Likes Received:
    50
    GPU:
    MSI Geforce GTX 1080
    Release V2.0

    Fixed the AMD Catalyst installer Yellow mark.
    This fix has the potential to fix the same problem with people that didn't even used a cleaner before and are experiencing this yellow mark.

    p.s Driver Sweeper does not fix it but I do ;)

    First post link updated
     
    Last edited: Jul 17, 2013

Share This Page