Display corruption when using adapter.

Discussion in 'General Hardware' started by Terje_P, Jun 7, 2019.

  1. Terje_P

    Terje_P Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    GeForce GTX 970 SLI
    Really specific issue here.

    When using a dp port to dual link dvi adapter https://www.amazon.com/DisplayPort-Dual-Active-Adapter-Converter/dp/B00A493CNY/ and Edge Dev Channel, certain youtube videos will cause display corruption.

    The problem persist until I close the tab, simply going to another site in the same tab won't fix it.

    https://ibb.co/mF1wyqN

    I don't get the same corruption when using my 4k AOC monitor that is also connected.

    Opera works on both monitors.

    1080
    Windows 10 1903 18912.1001
    435.27.

    Games and other applications works fine on the monitor, it is only certain videos which is triggering it. The image looks fine in screenshots though, so the issue seems to happen in the adapter.

    Video in question


    Works in normal Chrome Dev Channel too. The same video embedded here don't cause the issue either.

    Happens with the 430.97 driver too.
     
    Last edited: Jun 7, 2019
  2. Terje_P

    Terje_P Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    GeForce GTX 970 SLI
    Decided to just use Google Chrome instead which it doesn't happen in. The main reason I was using the adapter was to see if any adapter like that actually work, If I decide to upgrade to a videocard without native Dual Link DVI ports.
     
  3. metagamer

    metagamer Maha Guru

    Messages:
    1,237
    Likes Received:
    467
    GPU:
    Palit GameRock 2080
    You'll be better off just getting a gpu with DP anyway, in the long run. These adapters, even the active ones like yours will eventually struggle with high refresh rates for most. Some claim successfully running 120hz or so at 1440p but many have issues even at 60hz.
     
  4. Undying

    Undying Ancient Guru

    Messages:
    12,272
    Likes Received:
    1,795
    GPU:
    Aorus RX580 XTR 8GB
    Im using the same adapter for my second monitor, never had any issues with it.
     

Share This Page