Disabling HPET in BIOS doesn't do anything with new PC.. old PC was laggy as hell doing this - why?

Discussion in 'Operating Systems' started by xShino, May 14, 2021.

  1. xShino

    xShino Member

    Messages:
    19
    Likes Received:
    1
    GPU:
    RTX 2070 Super
    Maybe someone can help me with this because I don't understand it.

    On my old PC with the ASRock B85 Pro4 mainboard when setting HPET Off in BIOS, my OS was really slow and the games were stuttering.

    With my new PC, with the ASRock Z390 Steel Legend and ACPI HPET Table set to "Off" in BIOS, there is no difference to HPET On.

    I have tried many different BCDEDIT settings to replicate the "BIOS HPET OFF Lag", but I couldn't succeed yet. The only thing I know is that I have the laggs with "bcdedit /set useplatformclock yes", regardless of the BIOS HPET Table setting.

    Why is that? Any explanations to this? Why doesn't the BIOS HPET Table setting do anything?

    Old PC specs:
    http://www.sysprofile.de/id177485

    Current PC specs:
    CPU: Intel i7-9700K
    CPU cooler: Cooler Master Hyper 212 Black Edition
    GPU: Gigabyte RTX2070 Super
    RAM: 16GB GSkill Flare X DDR4 - 3200 (2x 8GB)
    Mainboard: ASRock Z390 Steel Legend
    PSU: Corsair RM650
    Storage: 1000GB Crucial P1 NVMe M.2 2280
     
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,808
    Likes Received:
    8,062
    GPU:
    GF RTX 2070 Super
    Obviously, your new rig got some powerful/hardware accelerated/next gen/boosted/alien HPET implementation.
    :cool:
     
    Smough and cucaulay malkin like this.
  3. xShino

    xShino Member

    Messages:
    19
    Likes Received:
    1
    GPU:
    RTX 2070 Super
    Sorry - what does that mean exactly? I am trying to fix my mouse Input Lag/Smoothing/Acceleration issue since about 2 years but couldn't manage to do so yet. I feel like knowing how to replicate the BIOS HPET OFF > OS lag / ingame stutter, might help in the future.
     
  4. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,808
    Likes Received:
    8,062
    GPU:
    GF RTX 2070 Super
    When HPET Off in BIOS you can get more problematic behaviour than with HPET On only on flawed hardware, as I take it.
    Setting in BIOS should not affect Windows because if all hardware is good OS will not use HPET for time stamping tasks.

    With "bcdedit /set useplatformclock yes" you force Windows to use either HPET or other platform timers in time stamping tasks - and that should worsen the behaviour of OS.
     
    xShino likes this.

  5. Passus

    Passus Ancient Guru

    Messages:
    1,765
    Likes Received:
    525
    GPU:
    RX 5700 Mech OC
    I think it now an old tweak that only really helped on some hardware

    never really saw any difference myself over my last 3 rigs ..4790k on h97 based system and fx 6300 (cant remember chipset) based system and my current 3700x based system on x570

    new systems and windows do not have the old issues
     
  6. xShino

    xShino Member

    Messages:
    19
    Likes Received:
    1
    GPU:
    RTX 2070 Super
    I see, then I will stop putting more time into HPET I guess. Thank you for your help.
     
    Passus likes this.

Share This Page