Disable DirectX features (acceleration) Windows Vista / 7

Discussion in 'General Software and Applications' started by tweakpower, Oct 30, 2010.

  1. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    WARNING:
    Disabling AGP Texture Acceleration can introduce/resolve lag and/or frame skips depending from system and game in question, but, you can always revert it.

    Forget about files, they are not needed, post edited. Here is how:

    For x86 systems:


    For x64 systems:

    Disable:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DirectDraw]
    "DisableAGPSupport"=dword:00000001
    Enable:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DirectDraw]
    "DisableAGPSupport"=dword:00000000
    To check if it worked type "dxdiag" into search/run command, it should look like this:

    [​IMG]
     
    Last edited: Nov 5, 2012
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,492
    Likes Received:
    1,541
    GPU:
    ROG Strix 1080 OC
    Dont mean to sound rude, but why would anyone want to do this ?
     
  3. Finchwizard

    Finchwizard Don Apple

    Messages:
    16,438
    Likes Received:
    7
    GPU:
    -
    I was thinking the same thing.
     
  4. F1refly

    F1refly Ancient Guru

    Messages:
    9,042
    Likes Received:
    0
    GPU:
    970GTX-oc edition
    he said he saw people ask about it on other forums...so maybe their questions would show this thread to make sense. maybe theres specific issues with dx9 mode in games with low end dx10/11 capable hardware?
     

  5. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    There is specific issues with (some) DX9 games and Vista/7 as F1refly said, and i was unable to find solution on any thread, so when this worked out, just decided to post if someone need that.

    That was the goal ;)
     
  6. scatman839

    scatman839 Ancient Guru

    Messages:
    14,115
    Likes Received:
    510
    GPU:
    1080, KD55XD800
    Doesn't disabling desktop composition in the shortcut properties just do the same thing
     
  7. Pzykotik

    Pzykotik Ancient Guru

    Messages:
    2,569
    Likes Received:
    0
    GPU:
    ZOTAC RTX 2070 AMP
  8. F1refly

    F1refly Ancient Guru

    Messages:
    9,042
    Likes Received:
    0
    GPU:
    970GTX-oc edition
    i wonder how many people with game issues never realizing this being a cause? Another cause of game issues i've had is with DEP yet hardly occurs to me to add it to the DEP allow list.
    I dislike PC gaming more and more sometimes, too many damn issues pop up, yet is how i learned so much about Windows to begin with, i can't imagine how it is for non tech gamers and kids, no wonder consoles sell more games.
     
  9. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    And most of the problems on PC gaming are from M$ not implementing old good features just to let user to have more control over hardware. Basically, what this thing do (my guess) is preventing RAM to interfere in GPU processing with VRAM, and on PC's with high end components (very fast DDR2 or DDR3) is less notable or not notable at all.

    Still need your help to disable "Shared System Memory" just for testing purposes, so if someone have a clue where to begin with it will be very appreciated. I do hope we will have this option in SP1.
     
  10. thomsip

    thomsip New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    dfdsfs
    after I did all this and I try to disable "AGP Texture Acceleration" I get a message only administrators may do this. However, I even used a command line to get the rights to even change the file.

    Anyone?
     

  11. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Well, i don't know what method you used to start DirectX Diagnostic Tool, if you did through run command typing "dxdiag", try to run dxdiag.exe in your system32 folder by right click "run as administrator" (are you sure your account have administrator privileges?), if not try otherwise (through run command). I hope this will help you, can't think off anything else now, if not, maybe someone else have better suggestion.
     
  12. thomsip

    thomsip New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    dfdsfs
    I tried going to the system 32 folder and pressing "run as administrator"

    here are the settings, and the error msg (sorry theyre in dutch =/ )

    [​IMG]

    [​IMG]
     
  13. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    No Problem, i can't understand dutch (few words maybe ;)), but i think you cant turn off this because you use integrated graphics, and that use your system RAM anyway, so there is no point to turn off AGP T.A. Maybe im wrong, never tested myself thought, but that's the case here i believe.
     
  14. Mineria

    Mineria Ancient Guru

    Messages:
    4,165
    Likes Received:
    107
    GPU:
    Asus RTX 2080 Super
    I think one of the hotfixes released a few months ago fixed the shared memory to video memory issue.
     
  15. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Thanks for suggestion, I've just tried recommended updates and they didn't change anything. The problem is that Windows Memory Management works that way, and it's not in MS (AMD, nVidia...) interest to change it, and i doubt they will. One day maybe someone will, till than i gave up on this one.
     

  16. Watcher

    Watcher Ancient Guru

    Messages:
    2,578
    Likes Received:
    219
    GPU:
    Gigabyte Windforce R9 380
    There is a Registry Key that allows you to Disable " AGP Texture Acceleration " . You do not have to replace any files to allow you to change this setting.

    Open notepad and copy the following text:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectDraw]
    "DisableAGPSupport"=dword:00000001
    Save it as " AGP Texture Acceleration Disabled.reg " in a location that you will be able to navigate to at a later time. Make sure to save it with the file extension of " .reg "

    Now with Window Vista and up, I find that the best way to apply the registry settings is to type in the search box in the start menu " regedit " which will show the result as " regedit.exe " Right click on the result and " run as an administrator "

    Registry editor will now open. Then use the top " File " menu and then import the file from were you have saved the above file. Then close Registry editor after the import of the file is finished.

    I find that if you double click or right click merge on a " .reg " file in Windows Vista and up, the file does not always enter the value into the registry. You can try and see if the double click or right click merge works for you.

    Run dxdiag.exe and you will see " AGP Texture Acceleration " is disabled

    If you want to turn " AGP Texture Acceleration " back to enabled,

    Open notepad and copy the following text:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectDraw]
    "DisableAGPSupport"=dword:00000000
    
    Save it as " AGP Texture Acceleration Enabled.reg " in a location that you will be able to navigate and import the file into the Registry. Make sure to save it with the file extension of " .reg "
     
  17. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Thank you for sharing Watcher ;). I've just tested it and it works for me (didn't test with games just via dxdiag), i will edit first post and leave files to have both solutions just in case one of them don't work for someone (like mine for thomsip).
     
  18. stormy

    stormy Ancient Guru

    Messages:
    2,593
    Likes Received:
    23
    GPU:
    Pulse RX5600XT
    It may be "shared", but it isn't used until you run out of physical video memory. Think of it as sort of a pagefile for video memory, and as I understand it works in a similar fashion as the old AGP aperture setting.

    Might want to read the white paper on how it is calculated and used linked here,

    http://www.microsoft.com/whdc/device/display/graphicsmemory.mspx
     
  19. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Well, it would be nice to have a option to disable it, or some sort of workaround, the thing is i doubt that memmory managment is so perfect, in my opinion this managment is only good for forcing users to buy new hardware when they do not need ;)
     

Share This Page