Disable Deep Sleep States Using MPT Can Potentially Remove Stuttering

Discussion in 'Videocards - AMD Radeon' started by Eastcoasthandle, Jun 1, 2021.

  1. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,925
    Likes Received:
    518
    GPU:
    Nitro 5700 XT
    I stumbled upon a reddit post that suggest that disabling something called deep sleep states has the potential to remove stuttering as it will prevent the gpu from going into deep sleep while you are in a 3d environment. My skepticism kicked in because I simply found it hard to believe that the gpu would cycle between deep sleep and active states. But I gave it a shot. To my surprise I noticed almost no gpu clock fluctuation, steady frame rates and overall improved response times in Modern Warfare.

    Now, I am still testing this. And, Radeon Software Vanguard is investigating disabling the DS flags. But I still believe it was worth mentioning because it doesn't hurt to try. Since the post about a month ago I cannot confirm if there was any immediate changes in the driver to reflect changes to this. However, as it stands now the procedure to do this is fairly simple.

    Step 1:
    Download MorePower Tool (MPT) from Igor's Lab: https://www.igorslab.de/en/red-bios...en-more-stable-overclocking-navi-unlimited/3/ (Scroll down)
    Download GPUz: https://www.techpowerup.com/gpuz/

    Step 2:
    Open GPUz and save a copy of your bios to desktop: There is an icon of an arrow inside a box. Click on that to Save Bios. It is between Bios Version and UEFI.

    Step 3:
    Exit out of GPU. Install MPT. Start MPT. Select your GPU from the scroll down at the top of the program. Click the Load button. Load your Bios saved file from GPUz.
    Go to: Feature Tab > Click Feature Control Button​
    To keep the GPU from going into deep sleep do to "lightly gpu loaded games that might be CPU intensive" you uncheck All "DS_..." options. The ones I found for my 5700xt are called:
    • DS_GFXCLK
    • DS_SOCCLK
    • DS_LCLK <---already disabled (for me)/unchecked
    • DS_DCEFCLK
    • DS_UCLK <--already disabled (for me)/unchecked
    Click OK > Click Write SPPT > Click Exit > Reboot PC > Play Games

    To undo the changes: Start up MPT > Select you GPU > Delete SPPT > Reboot PC

    This makes changes to the registry not the bios of your video card. I did not notice increase FPS.

    Caveat:
    I cannot tell you what DS flags you have on other non 5700 series GPUs. So be careful to select those flags that only start with "DS_...".

    Radeon Software Vanguard is/was investigating this so it's possible that by the time you read this (at some future date after posting this). Some/All of those flags might be unchecked already in newer drivers.

    This thread is only discussing deep states. Nothing else!!! I understand that MPT does more then this. However, lets keep the conversation steered in one direction.


     
    Last edited: Jun 1, 2021
    JonasBeckman, A2Razor and gfxzett like this.
  2. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,735
    Likes Received:
    1,018
    GPU:
    6800XT Nitro+ SE
    Just to add to the discussion for Navi21 owners you will have A LOT more DS... options in MorePowerTools.

    I have a 6800XT and have the following options;

    DS_GFXCLK
    DS_SOCCLK
    DS_FCLK
    DS_LCLK
    DS_DCEFCLK
    DS_UCLK

    All of them were ticked and enabled, I have had these disabled for quite a while and to be honest it doesn't change much at all. My GPU still clocks down when idle at desktop and still clocks down when playing certain untaxing games.

    Also this "tweak" needs to be done after every driver install.
     
    gfxzett likes this.
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,976
    Likes Received:
    4,051
    GPU:
    GTX 1080ti
    This shouldn't be happening under load in the first place.
     
    CPC_RedDawn and gfxzett like this.
  4. gfxzett

    gfxzett New Member

    Messages:
    9
    Likes Received:
    14
    GPU:
    6900XT MERC BLACK
    ... but it (sadly) happens - at least to me, I call it "agressive downclocking" ;-) and reported multiple scenarios to reproduce it to AMD. With less demanding (mostly DX11) games the GPU clocks (and volts) to "2d" for some ms (while pushing 144fps) than ramps up again to the 2000s (-> stutter or even crash in rare case). I'm not sure whether this (and other) settings currently work in MPT/SPPT for 6000 series right now. Maybe that is the reason the results on 5000 series are more pronounced/noticeable. Idk... but I will test and compare it, too.
     

  5. GSDragoon

    GSDragoon Master Guru

    Messages:
    317
    Likes Received:
    163
    GPU:
    AMD Radeon RX 6800
    Very interesting idea here. I'm curious how this would apply to situations with multiple monitors and switching between say a game and a browser. Many times games will cap fps to a much lower number when not in focus. Could that trigger a deep sleep state? Is there any way to view when this happens? I used to get game crashes fairly often with the VII, but not really with the 6800, when switching between a game on one screen and something else on another screen. I do notice occasionally some weird pauses when it comes to switching when there's a video playing on the other screen.
     
  6. X7007

    X7007 Ancient Guru

    Messages:
    1,636
    Likes Received:
    38
    GPU:
    Sapphire 6900XT
    does it fix any of the stutterings with 6900xt and 6800xt?
     
  7. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,925
    Likes Received:
    518
    GPU:
    Nitro 5700 XT
    hmm, i think the fix for that is to keep both max/min frequency no more then 100mhz apart.
     
  8. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,595
    Likes Received:
    427
    GPU:
    MSI 5600XT G. MX
    See if it's not this

    https://forums.guru3d.com/threads/r...wnload-discussion.438436/page-10#post-5923768
     

Share This Page