Did Amd fix the usb issues already......

Discussion in 'Processors and motherboards AMD' started by The Goose, Mar 26, 2021.

  1. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Since changing to an Msi x570 Unify and a Ryzen 7 5800x a few weeks ago i`ve had issues with what i thought was Icue and Msi Dragon center playing silly buggers.

    I play the division 2 and run with Icue lighting enabled for my Corsair rgb fans/led lighting/H115i platinum using the games built in color profile and Msi`s mystic lighting for my Msi 3070 gaming xtrio( sometimes works....sometime does not) but after leaving the game my Corsair K70 lux keyboard rgb would only show red lighting and the rgb on my Corsair h115i platinum cooler would go in to spasm, more often than not the h115i`s waterblock lighting would just turn off but after installing the latest beta bios for my board MEG X570 UNIFYE (MS-7C35) V10.92 BIOS all my rgb rainbow goodness is working fine after closing down the game,

    bare in mind that my Corsair k70 lux keyboard is connected to rear usb 3.0 but my lighting node pro and h115i are connected to a usb 2.0 header via a splitter.

    Updating to the most recent Icue and Dragon center made no difference to the glitchs in my rgbness prior to updating my bios, so just wondering if they nailed the usb issue already before the April release.
     
  2. Kool64

    Kool64 Maha Guru

    Messages:
    1,092
    Likes Received:
    421
    GPU:
    Gigabyte RTX2070S
    The fix is on AGESA code 1.2.0.2 so if you have a bios with that version there is the fix.
     
  3. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    The only details Msi have provided on the bios is......

    MEG X570 UNIFYE (MS-7C35) V10.92 BIOS Release
    -------------------------------------------------
    1. This is AMI BIOS release
    2. This BIOS fixes the following problem of the previous version:
    - Update to ComboAM4PIV2 1.2.0.1 Patch A.
    3. 2021/03/23

    Ive had my system on for 7 hours now and anything connected to a usb port or onboard header is functioning properly
     
  4. wavetrex

    wavetrex Maha Guru

    Messages:
    1,431
    Likes Received:
    1,071
    GPU:
    Zotac GTX1080 AMP!
    1.2.0.1 Patch A fixed it - I have all my ports back and they all work as expected.
    5800X, Asus B550 - confirmed
     
    Maddness, PrMinisterGR and The Goose like this.

  5. Kool64

    Kool64 Maha Guru

    Messages:
    1,092
    Likes Received:
    421
    GPU:
    Gigabyte RTX2070S
    Ahh that’s good that it’s 1.2.0.2 they snuck it into an earlier than intended version.
     
  6. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Oh well,another day of red leds on my k70 lux so looks like the bios fix didn't fix things.
     
  7. Passus

    Passus Ancient Guru

    Messages:
    1,809
    Likes Received:
    540
    GPU:
    RX 5700 Mech OC
    Never had any usb issues on my rog strix x570-f and installed all bios updates as they came along
     
    CPC_RedDawn likes this.
  8. Hog54

    Hog54 Maha Guru

    Messages:
    1,194
    Likes Received:
    39
    GPU:
    Asus Tuf RTX 3070
    Neither have I had any problems with any bios on my asus rog strix x570i.
     
    Passus likes this.
  9. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,814
    Likes Received:
    706
    GPU:
    Inno3D RTX 3090
    I don't have issues either, but that doesn't mean that there is no issue.

    AMD admitted it exists.

    @The Goose does the bios mention anywhere that this is fixed? Some manufacturers chose to backport this to AGESA 1.2.0.1 Patch A, but as far as I understand the "official" AMD fix is in AGESA 1.2.0.2.

    I would recommend submitting it as a but to AMD directly, if it doesn't fix all cases they might as well know about it.
    Does your equipment work OK with the control programs for the stuff uninstalled?
     
  10. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,938
    Likes Received:
    4,030
    GPU:
    GTX 1080ti
    lots of people had skipping mice, usb capture and headsets due to this issue.
     

  11. Passus

    Passus Ancient Guru

    Messages:
    1,809
    Likes Received:
    540
    GPU:
    RX 5700 Mech OC
    Of course im not implying nobody had issues just that i have been lucky with it
     
  12. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,938
    Likes Received:
    4,030
    GPU:
    GTX 1080ti
    no, thats fine, im actually aware of many people that haven't, but i've personally reproduced the issue while building a machine and fixed it by swapping the cpu out XD
     
    Passus likes this.
  13. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Most of my usb disconnects i worked around by disabling usb power management, the keyboard lighting issues seem to be a conflict between Msi and Corsair software, my last Msi gpu and no lighting so i did not bother with Msi dragon center, both pieces of software have recently been updated so im t testing them today.
     
  14. Passus

    Passus Ancient Guru

    Messages:
    1,809
    Likes Received:
    540
    GPU:
    RX 5700 Mech OC
    The new iCUE version 4 is out but it has a very plain interface

    I only have an h100i that uses it and only 1 device leaves a big empty box with a small icon for the h100i lol
     
  15. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Hi, I`ve had similar issues several times on different versions.....not a fan of v4, but i usually start with a clean install, the h100i has the link cable....try unplugging it from the block end and re inserting to initialize usb detection.

    have a gander at this list.......unfortunately.....I think your on it.

    https://forum.corsair.com/v3/showthread.php?t=205023

    Apart from from the simplified interface they also added Msi mobo support.....the plugin alone sucks up 9% cpu usage and thats just to supposedly control mystic lighting on the mobo....my Unify does not have rgb so i deleted the msi folder in the icue folder(have to stop the plugin process in task manager first)

    Some one told me there cpu usage was higher than mine.
     
    Last edited: Apr 3, 2021
    Passus likes this.

  16. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Yesterday i had a ton of disconnects/resets on my Corsair H115i plat which is on a usb splitter with my corsair node which in turn controls my 5 corsair ml140 hd rgb fans and my corsair led strips(4 strips on 1 channel), never had an issue with my fans but the leds have been problematic although today i`ve had 0 issues from the internal usb headers.

    Wondering if a commander pro might be a better solution.
     
  17. jura11

    jura11 Ancient Guru

    Messages:
    2,595
    Likes Received:
    668
    GPU:
    RTX 3090 NvLink
    I would have look on Aquacomputer HUBBY7, its great internal USB hub with 7 internal USB ports

    Regarding the Corsair CommanderPro or anything from Corsair I usually staying away from them

    Aquacomputer Aquaero is in my loop, if you are want to control everything then Quadro or Octo8 from Aquacomputer will do beautiful job and for RGB control RGBpx is great

    Hope this helps

    Thanks, Jura
     
  18. Passus

    Passus Ancient Guru

    Messages:
    1,809
    Likes Received:
    540
    GPU:
    RX 5700 Mech OC
    Luckily I have the H100i Pro Platinum and it is supported

    I just think the v4 interface is so very plain and empty with just 1 device
     
  19. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Did you try the clean install
     
  20. The Goose

    The Goose Ancient Guru

    Messages:
    2,768
    Likes Received:
    209
    GPU:
    MSIrtx3070 gaming X
    Screenshot (1).png
    Might not be a bad thing
    [​IMG]
     

Share This Page