Deferred AA BF3 crash

Discussion in 'Videocards - AMD Radeon Drivers Section' started by MadelineX, Dec 12, 2011.

  1. MadelineX

    MadelineX Master Guru

    Messages:
    259
    Likes Received:
    0
    GPU:
    Sapphire 295x2
    For a long time now I had issues with BF3 launching. Occasionally, I could get it run in multiplayer, but after repeated attempts. Generally though, it would encounter a driver no responding message, or a bsod right when the map was about to display after loading.

    After getting into the game by deleting my .ini file, I enabled the in game settings one by one. Everything to ultra. When I reached deferred AA x2 I started getting black bars on the screen by 4x the game hardlocked.

    I notice that when aa is enabled the game won't lauch. Disabled it lauches fine. When enabled again in game (multiplayer only) the game will continue to lock or corrupt.

    Would this be my own system specific error? Driver? Or game?

    Thanks!
     
  2. aaronbond

    aaronbond Member Guru

    Messages:
    192
    Likes Received:
    0
    GPU:
    XFX 5850 1GB 765/1115
    Are you running stock clocks? Not OC'ed too hard on your VRAM?
     
  3. MadelineX

    MadelineX Master Guru

    Messages:
    259
    Likes Received:
    0
    GPU:
    Sapphire 295x2
    I reset to stock speeds and tried that for awhile, but still encounter the same issue.

    usually I run 925/1375. Stock goes to 880/1250 ( for the 6990).
     
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    7
    GPU:
    7950 Vapor-X 1100/1500
    Can you check your Event Log?

    Also it might pay to run the game w/ your GPU clocks at stock, to rule out unstable overclock...
     
    Last edited: Dec 13, 2011

  5. antihero998

    antihero998 Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    EVGA SC 780
    I'm having the same problem has any one got any clue to whats going wrong?
     
  6. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,879
    Likes Received:
    478
    GPU:
    RX Vega
    If you check the known issues section of the last few catalyst drivers you'll find that bf3 crashing at ultra settings in mentioned.
     
  7. dade_kash_xD

    dade_kash_xD Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    2x XFX DD R9-280x 3gb
    I have been having the same exact issue since the Beta. The moment I enable AA, I get a driver crash error. Recently however, I have been able to enable AA up to 4x but as soon as I do, I get crazy artifacts and weird pixelation. So, I just leave AA off completely. Let me know if you ever find a solution, because I have searched these forums and google tirelessly to no positive effect.
     
  8. antihero998

    antihero998 Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    EVGA SC 780
    I'm not sure if it's a driver issue as it just started yesterday after working form launch with out a problem. I'll try rolling back to see if that helps.
     
  9. MadelineX

    MadelineX Master Guru

    Messages:
    259
    Likes Received:
    0
    GPU:
    Sapphire 295x2
    My work around has been to disable deferred AA and save a copy the config with it disable. I always have it disabled upon launch. Then, when in game I enable the setting and it runs fine.

    Before I fire up the game again I just replace the config with the backup I made, (just in case I have forgotten to disable DFAA on the way out.)

    Annoying, but functional. Just like the game itself.
     
  10. heroxoot

    heroxoot Master Guru

    Messages:
    442
    Likes Received:
    0
    GPU:
    EVGA 1080ti SC2
    Try using BF3 settings manager by realmware. I don't understand why you have to turn it off each time. You should be able to disable it once and be done.
     

  11. MadelineX

    MadelineX Master Guru

    Messages:
    259
    Likes Received:
    0
    GPU:
    Sapphire 295x2

    Oh, it stays disabled. Didn't mean to make my last statement so convoluted. I just like the look of it enabled. The game itself want launch without crashing while it's enabled, but works fine if you enable the setting after the level loads.
     
  12. zhengzhoudave

    zhengzhoudave Master Guru

    Messages:
    608
    Likes Received:
    0
    GPU:
    4GB EVGA GTX680 FTW 2xSLI
    I think it must be the game, the multiplayer has had some issues! Generally I find the actual code quite driver friendly!
     

Share This Page