Dead Space 2 low gpu usage

Discussion in 'Videocards - NVIDIA GeForce' started by ..VeNoM.., Jan 29, 2011.

  1. ..VeNoM..

    ..VeNoM.. Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    ASUS GTX 690
    Just installed dead space 2 (loving it by the way) and I topped all the settings and put it in 5.1 surround sound then enabled v-sync. Loaded up EVGA Precision to monitor my GPUs and FPS. The first thing I noticed is that my FPS is capped at 30 not 60 and my gpu usage is about 10-20%, it's that low that it downclocks my GPUs. I changed the profile to enable max performance but I find it strange that such a good looking game hardly pushes my 260's. Why is are my frames capped to 30 and not 60??

    Anyone else?
     
  2. Wanny

    Wanny Guest

    It really is not pushing cards that much. Yes, you can believe it that such graphics can run that good.
     
  3. TekkamanBlade

    TekkamanBlade Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    MSI 560ti Twin Frozr
    Disable the in-game v-sync option and use D3doverrider for v-sync.
     
  4. Sever

    Sever Ancient Guru

    Messages:
    4,826
    Likes Received:
    0
    GPU:
    Galaxy 3GB 660TI
    dude, youre running vsync. if your card can render sufficient frames to hit the framerate cap with only 10-20% of the card's processing power, then obviously the load on your gpu will only be 10-20%.

    use the nvidia control panel to make a profile and force vsync, or use nvidia inspector. these methods will cap it at 60fps.
     

  5. aayman_farzand

    aayman_farzand Master Guru

    Messages:
    828
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FTW
    I had the exact same questions as you do. Low GPU usage but constant 30FPS with great graphics running at 1920x1080.

    I'll try those other VSync options and how it works out.

    Edit: I just tried it without ingame VSync and get 100+ FPS at all times. Forcing through the NVCPL locks it at 60, so thats what we should be using :)

    Great optimisation, hats off to EA!
     
    Last edited: Jan 29, 2011
  6. Pete J

    Pete J Master Guru

    Messages:
    439
    Likes Received:
    10
    GPU:
    Some of those as well
    Dead Space and Dead Space 2 are bloody (pun, eh) marvels of coding. What makes it even more amazing is the fact that they are console ports and don't suffer for it. The original, when run without Vsync, runs at about 700FPS+ on my rig with everything on high at 2560x1600 - and that was with 480s, which were the bottleneck -the CPU was still doing bugger all.. Mind you, the mouse was stupidly slow at these framerates so I force Vsync through the drivers - a smooth 60FPS.

    It's just a shame that the engine still doesn't have proper anti-aliasing support. Still, I'm loving Dead Space 2! I've made it to chapter 4 so far.
     
  7. Corbus

    Corbus Ancient Guru

    Messages:
    2,455
    Likes Received:
    69
    GPU:
    Ref 6900 XT
    the game uses the old Godfather engine which doesnt push gpus that much also the handicapped Vsync of deadspace caps the game at only 30 frames...so imagine its not that hard for a gtx 260 to achieve 30 frames...disable vsync i personally didnt find any screen tearing problems with the game
     
  8. _CH_Skyline_

    _CH_Skyline_ Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    3x 3GB GTX 580 3way-SLi
    This game seems to tax my cards more than DS1. I could run DS1 in 2D Surround with a constant 60+ fps @ 5960x1200, while in DS2 it's more like 35-50 fps (depending on the room up to 85 fps). There is no lag though. The nice thing is that my cards are literally up to 85-99% usage in Tri-SLI. I guess the extra video options are really showing their potential there.
     
  9. ..VeNoM..

    ..VeNoM.. Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    ASUS GTX 690
    I ended up using the nvidia control panel to force vsync and now it's 60fps.. however has anyone noticed that this game seems to be using a single core on the CPU?.

    Just played from chapter 4 to chapter 6 in the dark with my headphones on... I have to say I might have poo'd myself on more than one occasion :)
     
  10. buddyfriendo

    buddyfriendo Ancient Guru

    Messages:
    3,394
    Likes Received:
    0
    GPU:
    EVGA GTX 480 SC
    This.

    I'm really getting sick of all these threads complaining about GPU usage being low when VSync is turned on. Perhaps it's time for a sticky or something, it's almost as if common sense is GONE. :bang:
     

  11. ..VeNoM..

    ..VeNoM.. Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    ASUS GTX 690
    I know it was because of V-Sysnc being enabled.. That's why I mention it was being limited to 30FPS... Jesus dude, take a pill and chill
     

Share This Page