D3DOverrider + Windows 8

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by dreamslides, Sep 9, 2012.

  1. dreamslides

    dreamslides Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD/HD/6480G
    It doesn't seem to be working for me, though I'm not certain. I know I hear no chime when it should load and the games still aren't seeming effected yet.

    My problem is on my HDTV with my GTX 670 when I move around it shows some tearing, I know many say this is due to drops in FPS but honestly it seems to happen no matter the FPS, it's just bad rendering. However in Windows 7 I use to have Triple Buffering forced on and this prevented that effect.

    Anyways does anyone know if it works in Windows 8?
     
  2. rewt

    rewt Maha Guru

    Messages:
    1,245
    Likes Received:
    0
    GPU:
    Enable Vsync, because it's vsync that prevents tearing not triple buffering.
     
  3. marcosamerio

    marcosamerio Master Guru

    Messages:
    679
    Likes Received:
    0
    GPU:
    EVGA NVIDIA 680 GTX
    Do like say rewt, enable triple buffer and limit ur fps to avoid spike fps

    and little input lag that can be introduced because vsync.

    Bye
     
  4. dreamslides

    dreamslides Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD/HD/6480G
    I answered my own question here :/ I installed Windows 7 and took 8 off, now it works fine and there's no tearing.

    I do have adaptive vsync with this 670 so I don't see how that's the issue, I know that whenever I enable triple buffering it always worked before to eliminate tearing but I thought I wouldn't need it with this expensive a card, guess it has something to do with it.

    But yea it's fine, but this is the most perplexing thing I've ever seen, my PC is brand new and does the same thing my laptop does A8-3500M 6620G unless triple buffernig is enabled I see tearing in games, oh well........ even using Precision X to limit the frames to 60 I still saw tearing obviously hardware isn't so great

    Bye
     

  5. rewt

    rewt Maha Guru

    Messages:
    1,245
    Likes Received:
    0
    GPU:
    Because with "adaptive" vsync, vsync deactivates when frame rate falls below refresh rate, and you still get tearing. If someone told you that tearing only occurs at fps above refresh rate then you are both sorely mistaken.

    The hardware isn't the problem, it's your misunderstanding of the feature set. Limiting FPS doesn't completely eliminate tearing either. Only standard vsync does. Limiting FPS with adaptive vsync can actually cause tearing (because of the reason above).

    Good job, now you're getting somewhere. :)
     
    Last edited: Sep 10, 2012
  6. Anarion

    Anarion Ancient Guru

    Messages:
    12,922
    Likes Received:
    2
    GPU:
    EVGA GeForce GTX 1070 ACX
    When I tested, D3DOverrider worked just fine W8. If I remember correctly that is.
     
  7. d0X

    d0X Member Guru

    Messages:
    164
    Likes Received:
    2
    GPU:
    Asus RX480 8GB
    Been using it with Sleeping Dogs and Windows 8 Pro x64. Seems fine to me.
     
  8. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    0
    GPU:
    570m / MSI 660 Gaming OC
    limiting to 60 does not remove tearing

    TB does not remove tearing, vsync does, TB lets you not jump to 30fps from 60 (d3do with TB on & vsync off shouldnt do anything unless the game is set to have vsync in its settings)

    http://forums.guru3d.com/showthread.php?t=367308 still not sure if d3do works in win8 or not
     
  9. dreamslides

    dreamslides Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    AMD/HD/6480G
    I'll try running some tests soon on Star Wars Force Unleashed and let you guys know. I do remember when I enabled TB it always stopped tearing so idk what to think, and anyway I must research more.

    I didn't hear the chime in Windows 8 indicating d3doverrider was active, also saw no results in games. Anyway ttyl
     
  10. Anarion

    Anarion Ancient Guru

    Messages:
    12,922
    Likes Received:
    2
    GPU:
    EVGA GeForce GTX 1070 ACX
    Like guys have said, enabling triple buffering alone will do nothing. Force Unleashed is capped at 30 FPS by the way.
     

  11. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    I tried D3DOverrider with Witcher 2 in Windows 8 RTM Evaluation 64 bit and it works perfectly TB+Vsync. Have vsync turned off in the settings of the game and also in the Nvidia control panel.

    Wonder what the problem was with setups in the older thread where there were multiple reports of it not working on Windows 8?
     
  12. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,667
    Likes Received:
    35
    GPU:
    Inno3d GTX 1070 iChill x4
    Doesnt work for me either. (tripple buffering part) win8 x64 9200

    just the vsync works. well partly. on darksiders 2 , forcing vsync doesnt even work. neither does on more games. like halflife2, killing floor,pes 2012,metro 2033.

    Seems i cant force any D3D9 titles.
    can anyone verify that please ?
     
    Last edited: Sep 24, 2012
  13. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    I have only tried it on Battlefield 3, Batman: AC, Borderlands 2 and Witcher 2. All work fine with D3DOverrider and Windows 8.
     
  14. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,667
    Likes Received:
    35
    GPU:
    Inno3d GTX 1070 iChill x4
    just tried it with borderlands 2 and it doesnt work for me either :(
    which drivers do you have installed ?
     
  15. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420

  16. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,667
    Likes Received:
    35
    GPU:
    Inno3d GTX 1070 iChill x4
    its kind of weird, i cant seem to load any custom dlls like the one for dark souls (DINPUT8.dll) or fxaa or smaa injectors either. its like windows is blocking it all.
    really have no clue what causes this, since i dont have any special software installed that could cause it. UAC notification is off aswell.
    have tired to run those games in comp. mode with xp,7, vista or with admin rights. didnt work either.
     
  17. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    That is weird. The only custom .dll I have tried is the Dark Souls resolution patch which uses a modified d3d9.dll and it works smoothly.
     
  18. Kyokushin

    Kyokushin New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Gigabyte GeForce 660ti OC
    Not working on my too.

    Anyone has some idea?

    Maybe good thing will be write to Nvidia for add this option like it is to OpenGL in control panel.
     
  19. Kyokushin

    Kyokushin New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Gigabyte GeForce 660ti OC
    ok folks i dont know why but it works.

    I have done:

    1: Delete 'config' file
    2: add to global file HookDirect3D11=1

    my global file:
    [Override]
    ForceTripleBuffering=1
    ForceVerticalSynchronization=1
    [Hooking]
    EnableHooking=1
    HookLoadLibrary=1
    HookDirectDraw=1
    HookDirect3D8=1
    HookDirect3D9=1
    HookDirect3D10=1
    HookDirect3D11=1
    [Debug]
    EnableSoundIndication=0
    EnableEventLogging=0
    [Info]
    Timestamp=14-10-2012, 14:40:38

    3. Run D3DOverriderWrapper.exe

    And it is working. Strange, a dont know what i do cause that, but it working.
     
  20. Bradders684

    Bradders684 Master Guru

    Messages:
    999
    Likes Received:
    0
    GPU:
    MSI GTX 980 Ti GAMING
    Its not working with PlanetSide 2 for me, it works with BF3 though :confused:
     

Share This Page