CVT Reduced Blank (CVT-RB) loses HD audio capability

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Nachbar, Mar 21, 2014.

  1. Nachbar

    Nachbar New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    EVGA 560 Ti
    I am losing the capability of playing HD audio formats via HDMI when I use my receiver and television. This only occurs when I set my television to "CVT Reduced Blank" in the custom resolution option. I have to use that setting to get full 1080p to work correctly otherwise I have an overscan issue and colors display slightly incorrectly. However if I instead use the automatic setting and then resize the desktop to 1824x1026 to correct the overscan I then get my HD audio capability back.

    My card is a EVGA Geforce 560 Ti 1GB which has 2 DVI slots and a mini HDMI slot. I tried all the slots using the supplied adapters that came with my card but to no avail. I also tried my other computer which has a Galaxy 650 Ti and it experiences the same behavior.

    To clarify what audio I get at each mode:
    CVT Reduced Blank @ 1080p: DTS, DD+, DD @ a max of 24-bit, 96khz
    Automatic, resized desktop @ 1824x1026p: DTS, DD+, DTS-HD, Dolby TrueHD, DD @ a max of 24-bit, 192khz

    I contacted EVGA for troubleshooting and we couldn't figure out the problem. I tried different, shorter cables and made sure they were class 2, High Speed cables. Our opinion is that it is a driver problem. I tried pre-300 drivers and it won't even accept cvt-rb for the monitor timing. My guess is nvidia partially fixed the problem but now has an audio bug. I would really like to be able to use 1080p while retaining HD audio capability over HDMI. I am open to any and all ideas on how to make this work. If you have a receiver capable of HD audio you should be able to test this if the screen accepts the cvt-rb timing when you go to create a custom resolution in the nvidia control panel.

    Pioneer VSX 1021-K receiver and a Magnavox 40mf430b/f7 TV
    Windows 7 64-bit SP1 with 335.23 WHQL drivers
     
    Last edited: Mar 21, 2014
  2. Mda400

    Mda400 Master Guru

    Messages:
    848
    Likes Received:
    89
    GPU:
    1660 - 2130/10ghz
    As you know 1080p is an ATSC (HDTV) standard resolution and is not recognized as a PC resolution by default. 1080p monitors have no problem with this since they expect all resolutions with RGB and full 4:4:4 chroma (PC resolutions).

    HDTV's that do not have a mechanism to defer 1080p from a PC source (Computer/Laptop/HDMI game console) to a non-PC source (Set-top box/DVD/Blu-ray player) will not correctly display their native resolution with the above PC characteristics (ability to decode RGB and show full chroma at native resolution). You are "tricking" your Receiver and TV's EDID by using CVT-RB to get this working, but HD audio does not due the receiver not knowing that type of signal format.

    What does this have to do with "Magnavox" specifically? It's an off-brand TV. Not a big HDTV brand like LG, Samsung, Sony, etc.
    While the receiver is fine and a fine receiver brand I might say, the TV is the end result of your issue. E.g. a TV that can switch to expect an ATSC resolution as a PC one would have the ability to "rename" its HDMI inputs to something like "PC" or "DVI".

    There's a solution to this which requires you using an EDID override for your display on the mini-HDMI port of your card (to force it to be recognized as DVI instead of HDMI) and use a DVI-to-HDMI adapter which can output the HD audio to your receiver on one of your DVI ports.

    Problem is, You have two different HDMI cables going rather than the PC-Receiver-TV chain which is more convenient...
     
    Last edited: Oct 25, 2017
  3. Nachbar

    Nachbar New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    EVGA 560 Ti
    Thank you very much for your reply and all the helpful information Mda400.

    I only have one 15' cable so I won't be able to use that override with my current setup. However when I get a new place I will have a HTPC sitting next to it and will probably look into that EDID override you mentioned. The TV was passed onto me by my late grandfather so I can't complain too much about it.

    Definitely though when I decide to get a new TV I'm going to bring a laptop and plug it in at the store and make sure it can do everything I want without too much fuss. Will probably have some of the ufo test pages zipping back and forth too and do some viewing angle and color tests.

    If you do know a good place where I can look into that EDID override let me know and I may tinker around with it in my spare time. I'm probably going to live without hd audio because with cvt-rb ticked I get correct 4:4:4 chroma and everything looks sharper and the colors are a lot closer to what they should be. Probably less input delay as well but I mainly use it to watch movies.
     
    Last edited: Mar 21, 2014
  4. Mangix

    Mangix Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    PowerColor Vega 56

  5. Nachbar

    Nachbar New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    EVGA 560 Ti
    Thanks Mangix for suggesting going over there and using his utility. I learned from the developer that I should just basically adjust the Totals values to increase the pixel clock rate until it works. The default for cvt-rb is 2080,1111 (138.65Mhz) and the automatic setting is 2200,1125 (148.50Mhz) for an increase of 120:14. I just went with bumping it up by 10:1 starting at the reduced setting and it worked for the first 4 bumps so I decided on 2100,1113 (140.24Mhz) and now the screen is perfect and I have HD audio capability.

    :banana:
     

Share This Page