CUVID/DXVA2 copy-back issue

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Ejziponken, May 26, 2020.

  1. Ejziponken

    Ejziponken Member

    Messages:
    20
    Likes Received:
    0
    Hi

    Trying to keep this short. Trying to watch a movie using MPC BE, MadVR, LAV filters etc.

    The movie has a few glitches when I watch it. The glitch happens always at the same exact timecode every time. It also happens with VLC player.

    Now the interesting part.. It goes away if I disable hardware decoding. I tried with CUVID, DXVA2 copy-back and D3D11 and glitch is still there. Also others has the same issue.

    I dont know much about this stuff. Where should I go looking for the problem? Is it an Nvidia driver issue? Is it Windows? Who should I report this to? :p

    GTX 1080, using latest Nvidia and Windows updates.

    [​IMG]

    Bonus points if someone can guess the movie. xD
     
  2. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    629
    Likes Received:
    67
    GPU:
    RX 480 8GB OC/UV
    Likely broken encoding, hardware decoding can't handle errors as good as software decoding.
     
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    6,898
    Likes Received:
    2,204
    GPU:
    GTX 1080ti
    broken encoding indeed.
     
  4. janos666

    janos666 Master Guru

    Messages:
    953
    Likes Received:
    132
    GPU:
    MSI RTX2060 6Gb
    This is definitely something else but in general, you should use D3D11 with madVR (auto = native mode is fine). For some reason (I am not sure why and how) DXVA2 yields lower quality with nVidia (at least with 10bit videos). And D3D11 is faster anyways (I tested this on a very old notebook with a GT8600M, a feature_level_10 card and D3D11 works with significantly lower CPU utilization [decoding 8bit SDR, obviously] while the quality is fine even on that old system --- of course this is not significant on a much younger and faster system but efficiency is never bad...).
     

  5. Noisiv

    Noisiv Ancient Guru

    Messages:
    6,990
    Likes Received:
    674
    GPU:
    2070 Super
    I saw this with both MPC and Potplayer. Ditched LAV video decoders. No issues.

    I keep them around for debugging/comparison purposes.
     
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    6,898
    Likes Received:
    2,204
    GPU:
    GTX 1080ti
    stop blaming LAV for bad encodes.
     

Share This Page