CS:Source ATI X850 Pro - 40fps ?!?!?!? PLEASE HELP

Discussion in 'Videocards - AMD Radeon' started by dc.uber, Mar 10, 2006.

  1. dc.uber

    dc.uber New Member

    Messages:
    2
    Likes Received:
    0
    Hello,

    Im desesperated i only play CS:Source i was a CS player a few years a go, but i left gaming for 2 years and now im back and playing CS:Source, and i decided to upgrade the graphic card since my old Geforce 4 Ti 4400 was not giving me the performance i was searching for, it´s and old graphic card it had it´s day that are now over i was doing 50fps-70fps (unstable) and when let´s of people appear and lots of models and grenades and mega caos it went to slow motion 15fps-20fps so i decided since my computer is kinda old if i did BOOST up the graphic card i would get more frames, so i decided to buy a ATI X850 PRO since my board only accepts AGP4x i thought it was a great solution.

    My computer is:
    Pentium 4 , 2.4 Ghz
    Motherboard Agp4x
    1.2 Gygas RAM DDR
    ATI X850 PRO

    I was so dissapointed :bolt: when i loaded the CS:Source i was doing less frames (30fps-40fps and sometimes less!!! doing 70fps in closed spaces) then using my old graphic card Geforce 4 Ti 4400 that i was doing ( 50fps-80fps unstable! in closed spaces 100fps), so i thought configs, and i tried it all OmegaDrivers, Ati Tools, Ati Catalyst, CS:Source Configurations, Casey´s Configs, Monitor Rates 75Mhz, I re-installed twice since i had nvidia drivers before for my old graphic card using driver cleaner i have spent an all day trying to figure out and it simples doesnt matter it does make any more it allways makes 30fps-40fps.

    It doesnt make any sense, i know my computer is nothing special and it´s using AGP4x, but since i did 50-80fps with a rubish graphic card compared to this new ATI X850 Pro, i should do more fps with the ATI, something like 80fps to 100fps (stable!) or maybe 90fps-110fps with a nice config...

    Im desesperated please help me, i have spent 280 euros in my new graphic cards to boost my frame rate and i simply got a worst performace...im so sad...

    PLEASE HELP :(

    Best regards,

    _
    DC
     
  2. Hinryu

    Hinryu Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Ati Radeon x1800 xt
    I had this problem with my card.

    With you it could either be, your P4 lagging your computer, which would make sense cuase you omly have 2.4 on a p4.

    Before thinking its that do a clean reinstall of your drivers for yoir graphics card and mobo.

    Use the normal add/remove tool to remove the drivers, then go into safe mode and use a driver cleaner http://www.drivercleaner.net/

    after that just reinstall it may help, also use driver cleaner to clean out your old graphics card driver there may still be some clashing with the drivers.
     
  3. LinkDrive

    LinkDrive Ancient Guru

    Messages:
    4,675
    Likes Received:
    0
    GPU:
    Toaster
    its most likely your agp aprature size...try maxing it out
     
  4. scatman839

    scatman839 Ancient Guru

    Messages:
    14,133
    Likes Received:
    537
    GPU:
    3080, KD55XD800
    For the love of god, why do people buy great rigs and waste it on CSS.

    Regardless, try overclocking and see if you get a difference.
     

  5. Saucy

    Saucy Master Guru

    Messages:
    389
    Likes Received:
    0
    GPU:
    6800 Silencer5 (16x1,6vp, 425/1147)
    Your P4 is bottlenecking your x850 (which is starved for bandwidth anyways, because it is using a AGP 4x interface).

    Change the Mobo and CPU.

    -Saucy
     
  6. 3dsage

    3dsage Master Guru

    Messages:
    502
    Likes Received:
    0
    GPU:
    EVGA 8800GT 512MB
    Yeah get a new mobo damn agpX4 is for sure a bottleneck. Taht powerful card is caged MAN.
     
  7. nathanstaples89

    nathanstaples89 Master Guru

    Messages:
    705
    Likes Received:
    0
    GPU:
    AMD 7850 2GB
    From what I hear, AGP 4x isn't much slower than 8x. I agree with someone who posted that you should try maxing out your AGP Arperture size, if you can, and do that whole thing, uninstall your Drivers in Add/Remove Programs, restart your comp in safe mode and use Driver Cleaner pro to remove anything that your old nvidia card has left behind and anything that your ATI driver has left behind, then reboot in normal mode and install the driver again.

    Hopefully this works, I can't think of any other reason why your performance could be so bad...unless it's just a faulty card, but I doubt that. :D
     
  8. DeathtrapX

    DeathtrapX Master Guru

    Messages:
    204
    Likes Received:
    0
    GPU:
    x800 XT 256mb sapphire 500/500
    It's three problems. 1) Source is one of the worst optimized engines on the market today, its just a bad engine and especially runs bad with css. The game runs fine for some people, and some people with great specs (alot better then yours) it runs horrible for

    2) Your not running dual channel ram, this is not helping you

    3) Your processor isn't that great, it is bottlenecking the card ... and combined with the crappy source engine, your gunna get bad fps. The physics and poor optimization are your problem along with no dual channel and a moderate processor

    I am on a 3200 athlon 64 @ 2ghz stock, ocz ddr 400 pc 3200 gig of ram, x800 XT 256mb sapphire, ocz modstream 520 watt power supply, and an asus k8v deluxe mb (754 socket ... so no dual channel either for me)

    Source can be at 190 fps in some areas, and fall to 38 fps in heavy combat ... my problem = no dual channel, an old processor (a64 sounds nice but this was the first one on the market, original clawhammer only 2ghz on a 754 sockeT), and the fact that the source engine itself is a piece of crap which is very poorly written and optimized in my opinion.

    You will notice an upgrade if you get a new cpu/mb man, your card is fine . This game is very very very cpu dependant. Keep in mind I went from a 9800 pro to an x800 XT on this system and saw basically no difference either, in other games I saw a difference though. Anywase I hoped I helped you gluck brother.
     
  9. scatman839

    scatman839 Ancient Guru

    Messages:
    14,133
    Likes Received:
    537
    GPU:
    3080, KD55XD800
    I had a pc slower and worse than what he had.

    It ran at a good 30-50fps at 1280x1024 on full, so your talking out your arse, its not the pc.

    Of course, this man has had 1 post, thats it, somehow I don't think he's coming back.
     
    Last edited: Mar 12, 2006
  10. DeathtrapX

    DeathtrapX Master Guru

    Messages:
    204
    Likes Received:
    0
    GPU:
    x800 XT 256mb sapphire 500/500
    Uhm I am talking out of my arse? Real constructive guy ...

    Any lets hear your specs on the computer you ran css on ok?

    And did you get 30-50fps no matter what in fire fights? I can't judge this because you didn't even list your specs, just made a nice rude comment instead.

    Btw source is very cpu dependant and if you bothered to do any homework on this engine, hell even read their official forums for css, you'd realize people with very high end rigs report having trouble ... while some report none.

    Some folks run better on a 2400 xp with 9800 pro then people on 4400 64's with 7800 gtx's, its a funky engine and really poorly optimized

    Again before you become rude (wait to late ..) , lets hear your system specs that you used to run css source with; If you even know them, you don't appear to know what core your even on according to your info, then could you please answer did you get 50 fps in heavy combat? Or just good fps without anyone on screen ... very big difference.

    Btw 20 bucks says he can max his graphics settings in game or lower them to bare minimum and he receives the same fps no matter what, clear sign of cpu being the factor.
     
    Last edited: Mar 12, 2006

  11. dc.uber

    dc.uber New Member

    Messages:
    2
    Likes Received:
    0
    Thanks

    Hello,

    I have re-installed my system and its better now, but still the gfx card is not like i have dreamed, it´s making 50fps-100fps (unstable! and lowering to 40fps in heavy combat!) that is almost the same my Geforce4 Ti 4400 was doing it...i have spent 280 euros :frown: and my performance didnt change, it was a waste of money really!!!

    Because when i buy a new cpu and mobo i will be thinking on buying PCIE and the problem is my new/old graphics card AGP4x / AGP8x will be out of date and just garbish...im sad a ATI RADEON X850 PRO cant do more fps then a Geforce 4 Ti 4400 because the fact is just that...

    I have maintained my CPU, MOBO and other parts and UPGRADED the Graphics Card and the game goes the same...im really sad the improvement is nothing compared with what i was waiting im still thinking on selling it and get part of my money back...

    Im sad...

    Thank you so much for the people that are helping :)

    _
    DC
     
    Last edited: Mar 13, 2006
  12. PowerGI

    PowerGI Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    EVGA GTX 580 1536MB
    ok that happened to me too. I had a radeon 9800pro and the game was running quite ok, very playable. But when i installed my radeon x800xt, the game started being chopy and slow. It seems that CS:S automaticly set antialiasing and anisotropic filtering on. All I had to do was to disable them.
     
  13. icywind32

    icywind32 Master Guru

    Messages:
    687
    Likes Received:
    0
    GPU:
    ati 6970 2gb
    its ur comp and ur agp...... my rig is a amd 3000+ and i have a ati x800pro and i have the settings at 1280x1048 with everything turn on high wit no aa and 8x af and i get 60+ fps so its ur comp
     
  14. Xaser04

    Xaser04 Ancient Guru

    Messages:
    2,871
    Likes Received:
    2
    GPU:
    RTX 3080 16GB
    You have upgraded your gfx card yes but now the rest of your computer is a severe bottleneck.

    You will possibly find having something like a 9800 pro would be better for you.

    Also stop comparing your ti4400 to the X850pro. Yes the fps might be close but the ti4400 was running in dx8 mode whereas the X850pro is running in DX9 mode so the fps are not comparible.
     
  15. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    OC ur cpu 2 3.3GHz on a better AGP 8x mobo n u will get 100FPS :)
     

Share This Page