Crysis Stuttering fix :)

Discussion in 'Games, Gaming & Game-demos' started by RagDoll_Effect, Nov 26, 2007.

  1. RagDoll_Effect

    RagDoll_Effect Ancient Guru

    Messages:
    4,509
    Likes Received:
    0
    GPU:
    2x nvidia GTX 560 SLI
    Had this stuttering in Crysis and some other games where the sound would also stutter. Well, I remember I had updated my chipset drivers on my mobo, the intel inf driver. Got my mobo cd which had the original chipset inf drivers, installed that and Crysis and other games run smooth as silk. No stutters :)

    Hope this helps some people,

    Cheers :)

    Edit:update, I thought it was that but it wasn't, but I did fix it by enabling : No execute memory protect in the BIOS.

    Hope this helps :)
     
    Last edited: Nov 26, 2007
  2. SolidBladez

    SolidBladez Ancient Guru

    Messages:
    3,716
    Likes Received:
    0
    GPU:
    2x 7950 Boost
    Which version though? I know the latest is 8.3.1.1009.
     
  3. RagDoll_Effect

    RagDoll_Effect Ancient Guru

    Messages:
    4,509
    Likes Received:
    0
    GPU:
    2x nvidia GTX 560 SLI
    Hey, you're mobo would have come with a Gigabyte cd, install the inf driver on that cd and your good to go :)
     
  4. RagDoll_Effect

    RagDoll_Effect Ancient Guru

    Messages:
    4,509
    Likes Received:
    0
    GPU:
    2x nvidia GTX 560 SLI
    Enable : No execute memory protect in the BIOS :)
     

  5. CJ3D

    CJ3D Ancient Guru

    Messages:
    2,388
    Likes Received:
    4
    GPU:
    Asus GTX970 4GB
    I cant see how no-execute can solve the problem. That setting simply tells the CPU to protect the memory from buffer overflows. The game would crash if a nasty buffer overflow happened

    The stuttering happens because the game is very graphic intensive, not because of a sound problem or anything like that. When you move in the level, graphics are dynamically being pumped around the HDD, video memory, virtual memory, and 'turbo' memory, which causes the video card to freeze up for a moment. To minimize it, you need to turn down the graphics settings.
     
  6. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    I apologize if I misunderstood you but I have to say, in response to this post, that he has no reason to lie. If he says enabling that option helped him, I believe him.
     
  7. CJ3D

    CJ3D Ancient Guru

    Messages:
    2,388
    Likes Received:
    4
    GPU:
    Asus GTX970 4GB
    I'm not saying hes lying at all, I just doubt it would make a difference considering the way No-Execute works :)
     
  8. UnclePappi

    UnclePappi Banned

    Messages:
    5,086
    Likes Received:
    1
    GPU:
    Asus 680 2gb 1250mhz
    btw gfx don't move "dynamically" around the hdd. The system memory and video memory yes, hdd no. (unless you run out of memory that is)
     
  9. RagDoll_Effect

    RagDoll_Effect Ancient Guru

    Messages:
    4,509
    Likes Received:
    0
    GPU:
    2x nvidia GTX 560 SLI
    Well, I don't know why, but it worked for one time playing the game, then it was back to the stuttering... lol Then I loaded Crysis up again, and still the same. This is really lame imo, the gameplay is not good with all this.
    It actually happens in some other games a bit, but I doubt it's the game because all the main hdd loading is done before the map starts. I know what you're saying CJ3D, but I think it's got something to do with the Giga Realtek onboard sound.

    If someone's got more info and the same probs, post here please :)

    Cheers:)
     
  10. UnclePappi

    UnclePappi Banned

    Messages:
    5,086
    Likes Received:
    1
    GPU:
    Asus 680 2gb 1250mhz
    It stutters on my x-fi too ;) More so in dx10 mode than dx9, so I kind of think it has to do with the game code. I think it's a problem with the audio syncing with the video as it happens when the video stutters for me. I wish they would have just used hardware sound/openAL.
     

  11. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    GPU:
    MSi N570GTX TFIII [OC|PE]
    Hi

    i had this huge stutters back on vista but that was also when i had my onboard soundcard, yes it stuttered like hell, sound part was a huge mess. That was in Crysis beta, but then i went to XP it was still here but not so much, and now with my new soundcard it actually ran better, no more sound loops and cracking pops (i refer to beta), in the final game also no sound related stutters, but there is another stutter imc - cpu and gpu stutters :3eyes:.

    LOL well actually i've been seeing in all my games I get a better performance compared to onboard sound, heck even in Colin DiRT i get avrg 35-42fps in single race (sound settings to max even dsp to high), before was like more like avg 26-32 ( sound lowest possible).
     
  12. Grahf

    Grahf Ancient Guru

    Messages:
    1,817
    Likes Received:
    0
    GPU:
    MSI N580GTX Lightning
    Zero stutters for me in Crysis with Very High settings.... My fps is crappy (~15 or less most of the time), but NO stutters whatsoever.


    BTW:
    No execute memory protect has nothing to do with game stutters; people aren't lying, it's just a placebo effect.
     
  13. gmavignier

    gmavignier Maha Guru

    Messages:
    1,447
    Likes Received:
    0
    GPU:
    Gigabyte GTX760 OC
    I thought Crysis sound was CPU rendered. I have no problem running Crysis most MED some HIGH, DX9, 1024X768 @ about 20-30 FPS. Very very playable even on the worst firefights. Still looks amazing at those settings.
     
  14. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    I'm considering buying a dedicated sound card too, but I know too little. How would this card perform (http://us.creative.com/products/product.asp?category=209&subcategory=669&product=16770&nav=0) compared to your current X-Fi Fatality Pro?
     
  15. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    GPU:
    MSi N570GTX TFIII [OC|PE]
    It will lack in some quality like cheaper signal-to-noise converters..., and in performance as mine has 64mb ram and that model you posted has 2mb well only a few use it atm, but this might change, i've seen it in Quake, Doom, Bioshock, Battefield, DiRT, and a few others...

    That card also lacks in mode selections, it appears as it only has a entertain mode. Because i can't see any suppport of aiso 2.0 and eax 5.0.

    A better choice would be this one or this one.
     

  16. Andrés

    Andrés Ancient Guru

    Messages:
    4,554
    Likes Received:
    0
    GPU:
    Sapphire HD 6950 2Gb
    I wonder what is the embedded RAM for?. Isn't it for MIDI samples?. I only care for performance. Quality is important too, but what I'm trying to know is if adding a sound card will improve my computer's performance.
     
  17. Grahf

    Grahf Ancient Guru

    Messages:
    1,817
    Likes Received:
    0
    GPU:
    MSI N580GTX Lightning
    Nope.
    It's for X-Ram compatible games; it's extra sound caching that helps performance....but sadly only a handful of games actually really make use of the X-Ram (Battlefield 2 is one of them).
     
  18. Rodman

    Rodman Ancient Guru

    Messages:
    1,721
    Likes Received:
    0
    GPU:
    GTX285 SLI@756-1580-2750
    My buddy had the same problem. The funny thing is we had the same exact system specs right down to the hard drive, yet I had zero studder issues. I told him to get rid of his sound card (X-FI) and go with the onboard sound since that was the only diff between our rigs. Plus a sound card in Vista is pointless as far as gaming go's anyway. Problem fixed;)
     
  19. UnclePappi

    UnclePappi Banned

    Messages:
    5,086
    Likes Received:
    1
    GPU:
    Asus 680 2gb 1250mhz
    What are you talking about? A sound card is very important especially if you use surround speakers. You get hardware acceleration in OpenAL and in Direct3d(via Alchemy), plus with good surround speakers you really notice the difference.

    btw, avoid the x-treme audio at all costs, you can get an extreme gamer(hardware acceleration) for the same price if you look around.

    I'm pretty sure any game that uses eax5.0 uses the 64mb x-ram also.

    @Digital Hunter I noticed an increase in frames in a few games also, mostly though I noticed a smoothness in gameplay and sound that wasn't there before. Kind of the same effect you get when you overclock the shiz out of a CPU.
     
  20. Year

    Year Ancient Guru

    Messages:
    11,595
    Likes Received:
    0
    GPU:
    EVGA GTX 690
    load crysis and set the audio to Medium in the options that might fix your problem, try it (couldn't notice much difference in quality).
     

Share This Page