Crysis 3 Problem

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by CoMa666, Feb 28, 2013.

  1. CoMa666

    CoMa666 Master Guru

    Messages:
    401
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    I'm using 314.09 and with all setting on low i have sometimes slowdowns in

    multiplayer...singleplayer not started yet...

    My video card is a gtx 680 windforce x3 4gb and all games run perfectly... pls

    someone can tell me how i can run fine this game?

    What's the best driver for this game?

    Thanks
     
  2. CoMa666

    CoMa666 Master Guru

    Messages:
    401
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    So....noone knows...
     
  3. 3dPlayer

    3dPlayer Banned

    Messages:
    1,820
    Likes Received:
    0
    GPU:
    Have
    Gonna be honest hear, i have no clue. :3eyes:
     
  4. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    Is it only in crysis 3? Are your temps okay? Is there any crap running in the background?
     

  5. Spets

    Spets Ancient Guru

    Messages:
    2,986
    Likes Received:
    43
    GPU:
    RTX 2080Ti XC Ultra
    What is your GPU/CPU usage/clocks/temps during the slowdowns?
    Do you have AO on? Try turning it off for C3, there's a lot of foliage that'll probably make it very demanding.
    Maybe PM other 670/680 users that play C3 often to see if they get the same results, could be a driver related.
     
  6. jordash

    jordash Member

    Messages:
    27
    Likes Received:
    0
    GPU:
    GTX 670
    Have you made any adjustments to any settings? volts? Nvidia driver AA? Do you overclock? I own a Windforce gtx 670 so I know temps should not be a factor.
     
  7. RanCor TDO

    RanCor TDO Master Guru

    Messages:
    344
    Likes Received:
    0
    GPU:
    Palit 1080 GameRock
    If you are running everything on low then you may be bound by cpu speed, crank up the graphics or overclock your cpu.
     
  8. CoMa666

    CoMa666 Master Guru

    Messages:
    401
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    My i5 3570k is at 3.9 GHz.... i don't think the problem is there...
     
  9. (.)(.)

    (.)(.) Banned

    Messages:
    9,094
    Likes Received:
    0
    GPU:
    GTX 970
    Have you tried the Titan drivers?

    Edit: I see that you have, i know this because i just re-read your op properly.

    What happens if you drop everything onto low settings?
     
    Last edited: Mar 1, 2013
  10. nicugoalkeper

    nicugoalkeper Master Guru

    Messages:
    867
    Likes Received:
    10
    GPU:
    ASUS GTX 1060 DUAL OC 6GB
    Make a clean driver install, and maybe a windows to, if everything is ok.
     

  11. CoMa666

    CoMa666 Master Guru

    Messages:
    401
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    on low the game run good on multyplayer but sometimes stuttering occurs...
     
  12. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    7
    GPU:
    7950 Vapor-X 1100/1500
    How's your internet connection?
     
  13. CoMa666

    CoMa666 Master Guru

    Messages:
    401
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    i think good, other multyplayers ahve not problems
     
  14. ---TK---

    ---TK--- Ancient Guru

    Messages:
    22,112
    Likes Received:
    2
    GPU:
    2x 980Ti Gaming 1430/7296
    overclock that cpu to 4.5 and try again provided you have proper cooling
     
  15. elite69

    elite69 Master Guru

    Messages:
    471
    Likes Received:
    9
    GPU:
    EVGA GTX 1060 6GB
    i dont guess that cpu its the problem clean the windows instalation start from fresh
     

  16. GokunDesu

    GokunDesu Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    GTX 680
    I have the same problem in singleplayer.. It can go from 100+fps to ~20fps even with absolutely no action happening, doesn't matter what settings i use.
     
  17. larsbaby

    larsbaby Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    KFA2 GTX670 EX OC SLi WC
    I haven't tried multiplayer but single player I have found the framerates drop dramatically. When you arrive at the dam level looking left I was getting 50FPS without moving but then looking right it dropped to 19FPS. On average I'm usually getting around 45FPS/50FPS but there are some area when it drops for no apparent reason.

    MaLDoHD has some theory on the FPS issue and possibly something that might be of use to some players.
    check it out http://maldotex.blogspot.co.uk/
     
  18. IamGODobeyORdie

    IamGODobeyORdie Banned

    Messages:
    245
    Likes Received:
    0
    GPU:
    2x GTX 780@SLI & GTX 780M
    I can run this game with only one of my GTX670, with everything almost max, some settings are high, but most are very high. And still I get 60fps, so something must be wrong if you cant play the game with settings better than low, with a 680?
     
  19. CoMa666

    CoMa666 Master Guru

    Messages:
    401
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    Man please try multyplayer and tell me if you have a bit of stuttering sometimes, i really dunno what can be... i don't want to reformat my pc without be sure it will help.
     
  20. Y1ROK

    Y1ROK Active Member

    Messages:
    95
    Likes Received:
    0
    GPU:
    MSI GTX 1070 GAMING X 8G
    Actualy it is. Crysis 3 crazy depended on CPU. With my 2500K @4500 fps not stable and CPU load 99%, but when i OC CPU to 4600 then game runs perfectly smooth... Thats the way crysis 3 is...
     

Share This Page