Crysis 3 Crashing right at the start of the first mission

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Plug2k, Feb 24, 2013.

  1. Plug2k

    Plug2k Maha Guru

    Messages:
    1,454
    Likes Received:
    0
    Dont know what is going on with this game as its the only game thats crashing on me no matter what i do.

    running oc`d or stock does not matter game will freeze on the first level about 5 seconds in system freeze then driver has been recovered.

    looked at event viewer : faulting module : aticfx32.dll

    running beta 6 stock or oc`d still still freeze.... if i disable crossfire game runs but with crossfire :/ crashes
    its like the same crash you would get if you where very high gpu overclock wasnt stable lol

    though i know my clocks are stable. so must be game right :/ anyone else getting this same issue....
     
  2. |ALE|

    |ALE| Master Guru

    Messages:
    387
    Likes Received:
    0
    no issue for my crossfire 7970 GHz edition stock, sorry, only bad and poor crossfire performance even with beta 6 :(
     
  3. Plug2k

    Plug2k Maha Guru

    Messages:
    1,454
    Likes Received:
    0
    Hmmm very strange cause the open beta ran like a dream apart from the random slowdowns in places arghhhhh

    only thing thats been upgraded on my pc is my sound card, but i cant see a soundcard causing this problem.

    EDIT : update : seems the issue is when i enable crossfire.
    game crashes right out even on stock default clocks even if i underclock it crashes out with a issue freezing then driver recovering like my cards where high oc`d on low volts ect (similar)

    tryed all my other games and there fine no issues, so what gives ? very strange.
     
    Last edited: Feb 24, 2013
  4. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    If you google this problem, you ll see that Nvidia users are having this same problem. It leads me to believe that is a game issue.

    I also have this system freeze at the start of the game. Sad part is that it happened in beta as well for me.
     

  5. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    9,606
    Likes Received:
    0
    No issues here.
     
  6. Plug2k

    Plug2k Maha Guru

    Messages:
    1,454
    Likes Received:
    0
    There is always people that will post in a help thread and say ( NO ISSUES HERE ) or WORKING HERE....

    lol wonder where the people are that do have this issue...
     
  7. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    It is like he represents 100% of the Nvidia users or us representing most of the AMD users.

    /facepalm
     
  8. Gaz

    Gaz Member

    Messages:
    14
    Likes Received:
    0
    I’m experiencing the same problem. Windows 8 x64 Radeon 5970 I did try Catalyst 13.2 Beta 6 and Beta 5, different profiles(like bf3) and crossfire method. No luck.
     
  9. warlord

    warlord Master Guru

    Messages:
    675
    Likes Received:
    0
    it's fine here i finished the game with cf not a single problem, smooth @ very high + fxaa :) so it's not a 13.2b6 problem except the awful scaling...:puke2:
     
  10. Plug2k

    Plug2k Maha Guru

    Messages:
    1,454
    Likes Received:
    0
    So why is it working for some people and not for other people.
    between amd/ati/nvidia you would think the game maker would have a fkin clue.
     

  11. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    9,606
    Likes Received:
    0
    Yeah, show me some people on nvidia forums with the same problem.
     
  12. BABA-The Hacker

    BABA-The Hacker Banned

    Messages:
    455
    Likes Received:
    0
    Using latest dot.net framework? a try... it worked for me.... Still a mystery...(under 313.95)
     
    Last edited: Feb 24, 2013
  13. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    Try beta 4.
     
  14. BABA-The Hacker

    BABA-The Hacker Banned

    Messages:
    455
    Likes Received:
    0
    Load optimized defaults under BIOS.....and at times bad OS do makes things worst.....That is unwanted features installed naively as transparency....


    Well, is it a genuine one, Crysis 3???
     
    Last edited: Feb 24, 2013
  15. Plug2k

    Plug2k Maha Guru

    Messages:
    1,454
    Likes Received:
    0
    Its not my OS, i can run farcry 3 for hours at max settings 99% gpu usage almost with out issues,
    so why would Crysis 3 crash as soon as i load up the first mission with a cfx.dll error and freeze my system with a driver recovered.

    ---------------------------------------------------------
    and yes its genuine pfft lol
     

  16. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,558
    Likes Received:
    1
    Have you tried replacing just the dll from older versions ? dont know if it works, but maybe worth a try ? Maybe you can even place them in the crysis 3 bin folder
     
  17. Plug2k

    Plug2k Maha Guru

    Messages:
    1,454
    Likes Received:
    0
    tryed beta 5 as well as beta 6 same issue.
     
  18. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    I said beta 4.
     

Share This Page