cryengine3 refresh rate after alt+tab

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by hemla, Nov 18, 2019.

  1. hemla

    hemla Master Guru

    Messages:
    230
    Likes Received:
    22
    GPU:
    nvidia
    When running CryEngine 3 games I ran into refresh rate problem. My monitor default is 1080p@60Hz but I have custom resolution in NVCPL, that is 1080p@72Hz and that's also my desktop resolution, only one monitor connected. I can launch full fullscreen CryEngine 3 apps normally and they will run in 72Hz but only until ALT+TAB after which they revert back to 60Hz and game restart is required. I have tried CRU with three different resolution options there but it didn't solve my CryEngine 3 issue. The video card is GTX1060 3GB and I've tried various drivers but there is no difference. Is there anything I could do?
     
    Last edited: Nov 18, 2019
    BlindBison likes this.
  2. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,317
    Likes Received:
    227
    GPU:
    MSI RTX 2080
    Does your monitor still have "HDTV" Resolutions listed?

    If not, I would CRU out the 60hz resolutions entirely so that the only option is 72hz and save that as a separate EDID override you can switch in and out of as needed. (Just remember to run the driver reset .exe in between with CRU)

    Cryengine almost always deviates to the lowest refresh rate possible. No matter what, so the only reasonable option is to remove anything but the desired one.

    I've recently played through Crysis 1, Warhead and Crysis 2 without issues on multiple monitors with only 60hz set and all HDTV resolutions,24/30/50hz modes removed.
     
    Last edited: Nov 19, 2019
  3. hemla

    hemla Master Guru

    Messages:
    230
    Likes Received:
    22
    GPU:
    nvidia
    Yes, it does have those rates listed. There are currently 3 groups with two latter being default: "custom, HD, PC". But I have tried what you were saying with CRU(not sure if properly) and left only 1920x1080@72Hz resolution - I had it in each separate CRU box without any other resolution listed there. Strange, NVCPL was still showing those "Ultra HD, HD, SD" resolutions even when I removed everything in CRU. I have also managed to force NVCPL to list 1920x1080@72Hz as "native" with CRU but it didn't change anything for CryEngine 3 game. As of note many other games behave normally(in full-fullscreen they keep 72Hz after alt-tab).
     
  4. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,317
    Likes Received:
    227
    GPU:
    MSI RTX 2080
    You need to edit the edid to remove HDTV support. The easiest way will be to completely delete the extension block if you don't need audio support.
     

  5. Marctraider

    Marctraider Member

    Messages:
    17
    Likes Received:
    6
    GPU:
    670GTX
    Maybe necro, But I've seen strange problems with cryengine based games and refresh rate problems with alt+tab, also in conjunction with full screen optimization.

    Solution was to remove all refresh rates in CRU and keep only 120hz. Solves a lot of problems. Only issue I can see here if you ever have to go back to 60hz you might need to boot into safe mode and reinstall driver :p
     
  6. BlindBison

    BlindBison Master Guru

    Messages:
    971
    Likes Received:
    249
    GPU:
    RTX 2080 Super
    Have seen this behavior too but never found a fix other than just alt tabbing a bunch of times.
     
  7. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,317
    Likes Received:
    227
    GPU:
    MSI RTX 2080
    It's been mentioned. But you need to remove things like HDTV Resolutions/TV timings with an edid override. I've never experimented to find the exact minimum required. But honestly the easiest is just to create a custom override you only use when playing said CE3 games that removes anything but the refresh rate you want to use. The game can't use 24/30/50hz if it doesn't know they exist.
    Played through all 4 Crysis games last year with an Edid override with no issues.
     
  8. theahae

    theahae Active Member

    Messages:
    60
    Likes Received:
    9
    GPU:
    GTX 1060
    I would use CRU (custom resolution utility) for custom resolution/refresh rates
     
    enkoo1 likes this.
  9. hemla

    hemla Master Guru

    Messages:
    230
    Likes Received:
    22
    GPU:
    nvidia
    For me CRU thing doesn't work neither. I guess game is just hard-coded for 60Hz.
     
  10. dezo

    dezo Active Member

    Messages:
    67
    Likes Received:
    26
    GPU:
    RTX 2080s
    Things that worked for me in Crysis games on Win10 and high refresh monitor (144Hz in my case):
    - Crysis 1 (dx10): Disable full screen optimizations
    - Crysis 2 (dx11): Disable full screen optimizations AND set the system timer to 1ms
    - Crysis 3 (dx11): Set the system timer to 1ms
    The System Timer Tool can be used to set 1ms timer interval. CRU modification was not needed on my system.
     
    BlindBison and enkoo1 like this.

Share This Page