Crossfire Profile: Bad Company 2

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Th3_Edge, Mar 17, 2010.

  1. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,904
    Likes Received:
    1,159
    GPU:
    6800XT Nitro+ SE
    Simply fix for these lines. They are the same problem as the flickering shadows.

    Simply go into options, change vsync setting (if you have it on set it to off and vice versa), go back into the game, then go back into the options and change vsync back to the original setting and it will be fixed.

    It may come back but for me it has only come back once so far, but I mainly use D3DOverrider and the runs perfectly smooth 60fps 95% of the time.

    EDIT: I have actually uninstalled this new Application Profiles as it only adds a few xfire profiles and they are quite rubbish. To actual drivers have more performance improvements in themselves than in this.

    Just one question? So since 10.2 have ALL the application profiles been separate to the driver? So without an Application profile installed does this mean I have no xfire profiles on my PC or are there still profiles within the driver set?
     
    Last edited: Mar 21, 2010
  2. Th3_Edge

    Th3_Edge Master Guru

    Messages:
    247
    Likes Received:
    0
    GPU:
    XFX 5870
    OK, I've turned on and off just about every setting and it still does it. It doesn't appear to be a specific setting causing it. It is the profile itself. If I remove the profile the problem goes away.
     
  3. N1mmer

    N1mmer Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    6970 Xfire
    I have a feeling it is catalyst AI screwing everything up again and the profiles are good I will test and repost.

    5870 crossfire

    10.2 flickering

    10.3 preview (good for 2 days then flickering)

    10.3a official (good until crossfire profiles)

    added crossfire profiles and then lines randomly appear

    Cat AI just screws up everything imho, it has benefits but problems outweigh benefits.
     
  4. N1mmer

    N1mmer Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    6970 Xfire

    not cat ai did fresh install excluding CCC and did same thing right after crossfire profiles.
     

  5. Th3_Edge

    Th3_Edge Master Guru

    Messages:
    247
    Likes Received:
    0
    GPU:
    XFX 5870
    Some guys on the Rage3D forums said to uninstall the profiles, driver, remove left overs with driversweeper and ccleaner and then install the drivers and profiles again.

    I went through all that and it does not make a difference. The horizontal lines are still there.
     
  6. Sneakers

    Sneakers Ancient Guru

    Messages:
    2,717
    Likes Received:
    0
    GPU:
    Gigabyte 980Ti Windforce
    This is a really odd issue.

    Could someone try and Screenshot this phenomena ?

    I mean I had the flickering textures with 10.3a but after the xfire profile they dissapeared to 99% ( had it once in 2 days and it dissapeared by itself then ).
    So for me this profile is working as "intended", wich is odd since alot of people seem to have severe issues with it.

    There has to be some common denominator here. I mean why does it work for me but not for others?
     
  7. games2007

    games2007 Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    ATI Radeon 5700 x2 xfire
    Hmm, I'll try 10.3a and see if I get lines or not.
     
  8. Ourasi

    Ourasi Master Guru

    Messages:
    294
    Likes Received:
    7
    GPU:
    MSI RX 480 Gaming X 8GB
    This issue has nothing to do with flickering textures, this spesific issue has to do with multiple vertical lines.. These lines appear to be linked to dynamic lightning conditions, as they come and go as clouds come and go. You can stand perfectly still, and when lightning changes, the lines appear. Isla Innocentes is a good place to check it out, start on atacking side, where you have the two blackhawks...
     
    Last edited: Mar 22, 2010
  9. Sneakers

    Sneakers Ancient Guru

    Messages:
    2,717
    Likes Received:
    0
    GPU:
    Gigabyte 980Ti Windforce
    As I said it is odd.

    The new 10.3 profiles fixed the flickering for me but then somehow caused these lines for some.

    Can't help to think it is some setting that I have off and others on, hence I thought about the HSAO, but I guess people already tried that.
     
  10. shaggeyman39

    shaggeyman39 Member Guru

    Messages:
    173
    Likes Received:
    0
    GPU:
    2 X 4850 705Clock 1150Mem
    If you run an OSD, I use ati tray tools and set it up to display GPU0% & GPU2% you can see corruption only happens when both cards hit 100%. This is why changing settings to cause lower usage gets rid all problems. The game doesn't always use 100%

    This is what is going on with my system. :3eyes:
     

  11. Ourasi

    Ourasi Master Guru

    Messages:
    294
    Likes Received:
    7
    GPU:
    MSI RX 480 Gaming X 8GB
    This is now a confirmed driver issue, and will be fixed, when is still undecided..
     
  12. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,904
    Likes Received:
    1,159
    GPU:
    6800XT Nitro+ SE
    So are these 10.3a preview drivers going to the final set with just a WHQL certificate slapped on them, or will we get a newer driver version in the final 10.3's? Anyone know?
     
  13. Ourasi

    Ourasi Master Guru

    Messages:
    294
    Likes Received:
    7
    GPU:
    MSI RX 480 Gaming X 8GB
    The 10.3 official is supposed to be these, just without some fixes and a WHQL stamp....
     
  14. Sneakers

    Sneakers Ancient Guru

    Messages:
    2,717
    Likes Received:
    0
    GPU:
    Gigabyte 980Ti Windforce
    I have now been able to replicate these grey lines some people have ( I think ).

    On the singleplayer level Upriver, just where you spawn if I look up into the sky at some spots, at certain angles ( where the AO is triggered in a special way ) I can make the grey horizontal lines to appear. But as soon as I move the mouse even 1mm in anyway the lines dissapear. It wasn't easy to replicate it but after a while of looking up in the sky triggering the AO to dimm the lights it apears again, it looks like if you where filming an old CRT monitor with a videocamera kinda, but more defined - grey 3-4 mm thick lines running up and down of the screen in a horizontal manner. Is this what you guys are seeing?

    When I truned HSAO=true the problem was easier to replicate then when I had HSAO=false, so imo you guys need to turn that off. I also tried turning AF on and off and that didn't seem to have any impact at all, other then again verifying that that the ingame AF is NOT working at all, if you want AF it has to be forced via CCC and then you get real x16 AF and it has NO performance impact at all.
     
  15. buddyfriendo

    buddyfriendo Ancient Guru

    Messages:
    3,401
    Likes Received:
    4
    GPU:
    2070 Super
    Thats because the profile is bugged not the drivers. You can reinstall it as many times as you like and the outcome will be the same. :3eyes:
     

  16. ATMccs

    ATMccs New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    HD5850 x2 CFX + Gf 220
    Sorry if i am reviving a dying thread...

    Have you guys found a solution yet? I notice last post was just before release of the official drivers. And, did you guys try the 10.3b? I still get them when i unable crossfireX. I do get less of them when i have Catalyst AI to advanced.

    Now, on another topic, i saw it being mentioned that this only occurs at 100 load on all cards. Now, i am not sure if this is only the case for me, but when i OC higher than what i am allowed in Overdrive, (say using Afterburner or ATI OC Tool) i max gpu usage to about 60%. It happened with two or 3 prev driver releases, but have not yet tried it with the latest ones. It was a weird issue that caused my bench scores for crossfire and OC to be lower than stock Crossfire. Maybe adding a little OC will make our GPUs throttle down and therefore escape the lines.

    (the vertical lines get pretty terrible for me on the snowy submarine base map)
     
  17. Th3_Edge

    Th3_Edge Master Guru

    Messages:
    247
    Likes Received:
    0
    GPU:
    XFX 5870
    My solution for the horizontal lines is this:

    1) Load the game.
    2) Change resolution to something else.
    3) Change it back to the resolution I use.
    4) Turn on Vsynch
    5) Play without horizontal lines.
     
  18. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    I never had any horizontal lines, I play with D3DOverrider and forced vsync and tripple buffer. Maybe that why?..

    Anyway new profiles out that supposed to fix the problem for you.:

    Below is a list of what will improve when a user installs the April 7 profile:

    * Battlefield Bad Company 2 Fix - horizontal lines are no longer observed when running an ATI CrossFireX configuration
    * Battlefield Bad Company 2 Fix - flickering and black square corruption is no longer observed when running on single card ATI Radeon products
    * Forcing on Anti-Aliasing through ATI Catalyst Control Center is now supported in the following titles: Supreme Commander 2, Dirt2, Avatar and Battlefield Bad Company2 (single GPU configurations)
    * StarCraft(r) II: Wings of Liberty beta on ATI Radeon™ 5800 products running in an ATI CrossFireX configurations : moving units near the edge of a cliff no longer causes them to fall because the height field is corrupted

    http://www.rage3d.com/xmp/profiles/ATI_Catalyst_AppProfiles_Apr7.exe
     
    Last edited: Apr 8, 2010
  19. Zebatshu

    Zebatshu Member Guru

    Messages:
    173
    Likes Received:
    0
    GPU:
    EVGA GTX670
    I can confirm that these new profiles does indeed fix the horizontal lines also the flashing objects issue. Holding thumbs for a fix to this long loading of maps in BC2.
     
  20. Mix-Master

    Mix-Master New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Sapphire 5870 Crossfire
    They are much better than anything previously, but still had a tiny bit of the same flicker, and much worse flicker in a single player cutscene.
     

Share This Page