Crossfire 'broken' in Star Wars: Battlefront

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ddelamare, May 31, 2016.

  1. ddelamare

    ddelamare Master Guru

    Messages:
    224
    Likes Received:
    5
    GPU:
    Inno3D GTX 1070 X4
    Hi Guys,

    Most of you are probably aware of this however does anyone play SW:Battlefront in CF and it works?

    I can see in the release notes for driver 16.3 that this was a known issue but there was no further mention of this in all of the driver packages from then till the latest. Nothing showing as 'Resolved'

    I am assuming that this was been swept under the carpet, 'Out of sight, out of mind' style. There is a CF profile for Star Wars Battlefront, which is funny as you would expect it to work or that they've taken the time to create the CF profile.

    Can anyone confirm this before i start tearing into AMD support for deliberately hiding the info?

    Cheers
     
    Last edited: May 31, 2016
  2. spyre

    spyre Master Guru

    Messages:
    227
    Likes Received:
    0
    GPU:
    AMD 6990 and 6970 TF
    Works fine here, R9 290X in Crossfire, Win 10 X64, 4K resolution, Driver Packaging Version 16.20.1013-160520a-302818E
     
  3. Groovy-Music

    Groovy-Music Member Guru

    Messages:
    113
    Likes Received:
    0
    GPU:
    MSI GTX 1070 AERO OC
    Despite the 2 cards having high usage, I'm having negative scaling using crossfire.

    The frames rate and the GPU usage are fluctuating and overall producing LOWER MINIMUM FPS with crossfire on. Specially on the planet Endor (the forest) (I'm getting some 30-35 as the minimum FPS on Endor with 2 cards and around 50 FPS with just one)

    To me, it's best to disable one card....as per usual :(

    I suppose the persons not observing problems with crossfire are having 2 powerful enough cards to not suffer the negative scaling.


    ^ Yes
     
  4. spyre

    spyre Master Guru

    Messages:
    227
    Likes Received:
    0
    GPU:
    AMD 6990 and 6970 TF
    If for some reason it isn't working for you, you can try manually adding a profile and picking the bf4.exe profile see if that works.
     

  5. ddelamare

    ddelamare Master Guru

    Messages:
    224
    Likes Received:
    5
    GPU:
    Inno3D GTX 1070 X4
    Thanks, i'll give that Driver package a shot when i get home tonight.

    As for the profile, i've already tried to assign it the BF4 one. I came across that in another post and thought 'maybe...' but no joy :)

    I've went back to using my R9 280x cards. Nano was problematic so RMA'd it.

    If anyone else could check and see if it works, that would be great. Cards and Driver version.

    I think theres something strange going on here. I have bad voodoo. :3eyes:

    Thanks for the help thus far
     
  6. ddelamare

    ddelamare Master Guru

    Messages:
    224
    Likes Received:
    5
    GPU:
    Inno3D GTX 1070 X4
    Ok, issue resolved.

    Seems it was an issue with the CF bridge or CF fingers on the cards.

    I have it working now as i had the same symptoms in a game that i know works in CF.

    Adjusted the cables whilst a game was on and BAM..., fixed.

    Now i just need to order a new bridge just to make sure.
    Any ideas? Looks like all the fancy bridges are for sli (nVidia) :(

    As another side effect though, i have missing Black textures in Battlefront. If its not one issue, something else pops up :p Other CF games are working perfectly.

    nutz... lol :bang:

    (Queue Benny Hill Music)
     
    Last edited: Jun 1, 2016
  7. Groovy-Music

    Groovy-Music Member Guru

    Messages:
    113
    Likes Received:
    0
    GPU:
    MSI GTX 1070 AERO OC
    http://help.ea.com/ca/article/common-gameplay-issues-and-workaround-star-wars-battlefront/

    Errors and issues:


    <<Lower than expected performance when running AMD CrossFire dual graphics cards Performance Gameplay PC
    A driver issue causes dual graphics card setups with AMD Crossfire to suffer performance drops.>>

    -AMD is working on a driver update for this issue.

    -In the meantime, disable one graphics card to avoid performance problems.

    Right-click your Desktop and select Catalyst Control Center.
    Open the Graphics menu.
    Click CrossfireX.
    Uncheck Enable Crossfire.
    Click OK to save your settings.

    Have 50% of the performance you paid for :!)
     
  8. Illyrian

    Illyrian Master Guru

    Messages:
    222
    Likes Received:
    13
    GPU:
    2080 Super
    I still have Flickering Shadows when I use Crossfire.... I always have, in quite a few games, but on Star Wars the game is unplayable....

    I haven't been able to play the game much since I bought it, and no it's not a problem with my setup or system.... AMD actually says it's a KNOWN ISSUE

    I posted about it here before, here is the video

    http://vid190.photobucket.com/albums/z75/Adon604/StarWars_zpsmlpo6d5j.mp4
     
    Last edited: Jun 2, 2016
  9. primetime^

    primetime^ Master Guru

    Messages:
    909
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    Hey sure i agree they should have CF working perfect since this is dice and amd were talking about. But your not able to play battlefront with one 290? What you playing it at 4k? I can play it fine at 1440p on my ancient 280x:)
     
  10. ddelamare

    ddelamare Master Guru

    Messages:
    224
    Likes Received:
    5
    GPU:
    Inno3D GTX 1070 X4
    Im more pissed about AMD Care telling me that @AMDMatt tested this with crossfire just a few days ago and didnt encounter any problems.

    These guys are just complete monkeys, minimal everything, including testing.

    My eyes are not lying.
     

Share This Page