Critical Nvidia Geforce 9500m GS problem

Discussion in 'Videocards - NVIDIA GeForce' started by abdullah_mag, May 15, 2009.

  1. abdullah_mag

    abdullah_mag Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    gtx 675m
    here's the thing
    i got Acer aspire 6920g Intel Core 2 Duo 2.0 GHz, 250 Hard Drive, and supposedly 4gb RAM.

    i have Mirror's Edge, Unreal Tournament 3, Prince of Persia and Dead Space.
    they all start ok, no lags, very good fps and smooth gameplay.

    it doesnt take long for thing to turn into crap.

    the fps goes down from 60-90 to 5-10, and stays that way, and even when i restart the game or laptop.

    i know people r gona tell me that my laptop cant run those on high, well im not, mirror's edge and prince of persia are on medium, unreal tournament on high textures and graphics, and dead space (which is the one that lags the least) all on high.

    idk what to do but someone has gotta tell me how to fix this terribleterrible lag, i wanna have fun without having to think if im gonna die or not after this frame!!!!

    and for the solution u gonna sugges, im gonna tell ya what things ive tried ((which is most of what ur gonna say)):::

    i scanned, defragmened and error checked my pc, i entered nvidia control panel and made everything provide high performance and ignore high graphics, i dusted my laptop from THE INSIDE, i installed the latest drivers, i turned physx off........hmm what else......oh.......i reinstalled the games, and i checked their system requirments and compatibilty on my laptop on www.systemrequirementslab.com before i even got them....www.yougamers.com too.

    this was this just one time today where the laptop ran he games like a hot knife in cold butter, the gameplay was very very very smooth, even on high graphics on prince of persia and unreal tornament 3 ((on the sandstorm map where even high end pcs can have a slight slugishness on it)) but it suddenly shut down without notice, and it has never done that again since then.

    please if u got any solution, advice or have faced a similar problem before, please please post it to me, or pm it.....plz
     
  2. snip3r_3

    snip3r_3 Ancient Guru

    Messages:
    2,983
    Likes Received:
    0
    GPU:
    1070
    I think that your laptop is overheating. You may try to use Rivatuner to check your temperatures if it can read off it. If temperatures are indeed high, I would suggest getting one of those laptop cooler pads, or just make sure your laptop has proper ventilation.
     
  3. abdullah_mag

    abdullah_mag Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    gtx 675m
    no its not overheating, the temperature is very stable here.

    ive seen someone saying he updated his BIOS to version 1.10 ((i got 1.07)) and it kinda solved the problem, but he also said it did very strange thing.

    i would overclock my CPU ((even if its just for a notch)) to get those stuff working good, but idk how to do it, and if i do its not always guaranteed

    today i just found out how to make UT3 stable ((but im not happy with it)), i simply set the screen percentage or whatever its called in the advanced video option to the lowest as possible ((it was 100 but now its 50)) it worked fine without lag but the graphics were horrible.

    and about this one time where the laptop just jumped up another 100% in performance and ran all games very very very good ((look at the original topic)) idk what was that but there has to be an explanation for it or someway to reanimate the conditions to make the laptop do it again.

    and please post all the ideas u have on your mind, i could use all sorts of help right now...
     

Share This Page