Crimson Skies - no H/W acceleration working

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by HitmanBM, Sep 1, 2009.

  1. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    Hello to everyone. I have a problem with Crimson Skies (yes, that oldie from 2000 :wanker:).

    When I click the game icon, a window shows up which lets me choose the rendering method. That can be either Software or Accelerator.

    The problem is, it only works in software mode. Whenever I choose the Accelerator mode (Direct3D) the screen turns black when a mission starts, and after a while the game crahses to desktop.

    That frustrated me a bit, since the graphics look crappy in software. Plus I miss most of the game effects. On the other side, the last time I played this I had a S3 Savage 4. :3eyes:

    I looked into it and found this:
    http://forums.nvidia.com/index.php?showtopic=47481

    It seems modern graphics cards don't support textures that are not a power of 2, such as those Crimson Skies uses. I don't know what's special with these "non-power of two" textures, but my 3850 doesn't mean to work with them.

    However, someone in the aforementioned forum found that graphics cards CAN actually support these textures, as they did till a few years ago. But our beloved Nvidia and ATi driver teams decided to cease the support for them in their recent driver versions. That was decided in an effort to further increase the performance in newest games.
    So they found a trick to force the drivers ENABLE the "non-power of two" support, by editing a driver .INF file.



    Summing up, does anybody know a way to enable the support of non-power of two textures on a Radeon 3850?

    Thanks in advance.


    P.S.
    Sorry for any mistakes, English is not my native language.
     
  2. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    Come on guys... It has to be some driver file edit I suspect.
     
  3. DarthElvis

    DarthElvis Master Guru

    Messages:
    220
    Likes Received:
    0
    GPU:
    Gigabyte gtx980 g1
    Ati Tray Tools can enable support for non-power of two size textures. The setting is in the "advanced tweaks" section. Good luck.

    BTW, make sure you get the latest beta of ATT, the other one is quite old and does'nt play nice with newer hardware and drivers. See the ATT section in these forums.
     
  4. GZJ9000

    GZJ9000 Active Member

    Messages:
    59
    Likes Received:
    0
    GPU:
    H387Q512NP2 @864/2502
    In case you need to revert back the settings to the original state, check this forum post: http://forums.guru3d.com/showthread.php?t=217673

    The latest ATT (1.6.9.1391) can be found here: http://cid-a50350ea7a969f0c.skydrive.live.com/self.aspx/Public/attsetup.exe
     

  5. KillerSneak

    KillerSneak Banned

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    2x HD 3870's CrossFireX
    HKR,, POW2TextureCaps, %REG_SZ%, 1

    Could add that to the INF.. And reinstall the driver.
     
  6. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    Thanks but how can I do that? I mean I can't find the .inf file.
     
  7. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    No luck with ATT guys... The EnablePowerOfTwo textures tweak didn't help at all. Still not working in hardware mode.
    Any other opinions?
     
  8. bokah

    bokah Ancient Guru

    Messages:
    2,315
    Likes Received:
    0
    GPU:
    EVGA 670GTX 2G
    is this multiplayer u try to run? i never got it launch properly, sp worked tho
     
  9. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    No, it's single player campaign.
     
  10. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    Found the INF file. It was in the C:\ATI\SUPPORT\9-5_xp32_dd_ccc_wdm_enu\Driver\Driver\XP_INF directory, named CX_80257.inf but has no POW2TextureCaps entry.

    Or have I found the wrong file?
     

  11. KillerSneak

    KillerSneak Banned

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    2x HD 3870's CrossFireX
    That's the right file, you should add the entry yourself. Copy and Paste the entry to your INF (under the main device settings)
     
  12. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    OK but it's a bit... confusing! It has too many parameters. Sorry, but I'm a n00b when it comes to such matters.

    Where EXACTLY should I add the new parameters?
     
  13. KillerSneak

    KillerSneak Banned

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    2x HD 3870's CrossFireX
    [ati2mtag_SoftwareDeviceSettings]

    You should put it undert this section (were you can also find the Catalyst_version)
     
  14. HitmanBM

    HitmanBM Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Radeon 3850 PRO 512MB AGP
    Did it but the game still crashes. Is there anything else I can do?
     
  15. Chejo

    Chejo Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    Asus Radeon R9 280
    Can you tell me where can i find that file in windows vista drivers? I tried looking in several folders but I couldn't find that file.
     

Share This Page