Creative Sound Blaster Z Series

Discussion in 'Soundcards, Speakers HiFI & File formats' started by IanM, Aug 15, 2012.

  1. IcE

    IcE Don Snow Staff Member

    Messages:
    10,692
    Likes Received:
    73
    GPU:
    Zotac GTX 1070 Mini
    It won't happen in Firefox 28 or before. It's only Blink engine browsers that have the problem.
     
  2. NHK

    NHK Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    XFX 6950 2GB
    [​IMG]
     
  3. Keitosha

    Keitosha Ancient Guru

    Messages:
    4,902
    Likes Received:
    148
    GPU:
    Gigabyte Vega56 8GB
    ROFL!! Gotta love Naruto. :nerd:
     
  4. Octopuss

    Octopuss Master Guru

    Messages:
    866
    Likes Received:
    72
    GPU:
    -
    Stop spamming with those dumb pictures. This is not 4chan or something.
     

  5. NHK

    NHK Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    XFX 6950 2GB
    I guess the anti-fun police showed up, back in line ladies. :whip:
     
  6. RanDy

    RanDy New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    2 x GTX 680 MSI lighthing
    Hello to all. I just bought a sound card ZxR but i heard something strange or maybe is normal.When i switch from Speaker's to Headphone in software from creative or viceversa i hear a noise wich is coming from the case where is mounted the sound card.Is like a click coming inside from case probably from sound card.This shoud be normal ?
     
  7. bigcid1

    bigcid1 Master Guru

    Messages:
    329
    Likes Received:
    25
    GPU:
    Nvidia RTX 3080 FE
    that's normal
    the card has a internal switch .you can't listen to HP and speakers at the same time
    by design
     
  8. ROBSCIX

    ROBSCIX Ancient Guru

    Messages:
    16,241
    Likes Received:
    8
    GPU:
    22" LCD on GTX260 C216
    Most modern soundcards use relays to switch signals, either input or output or both. It is 100% normal. You are hearing the relays clicking and rerouting the internal signals of the card.
     
  9. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    Is anyone experiencing high cpu usage while the soundblaster control panel is open? I'm not sure how long it's been doing this. The only reason I even noticed it was because I had task manager open at the same time. I either have to close out the control panel or switch from headphone to speakers just to fix the high cpu usage.
     
  10. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    Anyone have any thoughts? I uninstalled the drivers and installed them again. Still the same issue.
     

  11. applejack

    applejack Master Guru

    Messages:
    584
    Likes Received:
    4
    GPU:
    MSI 3070 Ventus 3X
    which process do you see using the cpu like that ? (is it sbz.exe? )
    also, whats "high" cpu usage, like, 99% or what ?
     
  12. ArgonV

    ArgonV Master Guru

    Messages:
    371
    Likes Received:
    1
    GPU:
    AMD XFX R9 295x2
    Not here, using the SB ZxR. Is your virus scanner maybe causing it?
     
  13. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    It's labeled sound blaster control panel and sound blaster audio service. The cpu usage can get at high as 45% combined. I'm not sure if it's the antivirus. I can check and report back.
     
  14. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Yep I was initially, but seems to be OK now after a reinstall. What drivers u using? Installed the latest DK pack.....
     
  15. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    I'm using the most recent drivers that are on the creative website. What is the DK pack?
     

  16. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Don't think yours is supported by Daniel_K..

    Not entirely certain what I did to stop the high cpu load, lemme check and get back to you.
     
  17. Jkhan

    Jkhan Guest

    I'm using the same Sound Blaster Z and don't experience any issues whatosever.

    I do, however, am looking for a new decent set of cans to make use of the 600 ohm amp on the headphone jack, if its any good that is.

    So, what do you guys recommend will sound best with this sound card? Budget around 150$ maximum.
     
  18. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Seems to be the sound blaster control panel (that opens from Windows speaker settings). You can uninstal it....
     
  19. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    I need the control panel though. So uninstalling it isnt really any option. Im going to try a couple things first.
     
  20. harkinsteven

    harkinsteven Ancient Guru

    Messages:
    2,942
    Likes Received:
    119
    GPU:
    RTX 3080
    I have the same issue PhazeDelta, everything worked perfectly until I did a fresh Win 8 install a couple of weeks back. Since then it's been taking quite a long time to open the control panel and it has a high CPU usage. I've added exceptions to antivirus, makes no difference. I've done clean installs of the drivers too and rolled back to release drivers. Still the same. The only thing I can think of at this stage is maybe a windows update is causing the issue.
     
    Last edited: Sep 16, 2014

Share This Page