1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Creative Sound Blaster Z series not working with Tosklink/SPDIF

Discussion in 'Soundcards, Speakers HiFI & File formats' started by AreYouSerious, Aug 5, 2015.

  1. AreYouSerious

    AreYouSerious New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    32
    Background:

    My Rig
    Processor: AMD FX8320
    Motherboard: Asus M5 A99FX Pro R2.0
    Ram: 32 Gig DDR3
    Video Card: Radeon R9 200 Series (PCIe 2.0 x16 slot, blue color)
    Sound Card : Creative Blaster Z (PCIe x4 mode, black color)

    Os: Win 8.1

    I have hooked up this rig to my Denon A/V 2809CI Reciever via HDMI coming out of Radeon R9 and Optical/Toslink from Creative Blaster Z.

    The Problem

    I want to bang my head on the desk while writing this, I am not getting any sound to my AV Reciever when I am using TosLink for Creative. I tested that the Microphone, headphone, 3.5 mm jacks work, I can hear sound through them when I insert my headphone. But Not through Optical.

    I have disabled onboard Sound via bios, didn’t install the HDMI Audio chip drivers that Radeon have. I, did however, notice that in my control panel ***8594; Sound, I do see a TV sign with[AMD HDMI high definition sound] option and when set to default and test it, AV receiver gets a stereo signal. But when I setup Creative Blaster Z series Speakers as default (After reading on forums all over, it seems like you set the Creative speakers as default and Creative automatically kick off SPDIF output, shrugs I don’t know how creative is still a company at this stage with this sort of convoluted ways). So yeah, when I setup the Creative Blaster Z series as default and do a test, My receiver don’t receive any sound, I can however listen to it via Headphone jack or 3.5 mm jack on the card.

    Resolution steps.
    - Made sure that Sound and Video cards are not sharing channels, can share pics if that help. Not using PCIe slot because Vdo card was covering it.
    - Uninstalled and wiped the whole system. Reinstalled Windwos 8.1, MB drivers (excluding Audio), Video and Audio drivers. Still same result, Setting SB speakrs as default wont get me any sound, Setting the HDMI High definition as default will send crappy stereo signal.

    Where I am stuck.
    - I cant for the life of me figure out how to get my toslink/SPDIF to work, it is clear from all the testing that soundcard work on analog.. just not on TosLink/spdif. One of the forums suggesting was to switch on the Dolby or DTS to ensure that SB Z is forced to use SPDIF but I get a nice error message saying “the task requires exclusive use of your audio device” – I went into Sound under control panel and switched off the “exclusive use” tick box both under Spdif and Speakers for Creative.. but same error keep coming up and I am at loss

    I am extremely frustrated because I don’t know what else to do … I am not sure what else I can do to get this thing working and I feel that it is a bit too early to burn the whole rig down ……so any help that you can provide would be great.. I just want creative to behave and send me a 5.1 channel signal via Toslink


    Side notes:
    - Yes, I did change the Spdif/Toslink cable to check if it works well.
    - Reslotted both cards
    - My AV receiver can take multiple input for the same A/V channel (my older system was similar but with GeForce and Razer Baracuda sound card)

    Let me know if I can send pictures to help out some sort of diagnosis
     
  2. AreYouSerious

    AreYouSerious New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    32
    Update: After reinstalling everything from scratch.. I have been able to setup the Creative Software to DTS. But still no sound.. AV Reciever shows "DIG" sign acknowldging Digital sound input but it wont play anything
     
  3. Geryboy

    Geryboy Ancient Guru

    Messages:
    3,123
    Likes Received:
    196
    GPU:
    2080ti AMP Zotac
    You only have the Toslink in the out ? That's the 2nd from right. No other connectors are pluged in.

    Go to sound playback and click on properties @ SPDIF out SB Z.

    tick everything in the advanced tab under the exclusive mode option.

    Set SBZ as your default device (NOT THE SPDIF).


    Edit:


    then go to the recording tab in your sound devices.

    Make sure "What you hear " is activated and in properties go to the Listen tab.

    make sure Listen to this device is unchecked and select the default playback device as playthrough.
     
    Last edited: Aug 6, 2015
  4. TomiQa85

    TomiQa85 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Core I5
    Try the following:

    ctually creative sorted it, here is the solution:

    In any case, as it appears that you have freshly installed Windows 10, we suggest you checking that under Windows Settings->Privacy->Microphone both the "Allow access to the microphone on this device" and "Allow apps to access your microphone" have been correctly enabled.

    Hello! I had
     

Share This Page