Creative Sound Blaster X-Fi series Driver 2.15.0006 XP and VISTA March 2008

Discussion in 'Soundcards, Speakers HiFI & File formats' started by Krankie, Mar 14, 2008.

  1. Hyvry1

    Hyvry1 Maha Guru

    Messages:
    1,453
    Likes Received:
    0
    GPU:
    980m 8GB
    Fixed random lock-ups with entertainment mode. Now i can listen to music and watch tv without having to use game mode all the time. Surround slider is more effective too.

    It will uninstall the old drivers before installing the new ones. No manual uninstalling needed.
     
  2. roguesn1per

    roguesn1per Ancient Guru

    Messages:
    9,508
    Likes Received:
    0
    GPU:
    GTX580
  3. apintojr

    apintojr Maha Guru

    Messages:
    1,175
    Likes Received:
    0
    GPU:
    Gigabyte RTX3070
    dammit, i just upgraded my system. i had my xfi in my old setup and the last 2 drivers that came for xfi never fixed my snap crackle pop in vista. upon upgrading i decided not to install my xfi. hopefully i can fit my xfi back into the mobo with my WC setup intact already.
     
  4. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    Your right about everything but the driver. That is the last official driver release that is verison 4. Verison 4 took over version 3 as it had a few minor problems. Version 6 being the driver of this thread topic, will work with all the vista X-fi software far better than the driver in this package you linked.
     

  5. RamsesII

    RamsesII Active Member

    Messages:
    55
    Likes Received:
    1
    GPU:
    Asus ROG STRIX GTX1080
    Looks like Creative packed and older driver with the this new release :3eyes:


    ctaud2k.sys driver included in the 0006 package
    File version 6.0.1.1283
    Product version 2.14.00.0003

    ctaud2k.sys driver included in the earlier 0004 package
    File version 6.0.1.1304
    Product version 2.15.00.0004



    Can someone, who still has the earlier 0003 package, confirm this? I'd bet that the 0006 package uses the same version.
     
  6. Balthazor

    Balthazor Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    2 x Sapphire Radeon 5970
    I've been getting some weird hard lockups using this driver while just using Windows Media Player and standard Office applications.

    Went back to the 0004 driver. It's a later 'version' anyway, at least if you go by the version listed in dxdiag.exe
     
  7. roguesn1per

    roguesn1per Ancient Guru

    Messages:
    9,508
    Likes Received:
    0
    GPU:
    GTX580
    Its not version six.

    its 2.15.00.0006

    The drivers in the pack i said has

    2.15.00.0004

    There arny any major differences in .0006 to goto it, And the pack i suggested has more software bundled...AND dts works!

    Also 2.15.00.0004 Is a XFI Driver, it has been modded to work on audigy
     
  8. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    These and the last drivers generally work fine for me. The only issue I have is that if I put my computer to sleep and resume a few times it can sometimes resume and the sound is crackly and distorted.

    I have to reboot to cure it, then it will happen again after I've used sleep 4-5 times.

    Any idea as to what may be causing it? I'm using Vista64 Home Premium, and device manager reports no IRQ conflicts.
     
  9. Xercerra

    Xercerra Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    XFX 7900GTX 512MB @ 690/1740
    these driver seriously nerfed my volume by at least half of what they were with the last .0004's
     
  10. Ultraq

    Ultraq Master Guru

    Messages:
    848
    Likes Received:
    0
    GPU:
    GeForce 6800GT AGP
    Me too unfortunately. The volume dial of the Volume Panel is wound all the way up, but reports it as 0%. I can only turn the volume down.
    Back to Web Update 4 for me, which never gave me any grief.
     

  11. Balthazor

    Balthazor Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    2 x Sapphire Radeon 5970
    This 'latest' driver release does note that the master volume control on the console is buggy... so perhaps don't use that control with this driver release?
     
  12. SierraX

    SierraX New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    EVGA 8800GT
    It amazes me that CL can release a driver that one of its "Known Issues" is that the volume control in their own software will no longer work. This is ok by them? That's like saying we have this great new software and driver update for you but you will have to use a different application to change the volume because we broke it with this update and you as our customer will have to find some other way to deal with it. Thanks so much CL for all the help. :bang:
     
  13. onipuss

    onipuss Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    Club3D Radeon X1950XTX 512MB
    Installer only re-installed Audio Console as with previous drivers too.
     
  14. bLinkZor

    bLinkZor Maha Guru

    Messages:
    1,308
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FTW SLI
    Krankie, thanks for the tip man, I wouldn't have update until I read this forum so thanks alot!!
     
  15. ST19AG_WGreymon

    ST19AG_WGreymon Ancient Guru

    Messages:
    4,703
    Likes Received:
    6
    GPU:
    eVGA 970 SC ACX 2.0
    Is it worth it for me to update mine? THe whole "no sound output when adjusting from mode" has got me a bit worried.
     

  16. TheHunter

    TheHunter Banned

    Messages:
    13,405
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    hm... i don't have any volume problems what so ever, even the mode switcher works the way it should and did.

    And btw i'm using creative volume panel, and do all the stuff there...


    edit: i just saw this, maybe its this that causes some probs
    [​IMG]

    when i move the volume in Creative volume control it moves the slider for ch8 and my main 2ch can be moved too, but looks like they're set to lower levels to prevent clipping...
     
    Last edited: Mar 20, 2008
  17. h9dlb

    h9dlb Active Member

    Messages:
    58
    Likes Received:
    5
    GPU:
    EVGA GTX1080 ACX SC
    I have 4gb of ram and Vista. In Unreal Tournament 3 I have nothing but screeching and lock ups since the new drivers.

    Creative products and support sucks. I regret buying my creative web cam and xfi sound card - never again
     
  18. ST19AG_WGreymon

    ST19AG_WGreymon Ancient Guru

    Messages:
    4,703
    Likes Received:
    6
    GPU:
    eVGA 970 SC ACX 2.0
    I just installed these new ones after my old drivers decided to stop working like it likes to do every few months. I'm hoping this release is more stable. I did notice that the drivers flashed the firmware for my card, did anyone else experience this?
     
    Last edited: Mar 21, 2008
  19. Keitosha

    Keitosha Ancient Guru

    Messages:
    4,876
    Likes Received:
    129
    GPU:
    Vega56 8GB
    And how did you notice that if i may ask? :)
     
  20. deceived

    deceived Master Guru

    Messages:
    624
    Likes Received:
    0
    GPU:
    XFX radeon hd 7870 @ 1100
    if thats true its a pretty dangerous thing for a set of drivers to do.
     

Share This Page