CPU heats up and computer turns off shortly after waking from standby

Discussion in 'Processors and motherboards AMD' started by FuriousAngel, Dec 15, 2017.

  1. FuriousAngel

    FuriousAngel Member Guru

    Messages:
    186
    Likes Received:
    1
    GPU:
    GTX960 Gaming 2G
    I've got an Ryzen 1700X paired with the Gigabyte GA-AX370-Gaming K7 (new F10 EFI, happened with F7a too), CPU is overclocked to stable 3,9Ghz (but it happens with stock frequency too), C-States turned on. Everything works fine, no problems with hardware or system except one little but annoying thing.

    Whenever I wake my computer from a longer standby, I can hear that fans are much faster than usual. I can also see CPU temperatures going up every few seconds a bit more. CPU wakes with normal temperature, then goes 10 degrees or so up, goes a bit down, afterwards another another 10 degrees or so up, then down again. This goes on until the CPU reaches very high temperatures. The computer eventually just turns off (directly off, no shutdown or anything), probably hardware overheat protection. While observing this, there is no visible CPU load, and from what CPU-Z tells, no higher than usual core voltage either. Still, this happens every time I wake my computer from a standby that lasts longer than a few minutes. If I wake it from short standby, it doesn't happen. If I restart the computer before it turns itself of, everything goes back to normal.

    Does anyone know this or have a solution for it? Maybe some EFI setting that is the culprit? I'll gladly give more information if that helps. I didn't really touch any setting I know of that could be responsible. Right now, standby is kind of unusable, and that's a shame, because I used or could use it quite often.
     
  2. waltc3

    waltc3 Master Guru

    Messages:
    575
    Likes Received:
    41
    GPU:
    Asus RX-480 8GB
    This might be beside the point, but I actually stopped using "sleep/standby" in my desktop environments years ago--because of various device-driver problems I kept running into of one sort or another when things would "awaken". It just got to be more trouble than it was worth, so ever since I've simply disabled sleep/standby entirely with the Power options for Windows. If you are interested in having the cpu throttle back to run cooler and quieter then Cool'nQuiet together with the other UEFI cpu bios options will do exactly that--no need for the system to hibernate (I turn that off, too--powercfg -h off, at an elevated command prompt) and constantly putting things like drives asleep, disconnecting them from the bus, etc. ad infinitum. These features have one purpose only--power conservation, as in battery life extension--but if you don't have batteries, where's the need? Also, as fast as SSDs boot these days it's almost as fast to simply cold boot.

    Just thought I'd throw that out there for your consideration--stopping all of that mess in a desktop environment simply removes an entire layer of complexity from your computing environment. I've never missed it...;)
     
    Last edited: Dec 15, 2017
  3. FuriousAngel

    FuriousAngel Member Guru

    Messages:
    186
    Likes Received:
    1
    GPU:
    GTX960 Gaming 2G
    Thank you. Yes, I understand your point of view. It's just a kind of quality of life (and energy saving) feature. My system takes about 25 seconds to boot into the login screen (15 of which are EFI boot time even though it's set to ultra fast boot) with my m.2 960 EVO, lots of software installed. Waking it from standby is 5 seconds, and only because the display takes some seconds to turn on, that's quite a difference. I'm the on/off kind of user, I use the computer a lot, also for work, but then am offline an hour or three, and that's where standby comes in really handy, specially because I can quickly resume my work just where I stopped.

    CnQ unfortunately doesn't work with the computer overclocked, and the energy saving is still much higher with standby compared to just CnQ and turning off devices.
     
  4. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    5,431
    Likes Received:
    122
    GPU:
    GTX1080Ti
    -
    Have you checked the CPU cooler? Is the fan running correctly? Are you using an AIO? Can you monitor the pump speed on resume? Something is not being initialized correctly when resuming. What software do you have that can read senors? Have you looked for changes using say HWInfo64 between a regular boot and resume? Have you tried different resume modes? Hybrid vs standard?
     

  5. FuriousAngel

    FuriousAngel Member Guru

    Messages:
    186
    Likes Received:
    1
    GPU:
    GTX960 Gaming 2G
    There's not really much time to check on things before the computer shuts down after standby. I could check that all fans are running, also the pump appears to be working, at least I could hear the noise. In fact, the whole case is louder than in idle, so I guess it's trying to compensate the heat (most case fan speeds are based on CPU temperature). I grabbed two screenshots of HWinfo, two minutes after a fresh reboot, and about 30 seconds after standby. It's a lot of data!

    Here is the fresh boot:

    [​IMG]

    And this is after standby:

    [​IMG]

    The two things I could see there is that after a standby, most fan speed sensors don't seem to be readable, and a serious difference in CPU wattage. But I don't know what causes is. Could the high wattage be the reason for the shutdown?
     
  6. waltc3

    waltc3 Master Guru

    Messages:
    575
    Likes Received:
    41
    GPU:
    Asus RX-480 8GB
    My SSD takes all of ten seconds to boot--I don't mess with sleep, accordingly--just no need and more trouble than it's worth. Have disabled hibernation, etc. and don't use fastboot. Also, I've overclocked to 3.8Ghz stable with 1.425 V on air and C6 states and Cooln'Quiet work just fine (I had my old FX-8320e setup in a similar fashion.) I can only suggest that possibly coming out of standby to such an overclocked state triggers a slight power surge which in turn triggers your mobo's cpu voltage-protection and shuts you down. You can avoid many troubles by simply refusing to invoke sleep, I've found.
     
  7. Arshad Hussain

    Arshad Hussain Member

    Messages:
    25
    Likes Received:
    3
    GPU:
    AMD Radeon HD 6850
    Reinstall Cpu cooler with a good thermal paste after that start your computer and do a stress test and check you are experiencing any lag or jerks.
     
  8. sykozis

    sykozis Ancient Guru

    Messages:
    20,386
    Likes Received:
    214
    GPU:
    XFX RX 470
    Judging by the missing data, I'm wondering if the UEFI is corrupt or not re-activating the fan headers properly. Sadly, I have the same issue if I enable sleep. My problem results from my pump not spinning back up properly, resulting in CPU overheating. The solution was to disable sleep and hibernation.
     
  9. tsunami231

    tsunami231 Ancient Guru

    Messages:
    8,321
    Likes Received:
    112
    GPU:
    EVGA 1070Ti Black
    dont use sleep/hibernation, Is wating 15 seconds or less from boot to desktop, really that much of issue? you cant say that 10 seconds save if benfical, if you had say 3m boot to desktop times and less then min with sleep ok i see it as usefull, even then imo sleep/hibernations has always been more trouble then it worth just to save a few seconds, which why its first thing i disable
     

Share This Page