correctly apply the nVidia settings for videos

Discussion in 'Videocards - NVIDIA GeForce' started by Aquinax, Oct 8, 2012.

  1. Aquinax

    Aquinax New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    NVIDIA GeForce4 MX 440 wi
    I have a problem with a "prehistoric" nVIDIA GeForce4 MX 440 with AGP8X . When playing videos, almost all media players apart from the Windows Media Player use the display settings reserved in the GPU for the desktop while the video settings (which are much brighter in my case) are only used by the Windows media player. (The settings of my nVidia card feature two different sets of settings for deskop and for videos). The result is that it's almost impossible to watch videos on the media players of my choice since the picture is simply too dark. And that is quite a disadvantage if you know what WMP generally stands for and one compares it to some other software out there, as for example the COWON's JetAudio.

    I want to note that the same thing (desktop settings are used for video playback instead of the video settings) happens when I play a video while another player is also busy playing back. It appears as if one player already uses the codecs or the GPU recources the other is restricted to use them properly.
    I am used to read a lot on the monitor, so the display settings are darker by default whilst I also enjoy watching videos, especialltg documentaries, so the display settings for these the two purposes must remain different for me. And I would really like to use a player other than the Microsoft's WMP product.

    Any suggestions how to solve this problem will be truly appreciated.
     
  2. IKnowJack

    IKnowJack Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    GTX470
    i think its got something to do with "video overlay" settings (overlay support has been dropped since vista)...
    IIRC there should be gamma, brightness, contrast etc in the nvidia control panel....one for Desktop...one for Video...
    you might need to force overlay support in the media player you want to use..if it still supports overlay!


    edit..here..
    [​IMG]
     
    Last edited: Oct 9, 2012
  3. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    You have to set Video playback to limited (16-255), I'm not sure where is that option in classic panel, maybe under video, fs video etc.

    But, that picture you get is a full (0-255) colors, and therefore, it is better with contrast etc. and much more enjoyable to watch movie then with limited. Maybe your display settings are not good, and you should correct monitor brightness/contrast.

    Anyway, on every newer (or older for that matter) nVidia GPU, i always set it to 0-255 to get better (more realistic) picture quality in videos. On limited, it looks like washed out image.
     
  4. Aquinax

    Aquinax New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    NVIDIA GeForce4 MX 440 wi
    IKnowJack,
    It is indeed as you said - just changed the video renderer from VMR (.. Direct X 9) to Overlay Mixer in the Direct Show options of JetAudio's Preferrences and the video playback accepted the the desired video settings .. !
    It's like I was in the world of hopelessness and you dragged me out of there! (that might be a slight overstatement .. but rest assured I am really grateful to you for that piece of advice!)

    Perhaps you also could tell me how to adjust the colour settings of the videos, because changing these options:

    [​IMG]

    does not affect the colour scheme of the video playback in the slightest, while the red intensity of the picture is too much to bear. I post some example images, not sure though whether they convey the real situtation ..

    [​IMG]

    [​IMG]
     

Share This Page