Control

Discussion in 'Games, Gaming & Game-demos' started by WhiteLightning, Jun 12, 2018.

  1. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    15,767
    Likes Received:
    1,752
    GPU:
    Sapphire 5700XT P.
  2. MarkyG

    MarkyG Master Guru

    Messages:
    856
    Likes Received:
    74
    GPU:
    MSI RTX 2070 Super
    Found an interesting tweak for DX12 stuttering during heavy combat, thought i'd create a quick guide.



    :)
     
    SpajdrEX likes this.
  3. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,910
    Likes Received:
    530
    GPU:
    R9 290 Crossfire
    Thanks for the tip.I done up a guide for this sort of thing before,here is a screenshot for people also.

    1.Search and Open Exploit Protection
    2.Click On the Program Settings Tab
    3.Click On The + Add Programs To Customise
    4.Click On Choose Exact File Path
    5.Find Game Which You would Like To Try To Remove DX12 Stutter Click Open
    6.Programs Settings For Game Opened ,Scroll Down To Control Flow Guard(Never Use For Global Setting)
    7.Put Check Mark In Override System Settings And Turn From On To Off And Apply
    8.Restart May Be Needed

    [​IMG]
     
    SpajdrEX and MarkyG like this.
  4. SpajdrEX

    SpajdrEX Ancient Guru

    Messages:
    2,092
    Likes Received:
    435
    GPU:
    GB RTX 2060 SUPER
    Great work MS once again, users needs to disable their crap :)
    Anyway good to know, can this be used for Windows Store games?
     

  5. kx11

    kx11 Ancient Guru

    Messages:
    3,056
    Likes Received:
    195
    GPU:
    2080ti watercooled
    Epic game store sucks , i uninstalled the game today then i tried tro install it again , guess what?! it says " unavailable" !!!


    any fix for that ?
     
  6. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,910
    Likes Received:
    530
    GPU:
    R9 290 Crossfire
    This happened to me after moving the game.To go from unavailable to install again .
    Settings->Edit vault cache location path and change path, then restart.
     
  7. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    15,767
    Likes Received:
    1,752
    GPU:
    Sapphire 5700XT P.
    CFG from memory should be avoidable via a compile setting or flag but I guess the game omitted that and it gets hit by this security routine and as a result the performance penalty from this measure. Well it can be fixed in the upcoming patch assuming it wasn't deliberate.
    (As I recall Monster Hunter World is also one of the few other games where this is a issue from well I need to look up the specifics but some flag during compilation and it engages Control Flow Guard when it's probably not intended.)

    EDIT: Ah Monster Hunter World via SpecialK for how it worked in that.
    https://steamcommunity.com/app/5820...594817439431537/?ctp=275#c1744479698815734092


    Probably a decent security measure but yep performance hit.
    (Guessing control flow guard dispatch protection points is a default to on thing in VC++ 2017 and newer SDK's then or something along those lines.)


    So probably something that's not set to enable CFG but untick to disable if it's defaulting to enabled but I don't know though whitelisting the exe or just disabling CFG and accepting the risk (Yada yada.) and that resolves it.
     
    Last edited: Aug 31, 2019
  8. kx11

    kx11 Ancient Guru

    Messages:
    3,056
    Likes Received:
    195
    GPU:
    2080ti watercooled

    still nothing , i get error md-0011
     
  9. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,910
    Likes Received:
    530
    GPU:
    R9 290 Crossfire
    Sorry man,It did work for me.Someone else must have an idea then.

    I can upload the game for you if you want.Would not be a problem at all.
     
  10. jmmy23

    jmmy23 Master Guru

    Messages:
    217
    Likes Received:
    13
    GPU:
    1080ti
    Dudes. I have 33fps-to 60fps and when its 33fps its definitely slows on combat, on 2080 ti Aorus Xtreme Waterforce with 9900K.

    Is any way to improve screen tearing/slowing on 30 fps? Its only in light areas. On darker i dont see even.

    Using RAYTRACING HIGH,1440P render without DLSS. It looking so real. I am impressed.
    But when i use DLSS ( 960 P ) i see an difference. Now its not looking so real and in fightning i just cant be happy with image quality + definitely i see low res and jaggies. Ehhhh.........

    Or maybe its in my brain?

    So what now. Play with 33fps+ 40+50+ or with DLSS full smooth?
     

  11. kx11

    kx11 Ancient Guru

    Messages:
    3,056
    Likes Received:
    195
    GPU:
    2080ti watercooled
    thanx man but you shouldn't do that , it's illegal :D
     
  12. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,910
    Likes Received:
    530
    GPU:
    R9 290 Crossfire
    @jmmy23
    Not sure why you want people to tell you how to play the game.It should not matter to anyone how you play.
    You could always play something else until the game gets DLSS 2560x1440 .For your 2560x1440 monitor.
     
  13. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,910
    Likes Received:
    530
    GPU:
    R9 290 Crossfire
    LOL that would be true,there is no protection in the game at all.Just down load a repack and put it in EPIC files and verify game files.I am sure your all ready done this anyway.

    That if EPIC has a verify thing.I am just messing around,I know you know more about computers then I ever would know.
     
  14. jmmy23

    jmmy23 Master Guru

    Messages:
    217
    Likes Received:
    13
    GPU:
    1080ti
    Hmmm ok fine. Just asking:)
     
  15. Syranetic

    Syranetic Master Guru

    Messages:
    523
    Likes Received:
    99
    GPU:
    GB RTX 2080 Ti
    Thanks I think that helped, I was actually testing forcing physx on my CPU because my 8 cores were barely doing 40% utilization while my GPU was hovering around 100. Interestingly enough, whenever there was a stutter (usually because lots of physx objects triggered at once), I could see my GPU usage dip for a few moments to 30-40%.

    I turned physx back to auto and I am using this and so far even when hovering near a bunch of physx objects it has not happened again.
     

  16. jmmy23

    jmmy23 Master Guru

    Messages:
    217
    Likes Received:
    13
    GPU:
    1080ti
    I found out. ! I made 1440P ( first ) but render 1080P and now 55-60fps and looking awesome without DLSS and 960P
     
  17. haste

    haste Master Guru

    Messages:
    838
    Likes Received:
    191
    GPU:
    GTX 1080 @ 2.1GHz
    OK I've finished this chore and what I wrote earlier stands. Considering only gameplay/story, this is the worst Remedy's game for me. And I've played all of them...
     
  18. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,910
    Likes Received:
    530
    GPU:
    R9 290 Crossfire
    That is great,you found a setting you are OK with.Did anyone ever try to help out over at the other forums.
    I stopped playing the game , but I was playing 3440x1440 with resolution scale 2230x960 I think.

    After a couple hours ,I also found it a chore to play the game and the noise in the game ,just does not look good to me at all.Wrecking stuff is fun but gets boring quick.

    That is a good thing,still could be placebo ,works for some and others it does not .Maybe i start playing again and see if it works on my PC and stops that annoying stutter/hitching.
    Nvidia seems to have the same crap on DX12 games.DX11 is very good on Nvidia.
     
  19. Noisiv

    Noisiv Ancient Guru

    Messages:
    6,657
    Likes Received:
    499
    GPU:
    2070 Super
    You're still dong it wrong imho

    1440P display resolution, but render at 1080p DLSS, is better looking and same performing as 1080p,

    or just a tad more demanding:
    2160p display, but render at 1080p DLSS,

    - forced via render.ini
     
    pharma likes this.
  20. jmmy23

    jmmy23 Master Guru

    Messages:
    217
    Likes Received:
    13
    GPU:
    1080ti
    Not big deal. But i found this personally,just try it and i like it. Resolution 1440P. And then Render Resolution 1080P ,without DLSS. And for me its better now not low res feeling like was with DLSS 960P.
     

Share This Page