Clean install of Win 10 from USB on M.2_2 drive on Asus Z390-A fails

Discussion in 'SSD and HDD storage' started by Lucas Young, Aug 10, 2019.

  1. Lucas Young

    Lucas Young New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    RTX 2070 8GB
    Hi Guys

    I just built a gaming/editing PC using the ASUS Z390-A Motherboard and the Samsung SSD 970 EVO Plus 1Tb M.2_2 drive.
    My only other computer is a Mac and I used this to create a bootable Win10 USB. I couldn’t use unetbootin because I’m running 10.15 beta, I make the USB bootable in the Terminal (using
    /diskutil eraseDisk MS-DOS “WIN10” GPT disk2/etc) and copied the Win 10 install files to it - it boots up OK.


    My problem is that the Windows Setup process can’t install files to the drive after it’s created the partitions.
    Regardless of whether I delete all the partitions from the setup and let Windows create them, or use DISKPART in the console to do it… I get “We couldn’t create a new partition or locate an existing one. For more information, see the setup log files”
    The setupact.log file says of the main partition: “The selected disk space is not of type ESP”


    After a lot of messing around I think it might be an issue people have discussed where Windows gets confused about which drive is the boot drive, and tries to install Windows to the USB instead of the newly partitioned drive. I can’t change the boot order to fix this because while the NVME shows up in the BIOS, it isn’t something I can set the boot order of.


    if I use DART in the Rewpoair section I can see a C: (Recovery), D: (the install USB) and X: (Boot) drive


    I’ve been through a lot of the troubleshooting steps I’ve found online, including:


    Making sure CSM is disabled
    Unplugging all other drives
    Updating the BIOS
    Using DISKPART to manually create the partitions… but you can’t make GPT partitions bootable and Windows won’t install on MBR


    My BIOS settings are:


    Intel RST On
    PCH Storage Configuration -> SATA Mode Selection: AHCI
    Onboard Devices Configuration -> Hyper M.s X16: Disabled
    USB Configuration -> Legacy USB Support: Enabled
    USB Configuration -> XHCI Hand-off: Disabled
    CSM: Disabled
    Secure Boot: Other OS
    Boot Option #1: UEFI USB Stick Partition 1
    Boot Option #2: UEFI USB Stick Partition 2
    AMI Native NVMe Driver Support: On


    Any ideas what I can try next?


    Many thanks in advance!
     
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,625
    Likes Received:
    4,390
    GPU:
    GTX 1080ti
    the driver letter issue was fixed, i suspect the issue you are having is actually a fault with the NVME.
     
  3. Lucas Young

    Lucas Young New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    RTX 2070 8GB
    Thanks Astyanax.. is there a way I can tell if the NVMe is faulty?
    I remember at one point I was messing around in the BIOS and I did get it to show up... but then the system wouldn't boot off the USB.
     
  4. Lucas Young

    Lucas Young New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    RTX 2070 8GB
    Turns out once I formatted the USB as exFAT and re-created the Win10 image on it, it installed fine. Wasnt the PC at all.

    ...life...

    Thanks for the help :)
     

Share This Page