1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Changing NAT type on Windows 10 (or 4G router)?

Discussion in 'Network questions and troubleshooting' started by AsiJu, May 12, 2018.

  1. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,142
    Likes Received:
    820
    GPU:
    EVGA GTX 980 Ti SC+
    Hi!

    All of a sudden for example Destiny 2 and my PS4 started giving me warning that my NAT type is "Strict".

    Both PC and PS4 access the internet via the same 4G router, PC via LAN, PS4 via WiFi.
    Router is Huawei E5186.

    I've not knowingly changed any network security related settings yet get this warning. I'm assuming this is a router setting as the console also gives the warning.

    Only thing I did change just now is switch the PS4 to 5 GHz WiFi. Could it be the router defaults to and forces strict NAT if 5G is used?

    Or if both 2.4G and 5G are used at the same time? I also connect my phone via WiFi to internet when I'm home.

    Thanks!
     
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,863
    Likes Received:
    918
    GPU:
    GTX980 SLI
    AsiJu likes this.
  3. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,142
    Likes Received:
    820
    GPU:
    EVGA GTX 980 Ti SC+
    Thanks, I already checked uPnP and NAT settings though, uPnP enabled and Cone in NAT. As before.

    Router does not seem to have separate settings for port forwarding.

    Are there any Windows settings for port forwarding or should I check firewall settings so that those ports aren't blocked?

    I'll try setting PS4 back to 2.4 G to see if that makes any difference, though I don't understand how it should but that's the only change I've made recently.
     
  4. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,863
    Likes Received:
    918
    GPU:
    GTX980 SLI
    If the PS4 is showing the NAT strict messages it's nothing to do with Windows, got to be the router

    Wouldn't have thought 2.4GHz or 5GHz would have made any difference unless there are separate settings in the router for each band, did you check all likely suspect router settings with 2.4 vs 5GHz, switch between the two and see if anything is different, or is it a Dual-Band router that broadcasts both at once?

    Port forwarding for your router
    https://portforward.com/huawei/e5186s-22a/

    Sometimes just rebooting the router can solve strange problems
     
    AsiJu likes this.

  5. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,142
    Likes Received:
    820
    GPU:
    EVGA GTX 980 Ti SC+
    Thanks again, I'll check that link!

    Yeah it broadcasts both 2.4 and 5 at once, I can have my phone @ 2.4 and PS4 @ 5 simultaneously.
     
  6. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,863
    Likes Received:
    918
    GPU:
    GTX980 SLI
    Posh, I have 2 routers, one for 2.4GHz and one for 5GHz :D :D
     
  7. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,142
    Likes Received:
    820
    GPU:
    EVGA GTX 980 Ti SC+
    I was able to solve the problem by changing the APN address in router settings -> ISP now gives dynamic public IP.

    Also I just realised that:
    - PS4 might have given that NAT type warning from the start and I just missed it earlier
    - when I last played Destiny 2 I used a different ISP (so default APN probably gave a dynamic public IP to begin with)

    this just happened to coincide with me switching WiFi band to 5G on the PS4.
     

Share This Page