catalyst drivers 12.1, 12.2 & 12.3 crossfire issues

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by ROBIN/1, Mar 30, 2012.

  1. ROBIN/1

    ROBIN/1 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x ati 4770 in crossfire
    Hi,
    I noticed that the one of the two graphic cards (2x ati 4770's in crossfire) after installing catalyst drivers 12.1, 12.2 or 12.3 has workload 0% during gaming or benchmarks although in catalyst control center crossfired is enabled.
    ( gpu-z saw other times "disabled" and other times "enabled 2 gpu's" about crossfire).
    I had installed CAP with every version of 12.1, 12.2 and 12.3 catalyst drivers but the issue didn't solve. I tried several times to install 12.1, 12.2 and 12.3 catalyst drivers (clean install using driver sweeper, reinstalling win 7 etc.) but the issue remains testing with msi Combustor Benchmark and a lot of games like pes 2012, fifa 2012, nba 2012 which support crossfire.
    But when I installed catalyst drivers 11.12 or previous versions issue dissapeared and both cards worked properly (workload on both cards 70-95%).
    Is there any way to enable "real crossfire" using catalyst drivers 12.1, 12.2 or 12.3?
    Thank you very much!
     
  2. Drakaris

    Drakaris Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    2x Sapphire HD5850 Xtreme
    Yea, yet another of the "awsm new AMD features". Type "regedit" in the start menu, find this:

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control \Class\{4D36E968-E325-11CE-BFC1-08002BE10318}]

    You will have few keys there - 0000, 0001 or 0003 keys. Change "EnableUlps" to 0 in each one you have. Restart PC. Voila, problem solved. You have to do this after installing new drivers every time or your second card will be in "energy saving mode" (like anyone cares about energy saving with Crossfire during gaming...).
     
    Last edited: Mar 30, 2012
  3. ROBIN/1

    ROBIN/1 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x ati 4770 in crossfire
    Drakaris thank you very much for your quick response but the issue still remains after changing the values to "enableulps" to 0 (keys 0000, 0001).
     
  4. far-cough

    far-cough Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    XFX R7990 6GB
    just search for EnableUlps in regedit
    there is a lot off them in different places..
     

  5. ROBIN/1

    ROBIN/1 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x ati 4770 in crossfire
    I've allready did that without result
     
  6. Pill Monster

    Pill Monster Banned

    Messages:
    25,234
    Likes Received:
    0
    GPU:
    7950 Vapor-X 1100/1500
    Try this
     
  7. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    Hey guys I have anothe kind of problem... I was doing fine the day before yesterday when I was using the february 28th drivers with my dual 6850s.
    Saling was awesome, no flickering, no high temps, no nohting.
    Stupid as I may be, decided to try the 12.3 new drivers to find out they ****ed up my computer.
    First I has the issue I coulndn't OC well as clocks would fall back and AMD powerplay would not work in my 2nd card (with UOC allowed in afterburner), then I had my second GPU @ 99% use at desktop and now besides from having my 2nd gpu at max use, as both are linked, both are at 3d clocks at desktop... being noisy as hell and hot... all the time...

    What should I do? I already did a clean rollback to previous drivers... also did a windows restore to previous date so as to clean any remains from registry.. this is a new probelm to me... crossfire worked great from day one till I upgraded drivers !
    Should I uninstall drivers, driver sweep them, reinstall and avoid OCing with another tools than Catalyst Overdrive?
     
  8. Zemial

    Zemial Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7970 @ CF
    I have experienced awful lot of problems with drivers 12.x. Example poor GPU usage different games, especially with BF3. Odd idle clocks behaviour etc. I was going to sell my Radeon HD 6950 cards, but very last thing I tried was Catalyst 11.10 WHQL + 11.10 Cap 4, these drivers are for BF3 beta but amazingly these works like crossfire should work, proper GPU utilization, proper idle clocks, proper temps etc. Now I Get average 90fps in BF3 like it should with my rig!
     
  9. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    I'm gonna try them !
    Thanks a lot !
    I'm getting quite frustrated !
    Anyway 90fps in BF3? I was getting 100fps in bf3 with most things in ultra?
     
  10. djamorpheus

    djamorpheus Active Member

    Messages:
    64
    Likes Received:
    0
    GPU:
    Gigabyte WF 670 2GB
    Try doing an uninstall with Atiman and reinstalling drivers that did work. If that doesnt help just reinstall windows.
     

  11. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    Ok, gonna try that first.
    Reinstall windows = not an option.
     
  12. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    yeah i think everybody has come to realise AMD are skimping on there driver work force, nvidia drivers seem to be getting slightly better and better each time, so you know the best thing to do.
     
  13. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    I know drivers ARENT easy to make, there's a lot implied, too many different combinations and possibilities... but these latest 12.3 WHQL drivers are SH!T !!!
    1) shame on AMD, get a good task force for drivers, you have the money !
    2) shame on microsoft ! how in hell could they approve this piece of garbage? do they smoke pot all day or actually work?
     
  14. ROBIN/1

    ROBIN/1 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x ati 4770 in crossfire
    Originally posted by Pill Monster
    Try this

    I've allready use it without result. Summarizing the issue is independent if EnableUlps is on or off because when installed 11.12 or previous ccc version the crossfire works fine (gpu-z shows crossfire enabled) but when installed 12.x ccc version only one (main) card has workload (gpuz shows crossfire disabled). Something is faulty with the 12.x ccc versions.
     
    Last edited: Mar 30, 2012
  15. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    "SOMETHING" is faulty?
    I believe the word you are looking for is "EVERYTHING"
     

  16. ROBIN/1

    ROBIN/1 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x ati 4770 in crossfire
    Originally Posted by pokerapar88
    "SOMETHING" is faulty?
    I believe the word you are looking for is "EVERYTHING"


    You are absolutely right!!
     
  17. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    Αρχίζω να πιστεύω, στην κόλαση με την amd
     
  18. ROBIN/1

    ROBIN/1 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x ati 4770 in crossfire
    Δεν έχεις καθόλου άδικο, έχουμε και οικονομική κρίση, που να πηγαίνουμε για καινούργιες κάρτες (για nvidia φυσικά).
     
  19. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,686
    Likes Received:
    0
    GPU:
    Amp! GTX 1080 @ 2088/5300
    Economic crisis there is crazy right?
    Here its not much better....
    but videocards are very expensive !
    So for now i'll stick with this, later on I will keep with only one card... i think
     
  20. Zemial

    Zemial Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7970 @ CF
    I get 90-100fps average in bf3 depending on what map and how many players. I have everything maxed out except shadows in high, motion blur and smaa off. I have to noted that I did complete driver wipeout with driver sweeper and atiman 6.3.1. Then installed Cat 11.10 WHQL + 11.10 CAP 4. Now Crossfire work like it should!

    My main problem was that with cat 12.x my gpu usage was just ****. Hovering around 50-70%. Now Gpu usage is around 70-99% and everything work like it should.
     

Share This Page