Catalyst 8.8 OFICIAL!!

Discussion in 'Videocards - AMD Radeon Drivers Section' started by RBEJ, Aug 21, 2008.

  1. damafan

    damafan Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    MSI 580GTX Lightning III
    AA not working in Warhammer online with any of the 8.8 drivers.
     
  2. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,910
    Likes Received:
    1,168
    GPU:
    Powercolor 6900XTX
    damafan : report it to ati feedback.
     
  3. sandz

    sandz Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    Asus GTX570 DCII
    so 8.8 beta or 8.8 WHQL

    Got my new Asus HD 4870 ...so which driver wud b the best for me ?? the 8.8 beta or the WHQL one :nerd:
     
    Last edited: Aug 23, 2008
  4. eduardmc

    eduardmc Maha Guru

    Messages:
    1,315
    Likes Received:
    0
    GPU:
    Gtx 580 SLI 900/1800/4200
    this drivers hasn't giving me much problem (coming from nvidia i expected worth). some issue in some games but everything is rock solid. the only issue that is annoying at the moment that even forcing vsync i cannot get gears of war to enable it, does anyone know a solution, since rivaltuner doesn't work with this driver yet i cannot override dx.
     

  5. evolucion888

    evolucion888 Master Guru

    Messages:
    370
    Likes Received:
    5
    GPU:
    MSI Radeon RX 6900
    They can, but they won't because if you use the official drivers and have issues, you can ask for a ticket in the customer support department since it's an ATi supported product, hence more costs to troubleshoot it, and using those hotfix will free them from responsability since ATi doesn't longer support AGP, so the manufacturers are the one who must support them. I did an experiment which worked fine flashing my videocard BIOS to the ATi AGP original BIOS used on Powercolor and Club3D which has the DeviceID 9505 and works fine using the official drivers. With the new RBE, you can change your device ID of your video BIOS so you can use the official drivers and original BIOS with no issues. I modded the ATi one to use the same frequency that I had when overclocked since the Overdrive's limit with the ATi BIOS was 770MHz and my HIS Overdrive's limit was 800MHz, also I increased the fan speed slighly for better cooling and activated Powerplay which doesn't work with factory HIS AGP cards. The only issue is that Overdrive won't work anymore and I do not care since my GPU is running at HD 3870 specs except RAM which is set to 1.94GHz and I'm CPU bottleneck anyway, a core speed over 775MHz will bring little or no benefits and I wouldn't have to use Overdrive or other overclocking tools to set speed. Now my card's called Radeon HD 3800 series, Built by ATi
     
  6. absolute1

    absolute1 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    4850

    You would have failed Logic 101 if you ever took it.

    Your reasoning goes like this

    I have never had Cancer.
    So the people who do ...must be doing something wrong

    That's a Logical Fallacy that has no place in reasonable thought.

    Yes. There are users with all types of skill levels. Some causes their own problems. Some get lucky..some know how to troubleshoot

    But Im sorry to say that you obviously in the "Just got Lucky" group. It is not because of skill that you have had no problems.

    I know that for certain because if you had any advanced computer knowledge at all you would know your statment was complete rubbish

    Yes, there are complainers, who act like children, and dont have a clue what to do in troubleshooting. But there are also people who actually know a thing or 2 that are wise enough to understand Vista has many problems that rear their ugly heads in specific circumstances. It slower for many Recording studios, its slower for many motherboard chipsets, and its glitchy in areas that XP never was and performance users in any professional Audio or Video discipline would never recommend Vista, at this time, in its present state.
     
  7. poliv123

    poliv123 Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    r9 280x 3gb
    I think that the cat8.8 performs better (fps) with games, vantage etc..(Better CF support etc..)
    But this driver has problems too(For me)
    In random reboots (1 in 5 or 1 in 10)the ccc crashes with the message(''Catalyst control centre:host applicatin..has stopper working''
    Description
    Stopped working

    Problem signature
    Problem Event Name: CLR20r3
    Problem Signature 01: ccc.exe
    Problem Signature 02: 2.0.0.0
    Problem Signature 03: 469cdc9c
    Problem Signature 04: mscorlib
    Problem Signature 05: 2.0.0.0
    Problem Signature 06: 475777fa
    Problem Signature 07: 11a6
    Problem Signature 08: 0
    Problem Signature 09: System.ObjectDisposedException
    OS Version: 6.0.6001.2.1.0.256.1
    Locale ID: 1032

    Extra information about the problem
    Bucket ID: 239113851
    something like that i don't remeber exactly.

    I did uninstall device and driver--driver clean(driver sweeper-driver cleanser.net) and then install again new driver8.8 but nothing in this problem!
    Also after installing cat8.8 i installed net framwork 3.5.is it good or bad?
    Sometimes (random)i have artifacts in vantage
    Everything else is ok!!!
     
  8. Stukov

    Stukov Ancient Guru

    Messages:
    4,899
    Likes Received:
    0
    GPU:
    6970/4870X2 (both dead)
    Actually I have read enough of your rantings and blahs not to read any more. Myself and others have tried help you countless times and you were more concerned with ranting and raving than anything else. By hell, you could have just posted the most brilliant piece of text ever, but by god I am not going ro read it. I think you may find that many others will not either. We really got sick of your posts.

    BTW, I accidently got about a sentance into your response before I realized it was you, and let me tell you. Oh boy, Stuwart, shesh, you dun and got me good. Excuse me, I must go home and cry to mommy now /sarcasm.
     
  9. Stukov

    Stukov Ancient Guru

    Messages:
    4,899
    Likes Received:
    0
    GPU:
    6970/4870X2 (both dead)
    OOOH I am sorry, 90watts. Mea culpa. Mea culpa.

    I am sorry if I don't quite piece 2 and 5 together while you claimed to have problems with ATI drivers and OpenGL while in a DirectX game.

    And what new and upcoming games will be made on OpenGL again? Oh thats right, even ID software has bailed on OpenGL. You want perfect OpenGL, buy a FireGL card, their OpenGL functions should be just fine. Because if you haven't heard, DX quite took over OpenGL, OpenGL is mainly only used for professional work, and DX is used for games.

    OMG, ATI doesn't have full support for GLIDE the world is comming to an end!!!
     
  10. John

    John Ancient Guru

    Messages:
    16,764
    Likes Received:
    12
    GPU:
    GTX 970
    Enable the D3D overrider application that's located in the RivaTuner directory. Then force vsync from CCC.
     

  11. Darkuser

    Darkuser Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    HD4870
    Logic fallacy? You just compared random computer problems to someone randomly getting cancer.

    Computer problems are like the Flu. You can protect yourself from it and not put yourself in dumb situations where you will have to suffer. And if you do happen to get it because any OS is not perfect, it's not the end of the world.

    i.e. My brother's DVD drive randomly stopped working after installing a new anti-virus software. Your average user can't figure out how to fix it, goes 'omg, I have to reformat now'. Your advanced user identifies the problem, in this case registry corruption, edits a few lines of registry and your good to go in a few minutes.

    I never said Vista was a perfect OS, but after 5 years of dealing with XP, the lack of general stability and the lack of tools to identify and fix problems manually and automatically, I have to say Vista is superior in that area.
     
  12. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,445
    Likes Received:
    2,237
    GPU:
    GTX1070 iChillx4
    I guess this is vistax64 driver related :( i tried vsync in ccc, didnt make any difference. sh and bt still crash at the start
    thanks for you help though
     
  13. BlauweTulp

    BlauweTulp Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    5870 1GB
    You don't happen to run Ati Tray Tool? I had this error on startup, when both the CCC & ATT are running at the same time. To fix it, I disabled the auto startup of the CCC. You can disable the auto startup of the CCC in you registry, or with a tool like autoruns. This fixed the error for me. It is still possible to start the CCC! I think it is a conflict between CCC & ATT, booting up at the same time. When the CCC starts up later, the ObjectDisposedException does no occur.

    I see you have a crossfire setup. When you have enabled or disabled crossfire, Vantage bugs with artifacts on my computer as well. So: whenever you enabled or disabled crossfire, reboot before you run Vantage, and you should have no artifacts.
     
  14. janolle

    janolle Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    ASUS HD4850
    I think that it might be a heat problem instead of a driver problem.
    I had the same problem and the solution was putting some cooling on the hot chips on the backside of the card. I'm not taking my card out of the case for pictures so I robbed these pictures and marked the chips for you if you want to try it out. Two small Zalman memory heatsinks should suffice if you cover the two close ones with one heatsink.
    [​IMG]
    [​IMG]

    EDIT:
    My Cat 8.8 problem is that I get a black screen when I install the buggers. Can't even get to windows because of this. Keeping 8.7's that work flawlessly.
     
    Last edited: Aug 25, 2008
  15. alcest

    alcest Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    MSI R9 280X
    guys, i dont have problems with (none of the) :) games you posted here,
    i had with some, on 8.8b, but they re gone,
    and i have XP, so vista might still be the problem maker,
    in general i would say ati, even with a bit worse drivers then nvidia, is still WINNER with HD4800 (I previously owned 8800gts).
     
    Last edited: Aug 25, 2008

  16. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,445
    Likes Received:
    2,237
    GPU:
    GTX1070 iChillx4
    its not vista. the games worked perfectly on my 8800gtx
     
  17. drumthrasher109

    drumthrasher109 Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    HIS 4850 512MB
    For people who want some info:

    [​IMG]
     
  18. Valagard

    Valagard Guest

    After a reinstall of Vista, I went back to 8.7's, and 3D games worked fine.

    So I tried 8.8's, and it was back to blank black screen when playing fullscreen 3D games.

    So I played around with my computer, and I tried uninstalling, reinstalling 8.7's and 8.8's for hours, 8.7's would work, 8.8's would not.

    After about 4 hours, I went into the monitors section of the drivers setup, and examined what was different between 8.7's and 8.8's

    The 8.8's with my monitor off, would still say it was on and enabled, even though no picture was being broadcasted too it, and vista's display manager also said it was disabled and off.

    So, I unpluged the second monitor, and tried a 3D game.

    SUCCESS!!! It worked! I can play games again!

    So I hooked back up my second monitor and rebooted my comp, and since then I can play fullscreen 3D games with the monitor being either on or off.

    But for this bug to slip through testing baffles me.
     
  19. mysterfix

    mysterfix New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Xfire HD4850@850/1180
    I've read so many people having trouble with these "official" 8.8 drivers it's crazy! Seems like theses are betas and the betas are the more stable version.
     
  20. busta_dude

    busta_dude Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    Sapp R9 280x Dual X Stock
    Yup...same for me...8.8 WHQL are nuts. Going back to the BETA..This BETA more stable for me with any games....
     

Share This Page