Catalyst 11.2 Display Driver installation failed :(

Discussion in 'Videocards - AMD Radeon Drivers Section' started by robert1990, Feb 26, 2011.

  1. robert1990

    robert1990 Master Guru

    Messages:
    734
    Likes Received:
    0
    GPU:
    HIS 5850 iCoolerV750/1100
    Need help here, got a problem when installing the display driver.
    [​IMG]
    Any ideas? :(
     
  2. geppwnd

    geppwnd Member Guru

    Messages:
    141
    Likes Received:
    0
    GPU:
    MSI GTX 680
    Go to device manager and remove/uninstall your display adapter. Then reboot and let windows install the default plug & play drivers aka generic ones. This is assuming that you remove your drivers via the control panel and use the catalyst installer to remove all components.
    You can try and boot in to safe mode, use driver sweeper to remove the ati display, then go to start and type %temp% to remove your temp files. Now open up windows explorer and remove a folder call ATI under C:\ directory, this is where the extraction of the previous driver is located. Also go to Program Files and remove and AMD or ATI name folders.
    Now restart in normal mode and install your new drivers.
    This might also have something to do with SP1 if you are using win7.
     
  3. robert1990

    robert1990 Master Guru

    Messages:
    734
    Likes Received:
    0
    GPU:
    HIS 5850 iCoolerV750/1100
    OK, tried everything you typed above, then installing the 11.2 driver, the report still says the display driver installation failed :(

    EDIT: After reboot, the generic driver is working. I ran the 11.2 installation, but the CCC didn't installed in my PC.
     
    Last edited: Feb 27, 2011
  4. Murderonomist

    Murderonomist Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    X-Weasel 2870.5 Graphica
    Check to see if you have the file "difxapi.dll" in your System32 directory. I was having failed driver installation problems earlier before I found out this file was missing.
     

  5. robert1990

    robert1990 Master Guru

    Messages:
    734
    Likes Received:
    0
    GPU:
    HIS 5850 iCoolerV750/1100
    Ran a Search, found 4 of them. Is that correct?
     
  6. Murderonomist

    Murderonomist Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    X-Weasel 2870.5 Graphica
    I don't know about having 4 of them, but assuming one of this is in System32, then you're having a different problem than I was.
     

Share This Page