Catalyst 10.4a Preview

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by KyleStilkey, Apr 21, 2010.

  1. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    440
    Likes Received:
    0
    GPU:
    Sapphire RX 580 Nitro+
    http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst-10-4-a-Hotfix.aspx

    The ATI Catalyst 10.4a Preview provides resolution for the following issue:
    • Long load times for new maps in Battlefield: Bad Company 2 when using a Windows 7 / Windows Vista based system with an:
      [*]ATI Radeon HD 5xxx series graphics card
      [*]ATI Radeon HD 4xxx series graphics card
      [*]ATI Radeon HD 3xxx series graphics card
      [*]ATI Radeon HD 2xxx series graphics card​
    • The XP driver is provided only as an early look of Catalyst 10.4

    [​IMG]
    Thanks CyberTronics
     
    Last edited: Apr 22, 2010
  2. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    440
    Likes Received:
    0
    GPU:
    Sapphire RX 580 Nitro+
    Seems like every time I go to install them, the ATI Install Manager crashes...
     
  3. CyberTronics

    CyberTronics Active Member

    Messages:
    95
    Likes Received:
    0
    GPU:
    4870 512mb 800/1000
    installed them successfully. Screenshot on Vista X86 SP2:
    [​IMG]
     
  4. buddyfriendo

    buddyfriendo Ancient Guru

    Messages:
    3,394
    Likes Received:
    0
    GPU:
    EVGA GTX 480 SC
    Works great here, connected to a server and it loaded in 7 seconds compared to 30-40 seconds. Awesome!
     

  5. ehsancgfx

    ehsancgfx Active Member

    Messages:
    75
    Likes Received:
    0
    GPU:
    Nvidia 560GTX & ATI 6770m
    This driver got some real issues with 3ds max. the viewport tools gets invisiable. revert back to prior driver and its ok.
     
  6. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    440
    Likes Received:
    0
    GPU:
    Sapphire RX 580 Nitro+
    Fixed the install manager crash. Apparently a VC++ file was corrupted.
     
  7. hallryu

    hallryu Don Altobello

    Messages:
    11,378
    Likes Received:
    0
    GPU:
    2x HD7970 - QNIX/U2711
    Driver & CCC version appears newer but others appear to be slightly older!
     
  8. sanel

    sanel Member Guru

    Messages:
    160
    Likes Received:
    0
    GPU:
    6850 Cycl 1gb @ 940, 1200
    any benchmarks to compare them with 10.x?:nerd:
     
  9. wallblow

    wallblow New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire Vapor-X 5870
    I had random crashes on Bad Company 2 with the 10.4 preview, I could not play an entire game without a grey screen. I think this version fixed it for me, i've just played 3 hours in a row without any crash :banana:
     
  10. VERRY

    VERRY Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    Ati HD5850

  11. BrainDedd

    BrainDedd Member Guru

    Messages:
    183
    Likes Received:
    0
    GPU:
    ASUS Strix GTX970 OC
    Based on the release notes, just that they fixed the Bad Company 2 loading issue for all the rest of the cards, not just HD5xxx.
     
  12. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    1,564
    Likes Received:
    0
    GPU:
    R9 Fury
    Glad you got that worked out. I will make a note of this. What did you do to correct the issue?
     
  13. Sneakers

    Sneakers Ancient Guru

    Messages:
    2,714
    Likes Received:
    0
    GPU:
    Gigabyte 980Ti Windforce
    I can't get this driver to install properly either.

    First I got a warning message during the install and basically tells me that not everything was installed, but looking in the report there is no further info on what exactly the error was.

    Obviously CCC and the driver itself failed to install. So I tried to manually install driver then CCC, I managed to install the driver but I cannot get CCC to install.

    Now I cleaned registry files and other remaining files 2-3 times and still it fails to install with a little warning prompt comming up each time. Extremly annoying...and if that wasn't enough now the old drivers cannot install properly either so something has been fed up in the ati registry.

    Anyone got any ideas except formating? I had this happend before when driversweeper broke things, maybe 2-3 times and I know I had to formate each time but one after those things happend ( now I can't remb what I did that one time to get it working without a formate, sigh ).


    /edit

    Oh well this driver properly f'ed my system, that or driversweeper..

    How do I install CCC manually without the for me bugged manager?


    /edit2

    Tested the driver now with BF2 and yes loading is alot quicker about 6-7 seconds from when you press join until you land on the weapons selection. But still I have found no way to get CCC working here, totally bugged out for me.
     
    Last edited: Apr 22, 2010
  14. VenoMaizeR

    VenoMaizeR Member Guru

    Messages:
    123
    Likes Received:
    0
    GPU:
    Asus Strix RX480OC 8gb
    Got a error in the end of the install but i did a reboot and all install ok. Loadings are fast now and i notice also a boost in performance on my 4890... only report i have on BFBC2 is the click to spawn it a bit laggy or strange..
     
  15. dirthurts

    dirthurts Master Guru

    Messages:
    727
    Likes Received:
    0
    GPU:
    RX 580 4gb
    In my experience driver sweeper causes more problems than it solves...
    I recommend installing over top of older drivers. Works best with non beta releases however...
     

  16. TwL

    TwL Ancient Guru

    Messages:
    1,828
    Likes Received:
    0
    GPU:
    2x5850 2x6950 + 9800GTX
    hmm, Seems crashing a lot while extra features are enabled.
     
    Last edited: Apr 26, 2010
  17. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    5,947
    Likes Received:
    5
    GPU:
    GTX 1080 FE @ 2ghz
    With me its the other way around, If I dont use driver sweeper and unistall, files doesnt get copy over right when I install over. I tried the install over a copy of times. I always have to uninstall, sweeper and install.

    Edit:Hmm THese I cant use 1ghz gpu any more as it doesnt let me set it any more only 960mhz is setable.
     
    Last edited: Apr 22, 2010
  18. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    440
    Likes Received:
    0
    GPU:
    Sapphire RX 580 Nitro+
    I download Visual C++ 2005/2008 64bit and 32bit versions with each SP. It worked out fine.
     
  19. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    440
    Likes Received:
    0
    GPU:
    Sapphire RX 580 Nitro+
    Was your error something like APPLICATION WAS NOT GIVEN PERMISSION TO INSTALL?

    If so I had that too and now anything with ATI slapped onto it gives me this error when trying to install it (only tested ATI Crossfire Profiles)

    "The system administrator has set policies to prevent this installation"

    Can't seem to get it to stop no matter what "FIX" I try.
     
  20. Scerate

    Scerate Maha Guru

    Messages:
    1,039
    Likes Received:
    0
    GPU:
    980Ti@1.5/1070N@2Ghz
    Installed these instead of the normal 10.4 Preview one, even there 2d Artifacts on mass i'm back to 10.3 OPENGL 4 atm. :(
     

Share This Page