Catalyst 10.3pre (8.71) leaked (Win7/Vista)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Ti3Kob, Feb 19, 2010.

  1. Roffle

    Roffle Member Guru

    Messages:
    136
    Likes Received:
    0
    GPU:
    ASUS HD 5770 CUcore
    I tried this using my HD 4770 CrossFire setup, flickers badly in Crysis (frames alternate between black and rendered frames). Other than that, it works beautifully. Going back to 10.2.
     
  2. blitze

    blitze Member Guru

    Messages:
    194
    Likes Received:
    0
    GPU:
    Power Color 4870 1GB PCS+
    Loved them with ME2, cut scenes nice and smooth but Video not working (watching movies etc) with these so back to 10.2 for now.

    Looking forward to a stable release of 10.3 though.
     
  3. Bodar

    Bodar Ancient Guru

    Messages:
    2,395
    Likes Received:
    0
    GPU:
    Lots of Fermi'zzzz
    I hav'nt tried these drivers on anything but browsing the internet... They seem to be stable and great though! Maybe I'll try a video or a game or two.. :) They work on guru3d.com and that's all that counts. :)
     
  4. Kefran

    Kefran New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    ATi 5970 @875/1250
    Hello all,
    My first post on this forum.

    I tested the 10.3pre on my 5970+eyefinity (3*1680*1050) set-up. My results are:

    1/ Black screen/grey screen: No issue
    2/ Games crashing prior 10.3pre:
    - NFS shift: still crashing
    3/ Bezel management (new resolution 5292*1050):
    - Ok on desktop
    - Ok on Batman AA
    - Ok on GTA4
    - Crashes on Dirt 2.
    4/ Performance
    - little boost on tested games
     
    Last edited: Feb 25, 2010

  5. Covert

    Covert Maha Guru

    Messages:
    1,187
    Likes Received:
    0
    GPU:
    Asus HD 5770 1000/1300

    Same here mate, but according to some ive failed to install the 10.3 drivers because i gained fps but lost picture quality (Shimmering) but i even went a couple ofsteps further.

    i downloaded driver
    i uninstalled Cat 10.2 completly
    i restarted into safe mode
    i ran Driver sweeper
    i restarted
    i then ran CCleaner.
    i then Installed 10.3 drivers.

    im sorry but can somone tell me what im doing wrong ?

    please run Haven in your native reZ with default DX11 4x Anisotropy.

    and see the shimmering, dont be blind to it its there..........lol

    But Cat 10.2 doesnt have the shimmering but its also got a lower fps aswell.

    put 2 and 2 together and make 4 :)
     
  6. Kovoet

    Kovoet Member Guru

    Messages:
    164
    Likes Received:
    5
    GPU:
    Gigabyte 3080Ti
    I think I will stick ith 10.2 at the moment as in game and photoshop it works perfectly
     
  7. Ripshod

    Ripshod Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    HIS HD7950 FAN 3GB
    10.2s suck big time. Thanks people!!

    *edit*

    Scrub that, gone back to 10.1s.
    could not get my Sapphire HD5770 Vapor-x installed on Vista Ult x64. Tried the usual process and also tried driver update from device manager. No go.
     
    Last edited: Feb 25, 2010
  8. gor1l1a

    gor1l1a Active Member

    Messages:
    98
    Likes Received:
    0
    GPU:
    EVGA GTX 680 Superclocked
    From what I'm reading should I skip the Driver Sweeper portion of my usual process and just upgrade from 10.2?
     
  9. Ti3Kob

    Ti3Kob Master Guru

    Messages:
    682
    Likes Received:
    1
    GPU:
    980Ti @1505/7600
    If you are under Windows 7, you can skip Driver Sweeper.
    You can just upgrade, or uninstall first with the ATI uninstaller, then uninstall+delete old driver in the device manager, and then clean install.

    Just try and see what is the best for you and on your system.
    I'm using the second way to avoid any problem though.
     
  10. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    You just added some unnecessary steps. driver sweeper? Ccleaner? lol
     

  11. scorpeeon

    scorpeeon Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    ATI Mobility/HD 4670/1 GB
    FYI Flash Player 10.1 (gpu accelerated) beta 3 has been released.
     
  12. gor1l1a

    gor1l1a Active Member

    Messages:
    98
    Likes Received:
    0
    GPU:
    EVGA GTX 680 Superclocked
    Don't mess with me Bodar lets hear some benches with the quad setup. :)
     
  13. Razorrig

    Razorrig Banned

    Messages:
    312
    Likes Received:
    0
    GPU:
    HD 5870 Xfire 1025mhz
    And whats wrong with that? I have been using that same method for years now and always find it funny when im not having any of the issues that a lot of other guys claim to have every time they update their drivers.
     
  14. LinkDrive

    LinkDrive Ancient Guru

    Messages:
    4,675
    Likes Received:
    0
    GPU:
    Toaster
    There's no need for driver sweeper. From what I've seen from actually working with driver sweeper, and through others who have used it, the program is prone to cause more issues than what it claims to fix. There's a reason why ATI and nVidia drivers come with their own uninstaller. :thumbup:
     
  15. Sevenz

    Sevenz Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    ATI HD4870 512MB
    Thanks for the info, I was just checking last night and didn't see it. :)
     

  16. BlauweTulp

    BlauweTulp Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    5870 1GB
    In NFS Shift, try to set the track detail to 'Low'. It fixed the crashes for me just before beginning the race when using Eyefinity resolutions.
     
  17. Razorrig

    Razorrig Banned

    Messages:
    312
    Likes Received:
    0
    GPU:
    HD 5870 Xfire 1025mhz
    Like I said, I have been using them for years and have not had a minutes trouble with them.


    And BTW neither ATI's or Nvidia's uninstaller removes everything.
     
  18. Bodar

    Bodar Ancient Guru

    Messages:
    2,395
    Likes Received:
    0
    GPU:
    Lots of Fermi'zzzz
    I have some feedback... How about red artifacts while using 3-way crossfire.. Rolled back to 10.2 and has'nt happened since..
     
  19. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    Doesn't cross to your mind that maybe there is a reason for it? but what do ATI or Nvidia know anyway, right?
     
  20. Razorrig

    Razorrig Banned

    Messages:
    312
    Likes Received:
    0
    GPU:
    HD 5870 Xfire 1025mhz
    I have heard this arguement before and this is my answere. Are those left over files in place when you reformat your HD and install the drivers for the very first time? nope, they are not and therefore they are not needed.

    Again, every driver update that comes out there are 50 post or so right after complaining of all these so called issues which I never have neither do any of my friends who have been using this same method now for years and until I have issues I will continue to stick to this method.
     

Share This Page