Cat 6.3 is out...

Discussion in 'Videocards - AMD Radeon Drivers Section' started by CraptacularOne, Mar 8, 2006.

  1. reggis

    reggis Active Member

    Messages:
    63
    Likes Received:
    0
    GPU:
    4870x2 and 4870 crossfire
    I see the main page has 6.3 -- but link goes to 6.2 for me (2/9/2006) :( Soon to be fixed I am sure ...

    Update

    link fixed :)

    Performance Improvements

    As with most Catalyst® releases, performance has increased in various situations.

    * 3DMark05: Pixel Shader test runs as much as 1-2% faster, primarily when Anisotropic Filtering is enabled
    * Call of Duty 2: Framerates are up 5-10% on the enthusiast-class ATI Radeon® X1800 and ATI Radeon® X1900 products

    Issues Resolved in Catalyst® Software Suite 6.3

    The following section provides a summary of the issues that are resolved in the latest release of Catalyst®. These include:

    * 3DMark06: Setting the display to 2560x1600 with AA set to 4x no longer results in graphic corruption being noticed when running the HDR tests. Further details on this resolved issue can be found in topic number 737-21768
    * Battlefield 2: The game no longer exit to the Windows desktop after the game logo is displayed. Further details on this resolved issue can be found in topic number 737-21660
    * City of Heroes: Running the Shadertest 7 no longer results in slow performance being noticed. Further details on this resolved issue can be found in topic number 737-21463
    * Far Cry: High Dynamic Range (HDR) corruption is no longer noticed when HDR is enabled. Further details on this resolved issue can be found in topic number 737-21762
    * Need for Speed: Most Wanted: Playing the game on a system containing an ATI Radeon® X1800 series no longer results in the operating system failing to respond after an extended period of game play. Further details on this resolved issue can be found in topic number 737-21769
    * Quake 4: Connecting a secondary display device and enabling extended desktop no longer results in the game failing to respond when switching between notepad and the game. Further details on this resolved issue can be found in topic number 737-21771
    * Serious Sam 2 Demo: Enabling CrossFire™ no longer result in a performance drop being noticed when playing the game under Windows XP Media Center Edition. Further details on this resolved issue can be found in topic number 737-20976
    * Serious Sam 2: Two directdraw samples are no longer displayed as blank screens. Further details on this resolved issue can be found in topic number 737-21748
    * The Fall: VPU Recover message is no longer displayed when playing the game on systems containing either an ATI Radeon® 9600, 9700 or 9800 products. Further details on this resolved issue can be found in topic number 737-21766
    * Tiger Woods 2005 and 2006: Playing the game with CrossFire™ enabled no longer results in a checkerboard type corruption being noticed. Further details on this resolved issue can be found in topic number 737-21764
    * World of Warcraft: Changing the multisample setting no longer results in display corruption being noticed when using an ATI Radeon® X1600 product. Further details on this resolved issue can be found in topic number 737-21770
    * Setting the display device to a resolution of 1024x768 or higher no longer results in the (PAL) TV image becoming unstable when moving the mouse. Further details on this resolved issue can be found in topic number 737-21664
    * Catalyst® Control Center: Clicking on the 3D aspect no longer results in an error message being displayed indicating that Preview.exe has generated errors and will be closed by Windows. Further details on this resolved issue can be found in topic number 737-21662
    * The Setup Video Playback dialog box no longer fails to appear when clicking on the Finish button. Further details on this resolved issue can be found in topic number 737-21737
    * Catalyst® Control Center: The desktop status for the CRT and LCD are no longer changed when exiting the Catalyst® Control Center and then relaunching the Catalyst® Control Center. Further details on this resolved issue can be found in topic number 737-21738
    * Catalyst® Control Center: Placing an ATI Radeon® X800 GTO PCIe in a system containing an ATI Xpress 200 series no longer results in the Disable/Enable button and the Pause button not being available in the 3D Quality and Performance Settings. Further details on this resolved issue can be found in topic number 737-21739
    * Disconnecting a CRT and a TV from a system containing an ATI Xpress 200 series no longer results in the CRT and TV still being available in the Display Manager once a mode change is completed. Further details on this resolved issue can be found in topic number 737-21740
    * The help button is no longer greyed out in the Edit Custom View aspect found in the Catalyst® Control Center. Further details on this resolved issue can be found in topic number 737-21741
    * The image for extended desktop and clone mode are no longer reversed when connecting an external monitor and entering the Basic view in the Catalyst® Control Center. Further details on this resolved issue can be found in topic number 737-21742
    * Making a change within the Standard settings found in the Catalyst® Control Center no longer results in the setting failing to be retained when exiting the Catalyst® Control Center and then re-launching the Catalyst® Control Center. Further details on this resolved issue can be found in topic number 737-21743
    * The Disable, Enable, and Pause buttons are now displayed in the 3D Quality and Performance Settings for the ATI Radeon® Xpress 200 series adapter when the system contains an add-in ATI Radeon® PCIe product. Further details on this resolved issue can be found in topic number 737-21744
    * Disconnecting a CRT and or TV and restarting the system no longer results in the CRT and TV display devices becoming available after changing the display resolution. Further details on this resolved issue can be found in topic number 737-21745
    * Catalyst® Control Center: Connecting an LCD display device as the primary and a CRT as the secondary display device no longer results in the Set up my Display Configuration wizard disappearing. Further details on this resolved issue can be found in topic number 737-21746
    * Catalyst® Control Center: Changing the gamma, brightness, and contrast no longer results in the Apply button still being active after the reboot of the system. Further details on this resolved issue can be found in topic number 737-21747
    * Catalyst® Control Center: Entering the OverDrive aspect and attempting to use the automated clock configuration diagnostic to obtain the ATI recommended speeds for the engine and memory no longer results in the engine and memory clock not changing. Further details on this resolved issue can be found in topic number 737-21749
    * Catalyst® Control Center: Connecting a display device that supports 1080i no longer results in the 1080i display mode failing to be applied. Further details on this resolved issue can be found in topic number 737-21750
    * Color corruption is no longer noticed when enabling the Reduce DVI Frequency on High-Resolution Display found in the Catalyst® Control Center when playing a DVD with Theater mode enabled. Further details on this resolved issue can be found in topic number 737-21751
    * Connecting an HDTV followed by playing an MPEG or AVI file using the Windows Media Player no longer results in the video file failing to be played back on the secondary display device. Further details on this resolved issue can be found in topic number 737-21752
    * Connecting a CRT as the primary display device and an HDTV as the secondary display device no longer results in display corruption being noticed on the HDTV when setting the HDTV 1080i in the Catalyst® Control Center and enabling Overlay Theater Mode. Further details on this resolved issue can be found in topic number 737-21753
    * Catalyst® Control Center: Selecting system skin and the German language no longer results in the text being cut off within the Adjustment aspect page. Further details on this resolved issue can be found in topic number 737-21754
    * Catalyst® Control Center: Selecting Russian as the language no longer results in the text for the secondary display device being cut off within the De-interlacing aspect page. Further details on this resolved issue can be found in topic number 737-21755
    * Catalyst® Control Center: Selecting Magyar as the language no longer results in text being cut off within the 3D - All Setting aspect page. Further details on this resolved issue can be found in topic number 737-21756
    * Catalyst® Control Center: The confirm changes dialog box no longer repeatedly appears when selecting No to changes. Further details on this resolved issue can be found in topic number 737-21757
    * France is now listed in the pull down menu for the Country option when selecting the TV out standard. Further details on this resolved issue can be found in topic number 737-21758
    * Resuming from a standby state no longer results in corruption being noticed on the lower half of the display, or the lower half of the display remaining blank when CrossFire™ is enabled. Further details on this resolved issue can be found in topic number 737-21759
    * Enabling CrossFire™ under the Windows Media Center Edition operating system no longer results in closed captioning failing to function. Further details on this resolved issue can be found in topic number 737-21760
    * Catalyst® Control Center: Display corruption is no longer noticed on the secondary display device when enabling clone mode. Further details on this resolved issue can be found in topic number 737-21761
    * Horizontal large desktop modes are no longer reported in the Display properties after switching from horizontal to vertical large desktop mode. Further details on this resolved issue can be found in topic number 737-21763
    * Deselecting the Use Extended Display Identification Data (EDID) or driver defaults no longer results in the operating system rebooting when setting the maximum refresh rate and resolution for the display device connected. Further details on this resolved issue can be found in topic number 737-21765
    * Connecting an HDTV to an ATI Radeon® X1300 series product no longer results in the display failing to apply the proper underscan mode for 1080i or720p. Further details on this resolved issue can be found in topic number 737-21767
     
    Last edited: Mar 8, 2006
  2. cheese06

    cheese06 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    X800 PRO 256 MB
    compared to the xg warcat 6.2 drivers, i get a decrease in performance. going back to the modified 6.2 drivers.
     
  3. WildStyle

    WildStyle Ancient Guru

    Messages:
    15,306
    Likes Received:
    20
    GPU:
    MSI GTX 970
    Downloading, will let you know how I get on.
     

  4. M_Math

    M_Math New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    ATI X850XT 256
    A link to these please. I have a x850xt and see no reason to upgrade so far as i see no info on any changes to the x850xt
     
  5. SniperDaws

    SniperDaws Banned

    Messages:
    2,565
    Likes Received:
    0
    GPU:
    XFX7600GTXXX Zalman Vf900
    Well ATI's site is being hammered, 64kb/s is fastest upto now for me, ill give em a go with my ageing old 9700pro and let you know how they are.
     
  6. Razoola

    Razoola Member Guru

    Messages:
    125
    Likes Received:
    2
    GPU:
    GTX980 (MSI gaming)
    Overlay Theater Mode Enhancement....

    I have read about this in the 6.3 release notes yet I do not see any such option in the ccc in the overlay settings. I have a 9800pro can anyone help me out?
     
  7. Kon$olE

    Kon$olE Ancient Guru

    Messages:
    3,901
    Likes Received:
    2
    GPU:
    Zotac GTX 1070
    Man, i hate having to always update drivers... so hard when the computer that needs them doesnt have internet.

    Also, it kinda sucks that there not revising the drivers for the 8XX cards anymore, but i they focus more on the X1K's. Its understandable, but i want beter FPS in quake and SS2, and BF2 and such as well!
     
  8. Hey, any Xk1 series (X1800 & X1900) card owners getting a jump in performance? Have yet to see any other powerhouse cards try these out. Though I hope this time ATI decided to give ATI X8XX series cards and below some love this time too.
     
    Last edited by a moderator: Mar 8, 2006
  9. WildStyle

    WildStyle Ancient Guru

    Messages:
    15,306
    Likes Received:
    20
    GPU:
    MSI GTX 970
    Nope, same scores all around, can't tell a difference in games either.

    I was hoping to get a boost from these as that's been the ongoing trend, but I haven't.
     

  10. Hmm, that's dissapointing. I got about 270 pts more in 06 with these, and a 330pt jump in 05.
     
  11. cheese06

    cheese06 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    X800 PRO 256 MB
    you could have googled but ill do the easy work for ya. :)

    *Edited by Wild*

    URL is filtered for a reason, please use PM.
     
    Last edited by a moderator: Mar 8, 2006
  12. SniperDaws

    SniperDaws Banned

    Messages:
    2,565
    Likes Received:
    0
    GPU:
    XFX7600GTXXX Zalman Vf900
    Running fine on my 9700pro, i cant tell any diffrence from the 6.2's though.
     
  13. Jkhan

    Jkhan Guest

    Is it me or does everyone notice how everytime a new driver is released, there are more unresolved issue than fixed ones, especially the ones with x800 series :mad:... grrrr.... 1st they force you to use the stupid CCC, then they leave you to rot with lame driver support :mad:..
     
  14. EnzoF1

    EnzoF1 Master Guru

    Messages:
    237
    Likes Received:
    0
    GPU:
    X1800XT 512mb (Aquaxtreme MP-1)
    Well i dont think that il even try it. I think that the x8xx series cards have reached a stage where they are just about stable. Unless i hear of some miracle story of a x8xxx card jumping 400 points in 3d mark. I think im fine where i am.
     

  15. ROBSCIX

    ROBSCIX Ancient Guru

    Messages:
    16,241
    Likes Received:
    8
    GPU:
    22" LCD on GTX260 C216
    Anyone using them on AIW cards? any noticable improvments? I don't like to mess with a working system. Thx for info guys..
     
  16. manson

    manson Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    EVGA 8800 GT SC
    :frown: waiting for softmod 6.3 or omega 6.3.why?i cant unlock the pipes with this drivers
     
  17. MetalFox

    MetalFox Master Guru

    Messages:
    907
    Likes Received:
    1
    GPU:
    GTX670 DCII
    Gotta try these.

    Well i'll try these out as usual.


    Yesterday i got about 1900 points in 3dmark06, something is lil' screwed :)
    well its maybe because im currently tingering with OC. but let's see how these affect things.
     
  18. Jattmon

    Jattmon New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    geforce 8
    on my 1600 pro 512mb, theres been an amazing difference!!!!!!
    3dmark scores are about the same, but in game fps are nearly doubled on some games, i think they must have reprogrammed memory usage maybe.

    on speedtree on areas which used to get average aorund 20-30 fps are getting 50-60 fps.

    other games include black an white 2, age of empires 3

    havent tried other yet.

    AA and anisotropic filtering are taking much less of a toll on negame!!!!

    shame reviews werent done with this driver
     
  19. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    i think you just installed them correctly this time :D.
    Anyways i cant seem to find a download for catalyst 6.3 CCC theres only MCE on gurus homepage for winxp.
    And ati homepage download section seems to be down allso. So if someone knows links, paste them please :p
     

Share This Page