Castlevania lord of shadow coming on steam

Discussion in 'Games, Gaming & Game-demos' started by prodigalson1, Mar 18, 2013.

  1. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,916
    Likes Received:
    1,763
    GPU:
    GTX1070 iChillx4
    thats the light power (giving health when attacking enemy) and shadow power (more damage). its also used for puzzles. (pretty straightforward though lol)
     
  2. Mr.Bigtime

    Mr.Bigtime Ancient Guru

    Messages:
    20,794
    Likes Received:
    8
    GPU:
    ASUS 1080TI
    sin the video the player can attach his chain and swing etc. doenst work on me. i press Right trigger and nothing happens. and at the same level i dont have that blue red powers.
     
  3. PNeV

    PNeV Ancient Guru

    Messages:
    2,069
    Likes Received:
    2
    GPU:
    MSI GTX 1070 Armor
    Health & Mana duh :p
     
  4. RecluSe

    RecluSe Master Guru

    Messages:
    885
    Likes Received:
    0
    GPU:
    EVGA GTX 980 SC/ACX 2.0
    I wouldn't worry about the powers, he's playing on New game plus I think. As for not being able to use Gabriel's combat cross have you tried RB?
     

  5. Mr.Bigtime

    Mr.Bigtime Ancient Guru

    Messages:
    20,794
    Likes Received:
    8
    GPU:
    ASUS 1080TI
    meant blue :D
    it worked after i restart the game and on screen commands..odd. thanx for info all.
     
  6. JaylumX

    JaylumX Master Guru

    Messages:
    561
    Likes Received:
    20
    GPU:
    RTX 2070 Super
    For those of you not getting the world map during gameplay. Unfortunately if you are far into the game, it means starting again but big shoutout to Golem on the Steam forums

     
  7. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,033
    Likes Received:
    554
    GPU:
    EVGA GTX 1080 Ti SC2
    This game has some very strange bugs from minor ones such as flickering only during the pre-rendered FMV cutscenes to a glitch with the checkpoints which return me to a screen that says Restart Checkpoint instead of moving on to the next part of the game. At one point I got the book showing in the middle of the screen while I could hear the next cutscene audio playing in the background but I couldn't access the menu or anything. Ended up having to exit the game with Alt-F4 but fortunately I didn't lose any progress as the game auto-saved just before the Metal Guardian fight at the end of Chapter II (after fighting the second Titan). The game also auto-checkpointed at a point where I died, meaning that I kept respawning during a fall and dying again. I had to exit the game and restart to resolve it.

    A good game but I'm a little concerned about these glitches as they never occurred in the PS3 version.
     
    Last edited: Aug 29, 2013
  8. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,288
    Likes Received:
    6
    GPU:
    MSI R9 390X 1178|6350
    SLI has flickering, artifacts, etc which is killing the performance for me. I want to play this game, does rolling back a driver help?

    How are people resolving this issue?

    p.s. need sli to maintain smooth frames at 3k(3072x1728)
     
  9. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,033
    Likes Received:
    554
    GPU:
    EVGA GTX 1080 Ti SC2
    The 326.80 beta drivers I'm using already have a SLI profile for this game and uses the following SLI flag: 0x02402005.
     
  10. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,288
    Likes Received:
    6
    GPU:
    MSI R9 390X 1178|6350
    Running 326.80 here. Those same bits are causing artifacting(green) and flickering for me. Nvidia profile has AFR2 enabled by default as well. Probably a problem on my end?

    But then again no other game I ran with SLI has this problem.

    Though beginning to see the quality of this port. Only the first level ran below 30fps, otherwise the further missions were above 40fps, and fought the titan at 35fps. Wonderful optimization is wonderful. Seems a single 560Ti still got some punch in it.
     

  11. prodigalson1

    prodigalson1 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    3 x gtx titan
    probably you put a anti aliasing flag.

    same probleme, don't work for me in sli and AA flag
     
  12. vejn

    vejn Maha Guru

    Messages:
    1,002
    Likes Received:
    0
    GPU:
    MSI 7870 TF3
    There is a hole in the wall but I can't go through(invisible texture) or when I go through nothing happens. How to fix it?
     
  13. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,033
    Likes Received:
    554
    GPU:
    EVGA GTX 1080 Ti SC2
    Do you see the green flickering only in the videos? I'm using forced AA using an NVIDIA flag of 0x000012C0 with the 326.80 drivers. Is that causing it then (I'll try turning it off and see if the videos still have this annoying green flickering every five seconds or so)?
     
  14. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,288
    Likes Received:
    6
    GPU:
    MSI R9 390X 1178|6350
    Videos, Menu, and even gameplay has that annoying flicker.

    Its as if you can see the frames rendering alternately with a speed of 1 second per frame, however the framerate still shows 60~80fps. Totally clueless here.

    What I do know is, its an SLI issue. And there is no AA flag. I made a fresh profile and added the executable, removing it from its old profile. Simply enabling AFR2 brings back the flickering. Even putting the bits without touching anything also bring the flickering back. Are you all playing fine in SLI?

    Then it must be a problem on my end, a weird one at that.
     
  15. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,033
    Likes Received:
    554
    GPU:
    EVGA GTX 1080 Ti SC2
    @ nanogenesis - I'm not using SLI though, just a single GTX 780, so it definitely is NOT just a SLI issue.
     

  16. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,288
    Likes Received:
    6
    GPU:
    MSI R9 390X 1178|6350
    Well, after disabling SLI, even the normal pre-rendered cutscenes just run fine. No sort of flicker or anything on my side.
     
  17. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,033
    Likes Received:
    554
    GPU:
    EVGA GTX 1080 Ti SC2
    71.5 MB update for Castlevania: LoS... anyone know what it fixes? Hopefully the flickering video and other bugs I've encountered up to Chapter III?
     
  18. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,465
    Likes Received:
    2,852
    GPU:
    MSI 6800 "Vanilla"
    No idea but I'm checking, seems it altered the exe and one of the data files. :)
     
  19. HitokiriX

    HitokiriX Master Guru

    Messages:
    285
    Likes Received:
    10
    GPU:
    Nvidia GTX 1070

    on the steam forums people are reporting the world map bug has been fixed other than that nobody's sure if anything else has been fixed so far
     
  20. N1GhTW4lK3R

    N1GhTW4lK3R Master Guru

    Messages:
    598
    Likes Received:
    0
    GPU:
    SLI 980Ti
    Game Crash with resolution 2160p...any solution?
     

Share This Page