Captured video stutters

Discussion in 'MSI AfterBurner Overclock Application Discussion' started by Artur, Dec 7, 2012.

  1. Artur

    Artur New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI R7850 PE 2GD5
    I used Afterburner v2.3 for video capture only, without OC. The captured video stutters with games like Mass Effect 2 and 3. Monitor resolution is 1366x768, target frame size is 1280x720. Codec x264, but tried RTV1 and MJPEG too, both 90% quality, same "dance effect".

    Tried 30fps game limit x 30fps capture, 60x30, 60x60. Last one is a little less choppy than 30x30 - two times more frames to encode, to write to hdd, and such a result?

    Settings attached as screenshots:

    [​IMG]
    [​IMG]
    [​IMG]

    Below video captured with Afterburner:
    264_ultrafast_game30_capture30_compress
    264_ultrafast_game60_capture30_compress
    264_ultrafast_game60_capture60_compress

    What would you suggest?
     
  2. Woxenrud

    Woxenrud Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    AMD 6970
    In your x264vfw settings, Ratefactor is set to 1. Try change it to 15 or higher
     
  3. Artur

    Artur New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI R7850 PE 2GD5
    I tried ratefactor 15, then 30 and 10. Same stuttering, just file size varies. The next test was to increase capture fps to 60. Still stutters, but less than at 30 fps capturing.
     
  4. Catamaytryc

    Catamaytryc New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    2x EVGA GTX 680 2GB
    Yeah, 30 - 30 is pretty bad. You're right though 30 - 60 and 60 - 60 are better. I agree with Woxenrud, the Ratefactor was way too low.

    Do you have anything checked in "Monitoring"? I don't know how much monitoring impacts system resources but I have everything off. It may not make any difference.

    I haven't tried this for encoding, only rendering, but it couldn't hurt to test it. Set x264vfw to "Single pass - bitrate-based (ABR)" with a value between 8000 (lower quality) and 16000 (higher quality).

    The only other thing I can think of is to set the "On-Screen Display rendering mode" to "Vector 3D" since it says it has less utilization but may not be compatible with all games.
     

  5. Artur

    Artur New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI R7850 PE 2GD5
    Thanks, I tried these settings, the result was similar to previous ones, maybe a bit less stuttering.

    I wonder if video lag depends on Mass Effect engine rather, than on computer performance. Capturing Witcher 2, same AfterBurner settings: gameplay fps drops about 30%, but no stuttering occurs, despite a "little" higher game requirements.

    Enabling/disabling compatibility with modified Direct3D runtime libraries makes no difference.
     

Share This Page