Can't install the driver

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by lmihai2oo6, Aug 26, 2010.

  1. lmihai2oo6

    lmihai2oo6 Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    ASUS EAH4770 FORMULA
    Today I started to have a problem. I had driver 10.6 installed and everything worked ok but I tried to install the 10.8 driver and everything started to go crazy. My ATI Install Manager dosen't detect the driver and ATI Catalyst Control Center. I use DriverSweeper but nothing. Now I use the driver that is coming through Windows Update.

    My videocard is 6 mouths old and I didn't OC or something else :(

    Thank you for any support you can offer to me.
     
  2. lmihai2oo6

    lmihai2oo6 Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    ASUS EAH4770 FORMULA
    Thanks to this guy my problem is gone. Thank you again :D
     
  3. Enmity

    Enmity Maha Guru

    Messages:
    1,303
    Likes Received:
    0
    GPU:
    EVGA 1080ti FE SLI
    So back up a little, did you install over the top of your 10.6's? or did you driver sweep from the beginning?

    Honestly, i've stopped using driver sweeper for ati cards, i've had it mess up things too often. Have you tried uninstalling your drivers through device manager? if not, give that a go, reboot then try the installation of 10.8 from there.

    Theres a possibility driver sweeper has screwed someing with your OS, some time back I had a problem where I could only play games in dx9, not dx10 or 11...this was caused by two things, betas drivers and/or driver sweeper. I had to reinstall all of my Microsoft C++ files to fix this. Perhaps those same files are at fault for you.
     
  4. Enmity

    Enmity Maha Guru

    Messages:
    1,303
    Likes Received:
    0
    GPU:
    EVGA 1080ti FE SLI
    oh excellent, good stuff. thats a good trick he showed you, it will only work for single gpu systems though. Glad you got it sorted mate :)
     

  5. lmihai2oo6

    lmihai2oo6 Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    ASUS EAH4770 FORMULA
    Thank you

    I had uninstalled the driver from device manager using express uninstall and then bot to safe mode and use driver sweeper. I tried to reinstall some c++ but nothing worked. I know that, this solution is just a work around but i can leave with that until i will reinstall my OS.

    Thank you all :D
     

Share This Page