cant install driver, HELP PLEASE !

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kayelkay, Nov 18, 2011.

  1. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb
    hi,

    I own a Toshiba A300 notebook with an ATI Radeon mobility HD 3470 installed on. I've been trying to update my driver for the display card but each time when trying to install i get a message saying:

    AMD Catalyst Mobility cannot be downloaded due to incompatible hardware/software on your computer.

    The version of your graphics is not supported.

    Also I've had my laptop reformatted at a shop. Before i reformatted my graphics card was fine, i used to be able to play Starcraft 2 with no lag. I'm trying to fix this problem now. If anyone can help, please. I am an idiot with these type of things :(
     
  2. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb
    apparently now i have installed the 11.11 version. But i cant seem to find the Catalyst Control Centre. So i'm not sure whether it is installed or not.
     
  3. Soulight

    Soulight New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    HD 5650
    try executing CCC.exe
     
  4. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    Which version of windows are you on? Some people report XP having issues not recognising their card and suggest trying the PC version instead of the mobile. Have you tried using AMD's automated detect and install program?

    http://support.amd.com/us/gpudownload/Pages/index.aspx

    Otherwise, are you sure you got the correct drivers? A300 is the satellite model?

    http://eu.computers.toshiba-europe.com/innovation/download_drivers_bios.jsp?service=EU

    Try uninstalling "all amd software" option in the add remove programs for amd catalyst if it is there then restarting and reinstalling the amd desktop one if you've already tried the toshiba one. Otherwise try the amd detect and install? perhaps even before the desktop one (advice given at hardwareheaven for the win xp).
     
    Last edited: Nov 18, 2011

  5. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb
    there is no ccc.exe to execute..
     
  6. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb

    Im on Windows Vista and the automated detector driver is the one i tried that wouldn't install. I've also tried the Toshiba one. Do you think i should uninstall all my drivers and try again? is there any suggestions on how i could do that aswell? because i tried uninstalling then using driver cleaner.. i resulted in a Blue screen of death and i had to go to a restore point to fix the problem.
     
  7. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    I do think you should uninstall and try again. I always uninstall using the amd uninstaller, select complete uninstall & restart between installations. I gave up on extra software except for CCleaner's registery cleaner after the uninstall.

    You sure you picked the right version in the toshiba drop down, seems there are a ton of different versions. Make sure to disable antivirus during the installation and just generally turn off anything unrelated. Can even uninstall and install in safe mode to be ultra safe :)
     
    Last edited: Nov 18, 2011
  8. elpsychodiablo

    elpsychodiablo Master Guru

    Messages:
    349
    Likes Received:
    0
    GPU:
    Retina Z2 + Vlab Motion
    Uninstall Ati Driver
    restart
    use atimen uninstaller
    restart
    encrypt ati ati driver
    use ati mobility modder to the encrypted folder
    install modded driver
    restart
    enjoy and sorry for bad english.
     
  9. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    by encrypt i think he means unarchive (can use 7-zip) and i think there is a modded ati mobility driver he is suggesting you can try. He signed up just to tell you so that's quite nice, might of had similar troubles?

    google "ati mobility modded", the site automatically censors the link for some reason.
     
    Last edited: Nov 18, 2011
  10. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb
    "AMD Catalyst Install Manager" this is all i found in my control panel's "uninstall/change programs". Should i uninstall that.

    Also is the ATI mobility modder the same thing as mobility modder from driver heaven? http://www.*******************/modtool.php

    and Mangaroo,

    this is what i downloaded from the AMD site: http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-32.aspx which i mentioned before and didnt work.

    http://eu.computers.toshiba-europe.com/innovation/download_drivers_bios.jsp?service=EU and this is what i checked just then from the toshiba website.

    what i just installed was from this website
    http://forums.guru3d.com/showthread.php?t=354066 and it said it installed but i dont see any proof of it being installed.

    thanks
     

  11. mangaroo

    mangaroo Master Guru

    Messages:
    382
    Likes Received:
    0
    GPU:
    780 GTX Ti SC
    the modder is the same i think.

    the file you linked from the amd says windows 7 and unfortunately the toshiba settings dont transfer.

    try the modtool and yes just uninstall using amd catalyst in control panel uninstall programs. i recommend ccleaner too (the registery fix tab).
     
  12. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb
    well i have done as said. uninstalled, reinstalled, using all the listed programs.

    Now there is a catalyst control centre in my All Programs list in start menu. But when i try to open it, it closes straight away.

    Any ideas?
     
  13. xacid0

    xacid0 Master Guru

    Messages:
    441
    Likes Received:
    1
    GPU:
    Zotac GTX980Ti AMP! Omega
    try manually install it.. go to ..\Packages\Apps\CCC2\Core-Static of the extracted driver and right click on ccc-core-static.msi then select Repair
     
  14. elpsychodiablo

    elpsychodiablo Master Guru

    Messages:
    349
    Likes Received:
    0
    GPU:
    Retina Z2 + Vlab Motion
  15. kayelkay

    kayelkay New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD3470 256mb
    Well it seems as if i was able to update by uninstalling everything and installing the driver on the Toshiba Website. Then i was able to get CCC working by googling this:

    "Originally Posted by Chythar
    This is an old thread, but it's one of the top search results for "ccc won't run" so I wanted to post another possible solution here. My solution was to clear out the Windows GAC (Global Assembly Cache). In Windows 7, you can browse directly to "C:\Windows\assembly". Sort by "Public Key Token", then delete everything with the Token "90ba9c70f846762e" (ATI's key). You'll obviously need Administrator privileges. No reboot needed either. Reinstalled CCC and it ran perfectly!

    The GAC lets you share DLL's that are the same version number. If it's in the GAC, any installer will NOT install a new DLL - it'll use the one in the GAC. If the GAC DLL is corrupted, you're majorly SOL.

    When I reinstalled the CCC, it took longer to install then it had before. Presumably, this was due to the installer copying all the correct DLL's to my hard drive. And no ATI DLL's have made it back into my GAC.

    To give credit to the original poster, here's the page I found this fix on:

    http://www.*******************/mobili...ol-center.html"

    HOWEVER.. my starcraft 2 seems to be laggier now.. before my reformat, sc2 would work perfectly, no lag. Now with settings all on low and highest performance, it still lags..
     

Share This Page