1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't install any video drivers other than standard VGA - "the driver selected for

Discussion in 'Videocards - AMD Radeon Drivers Section' started by boe, Sep 5, 2012.

  1. boe

    boe Member Guru

    Messages:
    154
    Likes Received:
    1
    GPU:
    PNY 980 TI
    Hello,

    I have a relatively new computer with an ATI 7570 card in it. I've tested the card on other computers and it works fine. I don't want to reformat the computer. It has a legit copy of Windows 7 x64 enterprise from MSDN on it.

    When I attempt to install new drivers direct from ATI or Dell it gets through the install but with errors - basically can't install the driver.

    I've tried uninstalling the standard video drive and installing the latest ATI and it won't let me. I'm definitely using Windows 7 x 64 and I'm definitely downloading the 64 bit driver. It doesn't find the 32 bit driver (tried that).

    When I manually select the device and driver, it starts the install but then comes back with the following message -

    Update Driver software - Standard VGA Graphics Adapter

    Windows encountered a problem installing the driver software for your device.

    Windows found driver software for your device but encountered an error while attempting to install it.

    AMD Radeon 7570

    The driver selected for this device does not support this version of Windows.



    I've even tried installing native windows ATI drivers manually and it still comes back with the same error even though I'm installing the drivers that are part of the OS.
     
  2. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    hmm..

    ok.. just as the computer boots... keep tapping F8 key... when the menu comes.. select the proper key for "Disable Driver Signature Enforcement" . . and let the system start.

    then try to install the X64 bit AMD driver back again... will do...
     
  3. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    1
    GPU:
    570m / MSI 660 Gaming OC
    any particular reason you're on enterprise instead of ultimate? drivers are done differently (also i remember someone modding for enterprise last year, either here or for sure on rage3d)
     
  4. LBJM

    LBJM Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    latest green team

  5. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Well maybe you downloaded for XP x64? I know it sounds stupid, but just saying.

    Also, when my old GPU died (finally), it had same behavior, i just couldn't install any driver, who, it was nVidia, but it should be the same.
     

Share This Page