Can't install any drivers.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by pha0x, Nov 23, 2011.

  1. pha0x

    pha0x New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI HD5570
    I simply can not install any ati drivers, the option to do so isn't there in the install package.

    [​IMG]

    This happens with any version I've tried, including 11.10, 11.08, 10.2, 10.5, 10.8
    I can only use drivers that windows xp automatically installs for me when I reboot after uninstalling drivers.

    What I have tried:
    Uninstall all drivers, using driver sweeper+cleaning registry with ccleaner afterwards(all in safe mode), reboot + install = nothing
    I also stopped windows xp from automatically installing drivers by renaming the folder in windows/system32 that has default drivers, thinking default drivers are the problem. nothing.

    GFX Card: ati hd 5570
    OS: windows xp 32 bit


    This just started happening lately, month or two ago my driver updates worked just fine, but I had been using 10.2 drivers for awhile before I decided to update(newer drivers had some compatibility issues with older games such as SoF2 where the game would crash on start up, but that doesnt matter really)


    any ideas?
    oh, system restore is out of question. i dont keep restore points at all.
     
    Last edited: Nov 23, 2011
  2. illprem

    illprem Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    6990
  3. pha0x

    pha0x New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI HD5570
    I tried driver sweeper and windows installer cleanup combo, no luck with this. I will try the method in BF3 topic mentioned tomorrow.
     
  4. pha0x

    pha0x New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI HD5570
    I just noticed weird thing:
    no matter how many cleaning utilities I used, there were always 3 files left from ATi
    [​IMG]

    ati2evxx.dll should be related to ati hotkey poller service, so I checked in services(or if its running in tskmgr - no) if I have it enabled or if the entry is there at all, but it wasn't. I had to delete ati2evxx.dll with killbox using restart option(otherwise it wouldn't work) and the other 2 could be deleted with simple delete key. restart->used driver sweeper to recheck for these 3 again(+ manually checked windows folders)=clean->install new drivers=fail again
     
    Last edited: Nov 23, 2011

  5. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,711
    Likes Received:
    681
    GPU:
    MSI 2070S X-Trio
    Tried extracting the drivers and installing it via the Device Manager (by pointing it to where you extracted, so it picks it up).

    Failing that, id just do a reinstall of windows. :)
     
  6. mrmonsoon

    mrmonsoon Master Guru

    Messages:
    697
    Likes Received:
    0
    GPU:
    Asus 7870+2509M+2511X
    here is link to ccc 11.11B performace driver-try it.
     
  7. Neo Cyrus

    Neo Cyrus Ancient Guru

    Messages:
    9,945
    Likes Received:
    733
    GPU:
    Asus TUF 3080 OC
  8. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    3
    GPU:
    RX VEGA 64 Liquid
    Navigate to the driver folder, go in the folder "Config", open the file "InstallManager.cfg" with a text editor such as notepad, edit this line from "WorkaroundInstall=false" to "WorkaroundInstall=true" go back to the driver root folder and launch "Setup.exe" now everything should appear in the install manager.
     

Share This Page